Home AOMEI Products Support

Backupper Pro amwrtdrv.sys causes system crash

I've been experiencing frequent systems crashes when Backupper Pro starts (and sometimes just after it finishes).

I'm using Backupper Pro 4.6.2 with Windows 10 Pro 1809 at current service level (KB4489899)

I have a Partition Incremental backup scheduled for 04:35 every day, using the AOMEI scheduler service.

Every other day a system crash, followed by reboot, occurs just after the backup starts, and the backup never completes. I suspect that the first backup after a reboot works, but subsequent backups fail, although I haven't had a chance to test this theory.

The WhoCrashed utility reports this crash is caused by the amwrtdrv.sys driver, shown below:

On Sat 23/03/2019 04:36:10 your computer crashed or a problem was reported
crash dump file: C:\WINDOWS\MEMORY.DMP
This was probably caused by the following module: amwrtdrv.sys (amwrtdrv+0x14D2)
Bugcheck code: 0xA (0x138, 0x2, 0x0, 0xFFFFF80058C9CB7A)
file path: C:\WINDOWS\system32\amwrtdrv.sys

I tried using the Windows Task Scheduler to run the daily backup and interestingly the backup completed successfully, but was followed immediately by a similar amwrtdrv.sys crash and reboot. 

Possibly not related, but I notice that the two versions of amwrtdrv.sys on my system have a slight difference. Both have a Created/Accessed date of 23 February 2019 (when I installed 4.6.2) and both have a Modified date of 01 September 2017.
But C:\Windows\System32\amwrtdrv.sys is 38,320 bytes
Whereas C:\Program FIles (x86)\AOMEI Backupper\driver\i386\amwrtdrv.sys is 34,864 bytes

Any, positive, suggestions?


  • edited March 2019
    I've posted this before but just to repeat for newer viewers. Backupper, for me also, has been creating 3 major errors which I contribute either to the 4.6.1 version and later or a conflict with Win 10 1809.

    1. Numerous, but random BSOD or complete PC lockups when running a scheduled backup.
    2. Disappearing Backup job definitions from home screen.
    3. VSS errors (which can be viewed in Windows Event Viewer) every time a backup runs. This also breaks the VSS function for other programs using VSS.

    I've stopped using Backupper until these problems have been fixed and noted as fixed in a future program update. I've notified both the admin here and tech support about these problems which as far as I'm concerned make the program unusable. I'm hoping these problems can be addressed as I was using Backupper for 2 years with great success in both creating backups and in restoring them. I'll remain positive and continue to try and help out whenever I can here on the forum, but product loyalty can only go so far.
  • Aomei.

    Eu não tenho esses problemas citados, mas não seria interessante lançar versões beta?
    Os usuários podem relatar o sucesso para você.
  • Flyer I am with you also. I have the Pro version of Aomei that I have been using for almost 3 years. I have abandoned the program for another backup program until Aomei can fix their problems. My backups are too important to me.
  • @vagn_32, all these problems have been reported by others in posts on this forum so I am not alone. I suggest you closely check your Windows event viewer for VSS errors that appear at every scheduled back up. My wife's PC was not blue screening or losing backup definition sets but she was getting the VSS errors. 
  • Flyer

    I don't do scheduled backups, my backups I do when I install some program or Windows updates.
    I suggested to Aomei betas versions for us users to help.
  • Aomei Backupper 4.6.3 Server Edition.
    If the task (partition incremental backup) is schedulled, immediately after start I have BSOD on Server 2016 Standard Edition.
    Examining MEMORY.DMP:

    On Sat 06.04.2019 21:00:23 your computer crashed or a problem was reported
    crash dump file: C:\WINDOWS\MEMORY.DMP
    This was probably caused by the following module: amwrtdrv.sys (amwrtdrv+0x14D2)
    Bugcheck code: 0xA (0x138, 0x2, 0x0, 0xFFFFF80188EC4F2F)
    Bug check description: This indicates that Microsoft Windows or a kernel-mode driver accessed paged memory at DISPATCH_LEVEL or above. This is a software bug.
    This bug check belongs to the crash dump test that you have performed with WhoCrashed or other software. It means that a crash dump file was properly written out.
    A third party driver was identified as the probable root cause of this system error. It is suggested you look for an update for the following driver: amwrtdrv.sys .
    Google query: amwrtdrv.sys IRQL_NOT_LESS_OR_EQUAL

    If the task is launched manually, everything is ok.
    So this is a very serious bug for Aomei!!
  • @testerics Please try the second option to see if it works.

  • Thank you for your answer, but I already tried in both way. The result is the same: if the task is launched manually, everything is ok. If the task is launched by scheduller, I have BSOD and server is restarting.
  • I use AOMEI Backupper Pro for quite a while now on Windows 8.1. For some weeks it causes a BSOD when it starts a scheduled backup. Not every time but most of the time. It's very annoying. Also all backups disappear from the Home screen after the crash, so if you did not export them, you have to create them again. The support can't help and only tells me to use an older version. That's not helpful.

    Why does it take MONTHS to locate and solve the problem??
  • Can wait another 4 months! I've never seen so much delay
  • Same problem here.
    I can't believe I paid money for this trash, BSOD on every other scheduled backup, disappearing backup jobs, manual backups working just fine. Please fix this, it is super annoying and renders this software almost useless because no longer reliable.
  • @admin switching to the built-in technique doesn't help here either.
  • I have to say Aomei support keeps on disappointing. I sought help with the same/similar symptoms as all other posts.
    Aomei never replied despite me having forwarded a "WhoCrashed"  dump analysis with my request.

    When I got no response after more than a week I emailed again. After a few days  I got a pathetic response from someone saying he was sorry but the support people were still looking and he hoped they would find something.

    Another couple of weeks with no advice from Aomei  and I ask again and (the same guy) emails back saying support want me to send a list of all programs I have installed so they can check if I have any out of date drivers.

    I write back asking them to give me a break, get support to advise precisely what information they required, and with which tool did they want it to be reproduced - what an insulting request. Seeems like they just want to spend hours doing what you think they want so they can say "naw, that's not what we wanted, try again"

    Needless to say I have not had a reply again.

    Tonight I googled "amwrtdrv.sys IRQL_NOT_LESS_OR_EQUAL" and the search result was this forum. Now even more insult is added to injury because they dont have the guts to admit they have a problem and are (maybe) working on it.

    Aomei support sucks!
  • edited May 2019
    Please read my post from 23 March. I am really sorry to continue to say Aomei is broken and is no longer reliable. I will still continue to hope there is a fix for this but I cannot use the program any longer until it is fixed and noted as such. I don't know what broke but it happened about when Win10 1809 update came out.
  • Now using Backupper Pro 4.6.3
    Crash still occurs when scheduled using Backupper Pro scheduler.
    My workaround is to leave Backupper Pro open, minimised, under my logged on admin user.
    Maybe an authorisation issue?
  • I can't find a clear pattern, last time it happened I had a BSOD "System_Service_Exception" without further info. I have a backup scheduled every 3 hrs. Sometimes it runs for a few days without error, sometimes I get multiple errors / reboots per day.
    Will try the minimised workaround now.
  • I am on the newest version Backupper Pro 4.6.3

    We are having this problem on multiple computers that we just set up. So I went looking for what was wrong and found this post and others in the forum. It looks like this has been a problem for a while. If it is not fixed by the time my 90 day return policy is up I will have no choice but to return the software. It is too bad because if this worked correctly it would be really good. Spent too much money for a problem like this.

    I just sent in a email for support and sent in the crash report via their program. Hopefully they will get back to me soon.
  • Yes, I have the BSOD crash from the same Aomei driver crashing.  Most of the time around the backup times.  WhoCrashed indicates that it is "amwrtdrv.sys IRQL_NOT_LESS_OR_EQUAL" consistently.
  • And that is no matter if it is via VSS or task scheduled.
  • edited May 2019
    I have 3 scheduled backups every evening. But only one of them causes the BSOD and always right when it starts (backup of system partition).

    I wonder if the guys at AOMEI are sleeping? The Backupper got rather many updates earlier... but since that problem appeared... ONE update within months. And that did not even fix it.

    Playing dead man is always the most bad idea. We are your customers, we pay for the software, so you could at least talk to us and write something like "We are still working on a solution" from time to time instead of ignoring us.
  • All went smooth the past couple days, I thought the problem was resolved because I kept getting regular confirmation mails from backups (which are filtered straight to archive) and had no more crashes.
    Then I discovered that my backup drive was full, took a closer look at the mails and found they all were error messages lol. Now the drive is free and it's back to the same old shit ... 
  • Support did get back to me with the following email:

    Sorry for the inconvenience caused to you.
    Our developers are working on this issue recently, there will be a patch fix available this month. 
    Would you please to wait for the patch a few weeks? 
    I will keep you posted when it is available.
    Sorry again for the inconvenience caused to you.
    If you have any other questions or suggestions, please feel free to contact us back.


    Hopefully there will be a fix this month. It seems like this is taking way to long for such a problem but if they fix it soon at least I will keep the software.
  • I'll also chime in and have had this problem but it seemed to start just recently.  However I'm only seeing it on 1 system a W10 Home 1709 17763.475.  I have a Pro system at the same level and it has not had this problem.  Also mine is not a scheduled task, its a adhoc batch file ie: .cmd.  To me it seemed to of started after KB4495667 was installed but after searching here a bit, it looks like this problem has been around for quite a while.   I have been running this batch for close to 2 years.  I'm also running 4.6.3 which was installed on April 26, 2019.   
  • Now that we are into a new month I am disappointed that they have not yet come out with a new update to fix this problem or give us a work around. I did email them again to ask when it will come out and he just responded saying they are still working on it.

  • I offer my thanks to a previous poster who observed that this problem did not happen if Backupper was already running when the scheduled. I have checked back thro the ever growing list of distressed users but could not identify who you are. You really helped me, thanks.

    I have run successfully now for two weeks, with 3 daily backups sheduled (system & 2 other partions).
    This is what I did: I just put in task through Task Manager to start Backupper 15 minutes before the first of the 3 tasks runs and while it is pathetic to have to do it its works for me, and is infinitely better than having to clean up afetr a Blue Screen. Excel and X1 are two key programs that done protect data sufficienly though a blue screen, as an example.

    I could have put in another task to shut down Backupper after the third backup each day but as these backups occur in the evening I let the shutdown procedure take care of it.

    If you were happy to minimise Backupper and leave it running , you could also just make it a "start up" program.

    Hope this of interest.
  • Would be helpful if there was a "minimize to tray" option.
  • Genlen, to try the workaround I am just leaving the program open. Last night it did backup without a problem. Only time will tell. Thanks for the info as well as the other user.
  • Leaving it open seems to work, thanks for pointing that out.
  • Have any of the current posters checked to see if the program is still creating VSS errors whenever a backup runs? You have to look in the windows event viewer to see this. Usually 4 errors are created. When this happens, VSS is disabled for any other program that needs it. This also needs to be looked at by tech support.
  • Flyer, I have not had a problem with this. My application event logs only show "The VSS service is shutting down due to idle timeout. " as information. No errors for a while now. Please keep in mind I have not been using the software for a while until two nights ago when I am now trying it as per above....

Sign In or Register to comment.