Home AOMEI Products Support

Backupper Pro amwrtdrv.sys causes system crash

12357

Comments

  • @Jh30uk, We thought that we need to know your sync problem from scratch. Could you contact us via email?
    Our support email: [email protected]
  • @Admin: At next upcoming error, I take a screenshot, currently I only remember that there were error codes displayed which were unknown to me until now and the error code was not included in the FAQ.
  • @admin: Now I received my BSOD, Win 2004, Backupper 6.0 with the original drivers of the installation file.

    With the new drivers amwrtdrv can not be started again. Net stop and copy works, after that I got the following error message:

    C:\WINDOWS\system32>net start amwrtdrv
    System error 2148204812 occurred. A certificate was explicitly revoked by the issuer.

    What can I do to restart the service?

    I am slowly losing interest in the product and would like to get my money back, I am still within the 90-day money-back period


  • The whole problem with the drivers started with the unsigned installation files and revoked certificates 4 years ago. Had to wait a very long time to get the drivers signed then.
    So a still ongoing problem I see.
    Please fix the driver problems FIRST before implementing new features or interface make-overs. Thank you.
  • @SirRudolphy, Our technician is checking the driver. We will solve the problem asap.
  • I experienced the PC restart issue with scheduled backups, whether that be using AOMEI's scheduler or Win10's.  I have gone through this thread and implemented the replacement of the three drivers in the System 32 folder. Did not have any issue restarting the services.

    So far this workaround seems to have worked - I have tried at least half a dozen scheduled backups without any problem.

    The reason I am writing this is to reinforce the views expressed by others, namely, if this is a four year old problem with a known solution, why is that solution not included in the most recent releases??  Are we going to have to manually replace these drivers every time we upgrade?  

    As stated by others in this forum, AOMEI should priortise the permanent solution to this problem before introducing new features.

    Thank you kindly.
  • edited September 2020
    Even though the @admin does a great job trying to solve and identify problems it is possible that the developers don't realize how it is affecting Aomei Backupper customers.  I saw this at another company and found that proper feedback makes people stand up and take notice.  So you might give that a shot and see if it will help.

  • edited September 2020
    @RonnieF Thanks for your feedback. I think it's great if the scheduled tasks work for you, but unfortunately not for many others. Especially when backing up whole hard disks with several partitions I have problems.

    And yes, I can restart the two services on one computer, but not on another computer. There must be a certificate problem with the drivers. 

    It is very strange for me too, that this problem was not fixed in one of the last releases. Especially when its paid software. I give the program a very last chance, because otherwise I am satisfied with it. At the moment I do scheduled backups with Acronis.
  • Sorry for the inconvenience. The solution still has some issues on some environments, such as windows 7. Our technician still needs to optimize it further. So, the solution hasn't yet been added to the released version.

  • edited September 2020
    Hallo, leider habe ich es jetzt gehört, dass meine systemabstürze bluescreens der letzten zwei bis drei Wochen auf wohl auch auf aomei backupper gehören sind. Leider hatte ich eine Menge damit. und die damit möglichen Probleme haben mich viel Zeit gekostet. Ich hatte immer die Windows 10 Updates in verdient, die bluescreens auszulösen. gibt es jetzt schon eine Lösung? Oder ein Update? Ich habe die Version 6.0 installiert.
  • This is totally unacceptable.  I cannot use drivers that require my customers to jump through loops every time the computer reboots -- they may not even know that it has rebooted!  BSOD is a symptom of totally incompetent design.
    In addition, the new version fails to find any Disks or Partitions (and existing backup jobs fail with Volume not Found) when using the drivers that do not cause BSOD.  That is, I have paid for a tool that does not work at all.  Pity no lawyer would bother with the amount of money involved.  But I have wasted hours of my time and I have lost face with my customers.  I will certainly recommend against the use of AOMEI products.   
  • I have done a fresh installation of Windows (version 2004 = build of operating system 19041.508).
    In addition, I also installed a new version of AOMEI Backupper Pro from version 4.0.6 (dated 2015) to version 6.0.
    I have never had problems with scheduled backups, but with the latest version my computer crashes immediately upon execution of the first scheduled task.
    I might be better off reinstalling my old version after all I read here, even though the new version looked promising.
    Incredible that a known problem has not been solved in all the new versions for 4 years.
    This is a big blame for AOMEI  :/ 
  • As explained on the previous page, copied the 3 sys files to Windows \ System32 \ and restarted 3 services.
    No more crash but during the integrity check of the system backup I get an error message:
    Backup is initializing ...
    Checking volumes ...
    Backing up the information of storage device ...
    Backing up of the volume 0 ...
    Backup data ...
    Backing up of the volume 0 done.
    Backing up of the volume 1 (C:) ...
    Backup data ...
    Backing up of the volume 1 (C :) done.
    Backing up of the volume 2 ...
    Backup data ...
    Backing up of the volume 2 done.
    Checking private structures ...
    Checking backup data ...
    Information Code: 4104
    Invalid image file. This file may not be complete or has been damaged, or it does not match with the current software version. "
  • Aomei, this is all very embarrassing. I hope that with the new release the bug is finally fixed instead of adding new features. If Windows7 is the problem, why don't you release a separate version? Windows 10 is the main system!
  • UPDATE: After a restart, a run again and now the integrity check is completed without errors.
    We'll see what the next run delivers in a week ...
  • Windows 1060,57%
    Windows 722,31%
    Mac OS X 10.155,03%
    Windows 8.12,69%
    Linux2,33%
    Mac OS X 10.141,96%
    Mac OS X 10.131,26%
    Windows XP0,78%
    Mac OS X 10.120,54%
    Windows 80,53%
    Unbekannt0,4%
    Chrome OS0,38%
    Mac OS X 10.110,37
  • edited September 2020
    Solution is to have 2 versions of the program available for download:
    - for Windows 7 the present installation file with the current drivers;
    - for Windows 10 a new installation file with the "test" drivers.
    Make both programs available on the website. Users will then be able to determine which program to download as the installation program seems not to be able to do so.
    In that way the technician doesn't have to investigate or optimize for 4 more years.
    Incredible that an installation program isn't able to distinguish between Windows 7 and Windows 10 and perform the installation accordingly.
    That would be far better than Windows 10 users getting stuck with a crashing system all of the time and most of the time not knowing what has caused it.
  • I have been evaluating Backupper and have the following comments...
    1. I've seen this BSOD with XP (32 bit), Windows 7 (32 and 64bit) and Windows 10 (64bit). I'm sure it happens with other Windows versions too.
    2. This BSOD doesn't only happen with scheduled backups. It also happens when starting a backup task from a shortcut created using backupper.
    Hope this helps


  • Error 4104 will continue to occur if the checking of the backup happens automatically immediately after taking the backup (at 99% of the check process).
    When I then manually execute the check procedure, it ends with an OK.

    Windows 10 Event Viewer:
    - in Application Log:
    2x event-id 8194 with 7 seconds in between =
    "Error in Volume Shadow Copy service: Unexpected error while querying IVssWriterCallback interface. Hr = 0x80070005, Access Denied.
    . This is often caused by incorrect security settings in the writer or requestor process.

    Operation:
    Collect writer information

    Context:
    Writer Class ID: {e8132975-6f93-4464-a53e-1050253ae220}
    Writer Name: System Writer
    Author Instance ID: {bb992cb8-0f05-45bb-b27c-42e13fed2cc7} "

    - In System Log:
    Event-id 98 between the 2 error messages from above =
    "Volume ?? (\ Device \ HarddiskVolumeShadowCopy7) is OK. No action is required."
  • @Dominik, Hast du die Treiber aktualisiert? Bitte laden Sie die neuen Treiber herunter: ambakdrv.sys, ammntdrv.sys, amwrtdrv.sys über den Link.
    Dann setzen Sie die drei Treiber zum Ersetzen in C: \ Windows \ System32.
    Im Allgemeinen kann ambakdrv.sys direkt ersetzt werden. Wenn Sie zwei weitere Treiber erfolgreich ersetzen möchten, beenden Sie zunächst die Ausführung von "CMD" als Administrator, um die Eingabeaufforderung zu öffnen.
    Geben Sie dann "net stop ammntdrv", "net stop amwrtdrv" ein.
    Kopieren Sie dann die zu ersetzenden Dateien ammntdrv.sys und amwrtdrv.sys.
    Geben Sie dann "net start ammntdrv" und "net start amwrtdrv" ein.
    Starten Sie danach den Computer neu und prüfen Sie, ob das BSOD-Problem auftritt.
  • @Renehoss @SirRudolphy, Actually, there also are some issues on some win10 environment. Our technicians are testing, checking and optimizing further. We will release it to asap.

  • @Willy_67, We have submitted the 4104 error to our technician to check further. Could you also send us log folder under the installation directory of AOMEI Backupper so that we check the error further?
  • @Admin
    Logs in attachment.

    For what it's worth:
    The log file under "System Information" states: Processor Architecture: AMD64
    However, my processor is an Intel Core i5-8500 CPU @ 3.00GHz
  • edited September 2020
    @admin: any news from technicans regarding the updated drivers?

  • @SirRudolphy, Sorry to reply you late. We have updated the drivers. Please try again.
    Please still download from drivers the previous link.
    https://drive.google.com/drive/folders/1sYFjaeNoaIe2RKFqsDWjdBONvjlftF8z
  • @admin: Thanks for the updated driver amwrtdrv.sys 
    This version could be start again via CMD.
    I will try now scheduled daily backups and report to you, when a BSOD occurs
  • @admin Short update: 4 scheduled backups of system partition without BSOD!

    Did someone else check the new amwrtdrv.sys?
  • Only just saw this latest post today...  
    I tried the very latest amwrtdrv.sys (the one that is 31K large) and had no problems with scheduled backups.  Having said that, I did not have any problems with the previous version (43K large) but at least this latest driver did not make things any worse.
    What we now need is the re-assurance that future updates of the Backupper will incorporate these drivers in their build.  As has been said by others, there is absolutely no sense in supporting Windows 7 when even Microsoft themselves have dropped support for that platform.

  • edited October 2020
    Downloaded the new drivers, replaced them... still BSOD. Neverending story. Running Windows 8.1 64 Bit.
  • I should add that I am running on Win10 Pro 64bit ver 2004.
Sign In or Register to comment.