Home AOMEI Products Support

Backupper Pro amwrtdrv.sys causes system crash



  • Unfortunately, windows 10 crash issues not fixed in v5.1 and 5.2, 
    After applying patch, I found another issue. when I try another backup task, pop up error "The Program did not find the system partition"  
    I think, AOMEI Team is sleeping, they are no care of customer, They should take immediate actions when user point out an issue
  • It looks like they are fixing first the non-critical bugs..
    And I paied for Server version..  and still BSOD if the scheduller is launched from application.. and the post-command is not working if is launched by application..
  • After applying patch, I found another issue. when I try another backup task, pop up error "The Program did not find the system partition" 
    You have to make sure you follow the instructions that came with the patch about restarting under Settings->Update & Security->Recovery->Advanced startup->Restart now
    If you restart without following those instructions you will get that error.  If the system restarts by itself (power failure, Windows Update) you will need to restart again as described above.
  • Version 5.2 released.  Have they lost their own patch?  Or perhaps they think the patch is the final solution?  Totally unacceptable!  Minus five stars for service.
  • I am getting backup failures as a result of Windows unattended restarts, without disabling Driver Signature Enforcement.  When is the patch going to be released?  It is essential to have it installed properly!
  • We are still applying for the certificate from Symantec, not sure how long it will take.
  • You have release two updates (5.1 and 5.2)  since the patch was found to be effective.  I don't understand why it was not included in those updates.  Was does Symantec have to do with this?
  • I don't know why but for me the crashes disappeared with version 5.1. Not a single BSOD was seen (scheduled backup runs once a day). May be it's just a coincidence but before I had at least 1-2 BSOD per week.
  • Be aware that when after installing an update you must reinstall the patch.  At least that was true when installing 5.2.
  • An ordinary code signing certificate, which is a minor pain to get, is not sufficient for signing device drivers. Sounds like they are getting the necessary cert through Symantec.  I have no idea what you have to do to get such a cert or why it's taking so long.

    We're still using 4.6.3 and haven't had any crashes recently.  I wonder if some Windows update has helped?
  • I'm running 5.2 and am experiencing system crashes. I applied the patch, following the instructions carefully. On reboot, my USB mouse and keyboard were not recognized. Luckily, I has the original amwrtdrv.sys. I re-installed it and got the mouse and keyboard back. What did I do wrong?
  • edited October 2019
    I also had a BSOD again some days ago...

    It's been 7 months now and still no fix. Seems they don't really care.
  • Has the bug been fixed?
  • Can someone from Aomei answer?
  • Does 5.3 address this issue?
  • Only this:

    Version 5.3 (Released 2019-10-09)

    Optimized the speed of file backup and file sync.
    Optimized the function to edit task.
    Added the ability to switch a sync task between real-time sync and other types of scheduled sync.
    Fixed issue: the path is too long to perform file sync.
    Fixed issue: unable to only restore individual files from a file backup in some situations.
    Fixed issue: unable to delete Windows scheduled task in some Vista systems.

  • As I already told that I have facing System crash with AOMEI Backupper 5.0, 5.1 or latest,
    The issue was resolved by apply BSOD Patch provided by Admin, but this patch worked when I Disable Driver Signature Enforcement but after restart "Driver Signature Enforcement"  again enabled and AOMEI Backupper does not read the partitions in the system and hence backup process finished with error, log of this error showed "System does not find the Path specified (Backup drive/partition)" and also new backup can not be create because of the same reason. This problem can be solved by permanently Disabling Driver Signature Enforcement (mean condition sustain after restart), Is there a way to disable driver Signature Enforcement permanently in Windows 10 v18362, HP 8440P.
    Anybody can Help;
  • edited October 2019
    I don't beleive the Driver Signature Enforcement can be disabled permanently.
    One of Microsoft's safety measures for unintentionally running malware drivers.
  • By the end of the year will there be any answers?
  • Another update, another time no fix.
  • edited January 2020
    @Willmore The driver is signed, please try the test version.
    Please uninstall AOMEI Backupper completely, restart computer and install the test version.
    About how to completely uninstall AOMEI Backupper, please refer to the link below:
    Note: the test version is only for Windows 10.
  • Do you have a download for the technician version?  Or can we use amwrtdrv.sys from one of the above installers to replace the file from a previous install?

  • @wssddc It will be the technician version once you enter the license code.
  • Bad news.  Trying the std version at home, first just did an update install and got a blue screen on the next boot.  Then followed the complete uninstall directions and got a blue screen at the end of the install.  Windbg says "Probably caused by : amwrtdrv.sys ( amwrtdrv+6059 )" and I also saw amwrtdrv.sys on the blue screen. Nirsoft bluescreenview says all of my crashes were at ntoskrnl.exe+93ea0, caused by nsiproxy.sys, wfplwf.sys or CompositeBus.sys.

    OS is Windows 7 ultimate 64-bit.

    Do you want minidump files or any other information?

    Note: to recover, I booted WinPE from a USB key and renamed wmwrtdrv.sys

    The complete uninstall process is ok for a single machine, but very painful to contemplate for multiple machines at work.  When using the technician license code, would that be with the free version (std.exe) or server (setup.exe)?  We've held off doing updates for a year waiting for this to get fixed.

  • @wssddc The test version is only for Windows 10.
  • And now we have version 5.8 and it still has the old corrupt driver in the installation files.
    The culprit file is amwrtdrv.sys and is of the year 2017.
    The test version of amwrtdrv.sys is of the year 2019 and works OK, it is not giving any BSOD.
    So please, insert this newer file into the installation setup.
    Why keeping the old file that is giving people troubles?
    I simpy don't understand anymore...
  • The changes to version 5.8 should only come at Christmas!
  • As for BSOD problem, please download the new v5.8 from the following link.
    Please first uninstall AOMEI Backupper you have installed via Control Panel, then delete ambakdrv.sys, ammntdrv.sys, amwrtdrv.sys under C:\Windows\System32, reboot the computer, install the new version we sent.
    Please note that the version still is valid for windows 10 system.
  • For those that are wondering, the new amwrtdrv.sys with v5.8 is dated 8Jun20 and is 43KB.
    A straight upgrade from v5.7 does not upgrade the sys - it has to be manually deleted as above.
  • Generally, the automatic upgrade process doesn't delete the original drivers. You might need to uninstall the old version manually to clear all things of AOMEI, then install the new version.
Sign In or Register to comment.