Backupper Pro amwrtdrv.sys causes system crash

I've been experiencing frequent systems crashes when Backupper Pro starts (and sometimes just after it finishes).

I'm using Backupper Pro 4.6.2 with Windows 10 Pro 1809 at current service level (KB4489899)

I have a Partition Incremental backup scheduled for 04:35 every day, using the AOMEI scheduler service.

Every other day a system crash, followed by reboot, occurs just after the backup starts, and the backup never completes. I suspect that the first backup after a reboot works, but subsequent backups fail, although I haven't had a chance to test this theory.

The WhoCrashed utility reports this crash is caused by the amwrtdrv.sys driver, shown below:

On Sat 23/03/2019 04:36:10 your computer crashed or a problem was reported
crash dump file: C:\WINDOWS\MEMORY.DMP
This was probably caused by the following module: amwrtdrv.sys (amwrtdrv+0x14D2)
Bugcheck code: 0xA (0x138, 0x2, 0x0, 0xFFFFF80058C9CB7A)
Error: IRQL_NOT_LESS_OR_EQUAL
file path: C:\WINDOWS\system32\amwrtdrv.sys

I tried using the Windows Task Scheduler to run the daily backup and interestingly the backup completed successfully, but was followed immediately by a similar amwrtdrv.sys crash and reboot. 

Possibly not related, but I notice that the two versions of amwrtdrv.sys on my system have a slight difference. Both have a Created/Accessed date of 23 February 2019 (when I installed 4.6.2) and both have a Modified date of 01 September 2017.
But C:\Windows\System32\amwrtdrv.sys is 38,320 bytes
Whereas C:\Program FIles (x86)\AOMEI Backupper\driver\i386\amwrtdrv.sys is 34,864 bytes

Any, positive, suggestions?

Comments

  • edited March 23
    I've posted this before but just to repeat for newer viewers. Backupper, for me also, has been creating 3 major errors which I contribute either to the 4.6.1 version and later or a conflict with Win 10 1809.

    1. Numerous, but random BSOD or complete PC lockups when running a scheduled backup.
    2. Disappearing Backup job definitions from home screen.
    3. VSS errors (which can be viewed in Windows Event Viewer) every time a backup runs. This also breaks the VSS function for other programs using VSS.

    I've stopped using Backupper until these problems have been fixed and noted as fixed in a future program update. I've notified both the admin here and tech support about these problems which as far as I'm concerned make the program unusable. I'm hoping these problems can be addressed as I was using Backupper for 2 years with great success in both creating backups and in restoring them. I'll remain positive and continue to try and help out whenever I can here on the forum, but product loyalty can only go so far.
  • Aomei.

    Eu não tenho esses problemas citados, mas não seria interessante lançar versões beta?
    Os usuários podem relatar o sucesso para você.
  • Flyer I am with you also. I have the Pro version of Aomei that I have been using for almost 3 years. I have abandoned the program for another backup program until Aomei can fix their problems. My backups are too important to me.
  • @vagn_32, all these problems have been reported by others in posts on this forum so I am not alone. I suggest you closely check your Windows event viewer for VSS errors that appear at every scheduled back up. My wife's PC was not blue screening or losing backup definition sets but she was getting the VSS errors. 
  • Flyer

    I don't do scheduled backups, my backups I do when I install some program or Windows updates.
    I suggested to Aomei betas versions for us users to help.
  • Aomei Backupper 4.6.3 Server Edition.
    If the task (partition incremental backup) is schedulled, immediately after start I have BSOD on Server 2016 Standard Edition.
    Examining MEMORY.DMP:

    On Sat 06.04.2019 21:00:23 your computer crashed or a problem was reported
    crash dump file: C:\WINDOWS\MEMORY.DMP
    This was probably caused by the following module: amwrtdrv.sys (amwrtdrv+0x14D2)
    Bugcheck code: 0xA (0x138, 0x2, 0x0, 0xFFFFF80188EC4F2F)
    Error: IRQL_NOT_LESS_OR_EQUAL
    Bug check description: This indicates that Microsoft Windows or a kernel-mode driver accessed paged memory at DISPATCH_LEVEL or above. This is a software bug.
    This bug check belongs to the crash dump test that you have performed with WhoCrashed or other software. It means that a crash dump file was properly written out.
    A third party driver was identified as the probable root cause of this system error. It is suggested you look for an update for the following driver: amwrtdrv.sys .
    Google query: amwrtdrv.sys IRQL_NOT_LESS_OR_EQUAL

    If the task is launched manually, everything is ok.
    So this is a very serious bug for Aomei!!
  • @testerics ; Please try the second option to see if it works.

  • Thank you for your answer, but I already tried in both way. The result is the same: if the task is launched manually, everything is ok. If the task is launched by scheduller, I have BSOD and server is restarting.
  • I use AOMEI Backupper Pro for quite a while now on Windows 8.1. For some weeks it causes a BSOD when it starts a scheduled backup. Not every time but most of the time. It's very annoying. Also all backups disappear from the Home screen after the crash, so if you did not export them, you have to create them again. The support can't help and only tells me to use an older version. That's not helpful.

    Why does it take MONTHS to locate and solve the problem??
  • Can wait another 4 months! I've never seen so much delay
Sign In or Register to comment.