Home AOMEI Products Support

Backupper Pro amwrtdrv.sys causes system crash



  • After installing an upcoming version 6.1.1 (including the new signed drivers), can we be sure that a following windows update will not overwrite these drivers again?

  • V 6.2 is released. You can downlod it only as trial version https://www2.aomeisoftware.com/download/adb/ABProTrial.exe

    due to they linked the wrong version here https://www.ubackup.com/changelog.html#v6.2

    After installing the trial , I get an new amwrtdrv.sys (dated today) and 2 old version (21.12.2016) of ambakdrv.sys and ammntdrv.sys.

    I am very curious if the BSOD have been fixed
  • I don't use scheduled tasks, but it looks like it's turned blue. I put to run a backup now at 20:30 and it went well.
    Now I was confused because the image backups in question there is password, but no password was asked.
  • Even if they finally fixed it the other side (Sync Files) is a mess after 5.8 so i cannot use it.
  • Hello, We have released v6.2. Please try to download from here:
    @SirRudolphy, we have updated the download link.

  • @admin

    Why is a password not required with scheduled tasks?
  • @Vagn_32,
    "Now I was confused because the image backups in question there is password, but no password was asked."
    ---Did you mean that you perform the backup manually without asking password? Will it ask for the password when you do other operations for the task? Such as, Check Image? Restore?
    Could you run the backup to check again?
  • @Jh30uk, Could you try the v6.2 to do sync again? 
  • edited November 2020
    The Image Backup has encryption, however when it arrives at the scheduled time it backs up, but there is no box to enter the password.
  • Now if the backup is performed manually, the box for entering the password appears as usual.
    Plugin-USB same thing ... Manual mode asks for backup password, but if you schedule via Plugin-USB makes the backup ask for the password.
  • I believe with the latest version (6.2.0) finally the correct drivers are installed
    into Windows 10. This should resolve the BSOD issues.... at last... ;l0
  • @Vagn_32, Actually, the password is recorded to the image file. When the schedule backup is performed, it will call the password automatically so that the scheduled backup can be completed automatically without interaction request.
  • @admin

    Okay, but how does Backupper call the password?
    Could you explain it a little better? Sorry for my annoyance, but I am trying to understand, because I walk a lot with my hard drive to my friends' houses and it contains all my encrypted backups.
  • Sorry to ask this again, but can we be sure that a following Win10-update will not overwrite the drivers provided by v6.2 again?
  • @CinqoSec

    What makes you think that a Windows Update overwrites the drivers? The problem was that the manually set drivers were overwritten by the installation packages of the Backupper.
  • I'm not sure but I had in mind that there were complaints about failing drivers after a windows update. If this isn't the case then it's even better.
    I just want to make sure to not make a mistake by updating Backupper since I nearly wrecked my whole system with my last attempt.
  • For me, everything works fine with the manual installed amwrtdrv since 8 weeks. I use scheduled system backup time triggered. No BSOD at all. And V6.2 still contains this amwrtdrv, so I am confident that this horror is over
  • @admin
    Just tested the new version - all OK with unattended backups.  Also tested with the most recent release Windows10 20H2 and it all worked fine so far.

    Thanks for your assistance in resolving the BSOD issue with the amwrtdrv.sys driver.
  • OK with unattended backups using 6.2.
    Thanks for resolving the BSOD issue!!
  • @Vagn_32, Sorry that we can't explain how the Backupper calls the password.
    "because I walk a lot with my hard drive to my friends' houses and it contains all my encrypted backups."----If you need to restore or explore the backup image, it will require you to type into the password. Or, if you perform the backup manually, it will also need to use the password.
Sign In or Register to comment.