Still bluescreens and crashes when an AOMEI Backupper scheduled task starts running

Last year I had a problem with AOMEI Backupper which lead to a blue screen when a scheduled task starts.

I found some posts regarding this (i.e. https://www.aomeitech.com/forum/discussion/6824/issues-after-applying-bsod-patch-to-cure-system-crash-in-windows-10-v-18365) and after some time the problem disappeared. I assumed a Win10 made the scheduling work again and regarded the problem as solved.

But now after some Win10 updates and some AOMEI Backupper updates I have this effect again. Not always but once in a while. I couldn't manage to find a soulution. When I start the task through Window's task scheduler the system freezes and crashes. The same task started directly from within AOMEI Backupper runs fine without problems.
In the task's options I switched the scheduling to the AOMEI service but still the task crashes when run by the scheduling.

Since I tried to restart the task directly after a crash while the scheduling starts the task when the system is running for some while I wonder if the problem lies in the fact that the target drive might have gone into some sort of hibernation or sleep mode. Does AOMEI Backupper check the availibility of the target when trying to back up? Or does it just start and crashes because the target is not reachable immidiately?

Or are there other ideas how to fix this issue?

(I am running AOMEI Backupper Professional 5.6.0)

Comments

  • I've had this same problem where Backupper BSOD's.  I only have this problem if I Batch run Backupper right after a restart of the system.   To stop the problem happening, if you restarted your system just run Backupper interactively and then shut it down.  Now run the batch and it works correctly.   To me it operates like the batch program is missing starting a service ?   Which one IDK. 
  • Did you try the test version?
  • edited March 16
    What test version? Do you mean the one mentioned in this thread?

    This is an altered 5.5.0 version. I'm not sure is downgrading from 5.6.0 for this testing is a good idea. What has been changed in comparison to the current 5.6.0 regarding the BSODs? Didn't the signed driver make it into 5.6.0?

  • Yes, please use the 5.5 version, 5.6 doesn't have the signed driver.
  • I installed the 5.5 test version and the last two scheduled backups ran as planned. I'll keep on monitoring  this the next weeks.
    Will this driver be shipped with an upcoming version?

  • Yes, it will.
  • Thank you :)
    Looking forward to that.
  • the same problem here with me. It can't be that it takes that long to fix this mistake! I am angry!!!!!!
  • Since 11 days there were 8 backups that ran automatically on my system. With the 5.5-test-version that includes the signed driver all scheduled tasks ran without crash. This fixed it for me.
  • edited April 17
    The test version fixes the problem for me as well.
  • Just saw that version 5.7 came out. Is this problem fixed in this version or do we still  have to stick with v 5.5?
  • Version 5.7 is extremely BAD version.

    1) Still has the old driver, and not the test driver "amwrtdrv.sys" dated 19-12-2019 17:57.
    Still many crashes with scheduled tasks. Please include the test driver, that is the only one that is OK!

    2) Furthermore with version 5.7 when I check for update manually, the program creates a child process with an executable file (.exe) in the temporary directory named AutoUpdate.exe.
    That is very bad practice! Since my virus scanner and firewall block any programs located in temporary maps with aribitrary names: "autoupdate{9bc00b53-0cde-49c2-89f3-cea264cd6d78}". Version 5.6 had no such problems.

    3) Furthermore the installation file created a desktop icon. At first the icon is ok, but after a reboot the icon is blank and cannot be recreated. The link on the desktop has no access to the icon stored within backupper.exe and I had to point to another program to get my icon back.

    4) And lastly the installer will only install the program in "C:\Program Files (x86)\Aomei\AOMEI Backupper 5.7.0". I am not able to choose a name myself if I want to install it elsewhere.

    Why all these strange and unnecessary changes to the program?
    I am not happy. Extremely bad update!
  • Version 5.7 doesn't fix the blue screen issue, please stick with v 5.5.
  • How long will you talk to stay with version 5.5 blah, blah, blah ... Get out before the COVID-19 cure?
    Does a soul that programs the software honor what is in the middle of the legs and come to give some satisfaction to free users and peagos?
    It is not a month, but almost a year to correct it.
  • That's sad to hear. Do you mind saying something about the reasons why the driver is not included?

    And for
    4) And lastly the installer will only install the program in "C:\Program Files (x86)\Aomei\AOMEI Backupper 5.7.0". I am not able to choose a name myself if I want to install it elsewhere.
    I assume this came with the automatic update feaure? I also like to choose a different  installation path (my programs reside on drive D).
    Any chance for a configurable choice (custom drive and path vs automatic updates)?
    The current problems with the driver and with the versions 5.5/5.6/5.7 don't make me think that it's a good idea for automatic program updates, anyway.
  • @CinqoSec ; Do you mean you can't choose a different installation path? Did you see the Path>> button?

  • Yes, in the version I currently use (5.5) I use a custom path. This is fine.
    I referred to the statement from JO45 that it was no longer possible in version 5.7 to use a custom path.
    Was this a wrong statement? I cannot try version 5.7 myself, because the fixed driver is not included there and so I would get bluescreens with that version.


  • It is possible in version 5.7.
  • You can use the latest version of Backupper but you have to replace the file "amwrtdrv.sys".
    See also post https://www.aomeitech.com/forum/discussion/4995/backerupper-amwrtdrv-sys-causing-bsod-on-windows-10#latest

    You cannot replace this file from within Windows because then it is in use. Thus this must be done outside of Windows.

    So you have to have the test version of Backupper installed first. Copy the file "C:\Windows\System32\amwrtdrv.sys" to a safe place. The correct file has the date 19th of December 2019 and is 27,360 bytes. I keep it on an external drive in case I might have to replace the file again in the future when I update Backupper.

    Then also copy this test version of "amwrtdrv.sys" to the bootable Backupper rescue USB that you must have made earlier.  Next step is to uninstall the test version of Backupper and reboot. Then install the latest normal version (Pro or Standard) and make sure that the installation went OK.

    Next you have to quit Windows and start the computer with Backupper from the bootable USB.

    There you will find the option to start a command prompt (in the Tools section). Now from the command prompt you can replace the file manually. The file resides in C:\Windows\System32. Delete the old file and copy the test file from the USB over to your SSD. Reboot into Windows and check that now the correct file is in place. You can check by size or date of the file.

    Would be nice if AOMEI would simply include the test version of the file in the normal installation program for users of Windows 10. I can confirm after using the test version of the file with the latest builds of Backupper (currently using 5.7.0 Pro) in this way for a long time that it works OK. I don't have BSODs anymore when Backupper performs an automated backup.
  • And about the installation path in version 5.7.0. You can change the path but the installation program adds a sub folder named "AOMEI Backupper 5.7.0" after that. This is new compared to version 5.6.0.

    I.e. if I want to install it to "D:\Backups" then the installer puts it in "D:\Backups\AOMEI Backupper 5.7.0". So you can only partially choose where the program is installed.
  • Thanks renehoss for investigating!

    I think the easiest way for all (Win10-) users would be if AOMEI would
    – include the correct driver in the next version of Backupper and
    – let the user have full control over the installation path without adding a subdirectory



  • @CinqoSec We will update the solution of BSOD to the new version asap. 
  • Yes, please put the fix into an official release.  Any solution that includes boot from a USB key to replace a file isn't practical when you have hundreds of machines and aren't even supposed to enter buildings if possible because of covid-19.  Also, one of the early test versions was Win/10 only.  What's the current status of server operating system support, and less important, Win/7?  (To be clear, I like your product.  Win/10 2004 hosed my personal machine and my Aomei backup restored without any difficulty. Earlier today a co-worker successfully restored a machine that had a disk failure.)
Sign In or Register to comment.