Home AOMEI Products Support

AOMEI Backupper Pro fails after WIndows 10 Anniversary Update



  • Yes, you are right. Disable the secure boot is the temporary solution. We will continue to solve it with the way you give us. Sorry.

  • Cautionary note regarding the installation medium:

    When trying to reproduce this configuration, don't use an installation medium with Windows 10 version 1511 or even lower and then upgrade.

    You have to use an installation medium with Windows 10 version 1607 (Anniversary Update/Redstone) right from the very beginning.

  • @admin: No problem. All I've been trying to do here is pointing you to the real issue and its only proper solution.

  • edited September 2016

    May Microsoft's Code Signing FAQ is helpful for any further steps.

    The most important sentence there is this one:

    "In Windows 10 for desktop editions, all kernel-mode drivers must be
    signed by the Hardware Dev Center Dashboard and the Hardware Dev Center
    Dashboard requires an EV certificate."

  • edited September 2016

    This information is pretty important as well in order to understand how to get your kernel-mode drivers correctly signed. I think I've posted it before, but just to be sure.

    Driver Signing changes in Windows 10, version 1607

  • edited September 2016

    Btw - I have to correct myself slightly regarding the steps to take to sign your drivers correctly. The end result is the same, but the steps are slightly different.

    1. Firstly, you have to have a Extended Validation Code Signing certificate. Contrary to what I initially said, this can be issued by a Microsoft partner, like e. g. Symantec as its purpose is just to validate your identity as developers.

    2. You then have to register that EV Code Signing certificate in your account at Microsoft's Windows Hardware Developer Center Dashboard portal.

    3. Then you have to submit your kernel-mode drivers (along with the merged HLK/HCK test logs) to said portal.

    4. Your drivers then get inspected and signed by Microsoft.

    As written before, the kernel-mode drivers themselves cannot get signed by a Microsoft partner like Symantec.

    Hope this helps.

  • edited September 2016

    imageIs there also any progress regarding the problem of skipping backup tasks with disk space management on after reboot?

  • @renehoss, please try to choose the "install the service to run schedueld task" in the schedule setting.

  • That does not make a difference. The scheduled task with disk space management is skipped after a restart or reboot. Never had this problem before Anniversary Update.

  • I managed to get the updated 3.5 version installed and working on Windows 10 Anniversary or newest version. It was a bit tricky though.

    What worked for me was first I had to go into BIOS and disable "SECURE BOOT" then I followed the steps outlined here to temporarily disable the digital certificate enforcement - 


    NOTE - This will only TEMPORARILY disable  the certificate enforcement, the second you reboot it will automatically turn back on, no option to turn it off permentantly that I know off.

    ALSO NOTE - For me anyway, Turning off the digital enforcement temporarily ONLY WORKS if you Disable SECURE BOOT FIRST.

    After I got everything installed without the certificate warnings for the drivers I was able to turn back on SECURE BOOT in Bios and shutdown and restart and load up Windows and use AOMEI with no problems. 

    To be fair, AOMEI Backupper is not the only software I have ran into this issue with, there are several of them having the same problems. It's just a pain to have to go through these steps to install something. 

    Just thought I would mention what worked for me incase it may help others having this problem. 

  • Well, according to the link I give I missed the part where it does say you can disable the certificate issue compeltely at the end of the article, sorry my bad. 

  • Following my previous post (#39, 25 Sep 2016) and upon advice from Megan of the AOMEI Support Team, I took the following actions that have returned AOMEI 3.5 to normal operation from my point of view.

    On my laptop computer running Windows 10 Version 1607 (upgraded from Version 1511, not a fresh install), I deleted all AOMEI backup tasks and all backup files (from an external hard drive) and downloaded the new AOMEI 3.5 version from the link Megan provided (http://www.aomeisoftware.com/download/adb/ABPro.exe).  I uninstalled the old program manually (through Control Panel / Programs and Features) and installed the new version, which does have numerous updated files despite using the same version number.  I made a new backup task using the Space Management Scheme, with up to 10 backup versions allowed.  To get results sooner, I set the schedule (through the offered AOMEI service) to run every three hours, which is much more frequently than I would normally use.

    Over time, the program made one full backup and nine differential backups.  Then it created a new full backup followed by a new set of differential backups.  In between various runs, I rebooted the computer and had the graphical user interface (GUI) open during  some runs and closed during others.  When I had left the computer shutdown past a scheduled run time and then restarted it, AOMEI popped up a small window in the lower right corner of the screen from which I could open the GUI to see the scheduled run begin.  I used the "Check Image" feature to verify the integrity of one of the full backups and one of the differential backups, and that utility reported no errors.  I did not try a Restore operation from any image.

    The updated AOMEI 3.5 version also worked on my desktop computer, which is still running Windows 10 Version 1511, to fix the problem of only full backups being produced by the  Space Management Scheme.

  • edited October 2016

    I have noticed something else regarding this problem of skipping tasks.

    If you create a backup task, a hidden file with a name like "f870c249-78e0-49ab-a037-5778e845b16a" in the map C:\ProgramData\AomeiBR\ is made.

    But as soon as you modify this task this hidden file is deleted. After this modification and automatic deletion of the hidden file the task is then skipped...

    Maybe here is the problem? If this is indeed a bug it should be repaired, users should be able to change a scheduled task and not always recreate from scratch.

    Just guessing of course... In the mean time I have disabled disk space management in order to make backups and I will check on the disk space manually.

  • image

    Hi, @Admin.

    I installed fresh WIN10 AU(in a empty SSD).

    I download the newest AOMEI Backupper, just like @RiseT said, it still can't work in my laptop. 

    In addition, I installed Chinese version backupper on my another labtop which has English version WIN10. It cannot display chinese character at AOMEI Recovery OS. Is there any chance to fix this bug? 


  • edited October 2016

    @Serious @UpBear @renehoss  Sorry for the driver problem. We are trying to buy the EV certification now. But it will take some time to buy it. Please give us the time. After we get the EV certification, we will unograte the software ASAP.

  • @mr_liang666   1. For the driver problem, the current solution is that disable the secure boot when you install it and we are trying to solve it ASAP. 2."AOMEI Recovery OS" It is the winpe right? If yes, it is the english whatever the languge you use. For this problem, we will improve it in the future.

  • edited October 2016

    Microsoft and the EV certificate cost and hurdles will be enough to put many small vendors out of business. Either they absorb the new costs or pass those onto their customers, which could result in loses either way. Or convert apps to Java, which in itself is a potential extrenuous cost and could also put small vendors out of business.  A conspiracy perhaps?  Does Microsoft have any investments in Symantec or Digicert?  Hmmm. Bait and switch ... the MS 10 Borg!

  • edited October 2016

    I posted this before, but perhaps it's not being understood.  You can temporarily disable the requirement to have a signed driver and then install AOMEI 3.5 in windows 10.  After it's installed, you can reenable Driver Signature Enforcement.  Read how to do this here:



    1. Open a Command Prompt with admin privileges. In Windows 10 or 8,
      just press the Windows key + X and then select “Command Prompt (Admin)”.
    2. Type in the following command and press Enter.
      bcdedit /set testsigning on

      You should receive “The operation completed successfully” message. Close the Command Prompt and restart your computer. From now on, you will be able to install or run any unsigned driver without problems.

    To re-enable Driver Signature Enforcement after AOMEI is installed:

    1. Run this command instead:

      bcdedit /set testsigning off

    At least you can continue to backup and give time to AOMEI to get their stuff together.

  • @yabedude     Thanks for your suggestions and feedbackup. We will discuss the information you tell us with our technicians.

  • edited October 2016

    And in the mean time I do hope that the technicians not only look at the driver signing problem but also at the original problem of the buggy drive space management. It is simply not working when Backupper 3.5 is installed on Win10 AU. Something in the last major Windows update must have broken the drive space management mechanism, because everything was working 100% OK in the Win10 version before the AU.

  • The unsigned drivers have been around for 5 months now.  I gave up waiting and moved on to macrium.  I do like the backupper and prefers it, but waiting 5 months is silly and there is absolutely no update on the fix. Every backup program got signed drivers a while ago, this cant be good for business.  An eta update would be nice.  I got old backups that I cannot use because I updated to anniversary update and uninstalled backupper by accident.  Trying to reinstall failed because of unsigned drivers. 

  • edited December 2016

    Please do not worry, we will release the fixed version recent days. When we do it, we will inform users in this forum.But we are also sad it takes long time. So so sorry for the inconvenience we made to all your guys.

  • edited December 2016

    Sorry for Windows 10 Anniversary Update (Windows 10 version 1607 or higher)


    We are happy that the driver signature problem on Windows 10 Anniversary version was solved. You can download AOMEI Backupper 4.0.1to enjoy. Hope this is the good news for every AOMEI user. And we apologize for all inconvenience caused sincerely.


    A few months ago, the Microsoft releasedthe new Windows 10 Anniversary Update (Windows 10 version 1607 or higher) which requires digital signed driver. If the drivers of all softwares don’t use the EV certification, all the drivers in the software cannot be installed and usedsuccessfully. As you know, this is the new requirements from Microsoft. Thereis no doubt that AOMEI software meets the same problem of the EV certification and it causes much inconvenience for all of the loyal users of AOMEI software.


    Although we have been tried to solve the problem and it was solved eventually, we do not solve it immediately. AOMEI must say so sorry for all the users again. Your understanding is veryappreciated. Thanks all of you.


    Please trust AOMEI, the technicians and allthe staff of AOMEI don’t give up to solve this problem all the time. AOMEI is worthy of your trust and support. Now we would like to share with you about the experience on solving the problem.


    As soon as we get the feedback about the problem from the users on the forum and email, our technicians try to do more tests and our leaders strive to ask the related information from the digital certification reseller. We find that although the SHA1 signature is in theAOMEI software, it also needs the SHA265 signature. Then we buy the SHA265 immediately. (You can check that there are two signature certifications of the AOMEI Backupper 3.5 version in the Windows 7 or higher system) After that, welet out a sign of relief, because we think that this problem is solved. But it disappoints us again, the problem is also there. The worst thing is that ittakes long time to try this method to solve this problem.


    At this time, after we get the EV certification indication from our user, say thanks for you, on the Forum and wedo the search from the website, we think that maybe the EV certification is useful for this problem. Then we ask the help from the EV certification reseller but they tell us that they are also not sure the driver problem will be solved with the EV certification. And the reseller continues to inform usthat the EV certification for the driver must be authenticated by MS official website. But we want to try, because we need to try every possible way to solve the problem ASAP. So AOMEI don’t hesitate to buy the EV certification, however,there is one USB token for the EV certification must be delivered from foreignand it also takes so long time about one month. Finally, when we get the USB token for the EV one month later, our technicians work over time to get the AOMEI software which has the EV certification and then they submit the software to get the authentication from MS several times. It takes several work days toget the good news from MS. At last, our technicians test the fixed version many times and they exhaustedly inform us that the driver signature problem is solved perfectly.


    AOMEI are very sorry for that the problem on the Windows 10 Anniversary Update, we know that it has brought lots of inconvenience for all the AOMEI loyal users. Thanks very much for your supportand trust, AOMEI will try to improve the software all the time. Hope we are helpful for you, because we are here with you.


    We would like to say thanks for all the friends in there. Your discussion in there is useful for AOMEI and AOMEI software. We also must say thanks to those who ( @renehoss @RiseT @JohnnyboyGo @Peter13feb @vagn_32 @UpBear @Serious @yabedude ) give us the solution and suggestions to solve this problem.


    Due to this problem, AOMEI brings the trouble for all your guys. In order to show our sincerity, if you need the AOMEI paid software such as AOMEI Backupper or Partition Assistant, please send us the email to [email protected]. Wewould like to give you the software for free to say thanks for your support and understanding.



    Merry Christmas

  • Hey, I waited 5 months and lurked here for months.  I don't get a chance at paid software?  image

    I'm glad you got the issue resolved.  But more frequent updates would had helped.  If you had let us know about your struggles, users here in the states (assuming you guys are from the east) could had easily assist you.  5 months downtime is disastrous for any business.  You guys are fortunate that only the clean anniversary updates are affected. 

    This is my favorite backup program by far and I am very happy you can get back to making the software better instead of spending any more time on certfication.  This is a Christmas gift to us all.  I wish everybody at aomei tech a very Merry Christmas and Happy New Year. 

  • It is already a present using the Aomei Backupper. Happy christmas and a prosperous year year

  • edited December 2016

    @admin Great to hear that this is finally fixed. I can confirm after some testing that so far it's working as expected.

    Just don't forget that the Microsoft certificate used to code-sign your kernel mode drivers will expire 12th of May 2017, so you will have to renew it before that date ;-)

    And thank you for your kind offer - glad if my comments have been helpful.

    Merry Christmas to all!

  • edited December 2016

    PS: I'd recommend updating the version number of the setup file. The setup file's properties still say version, which could confuse users as they cannot distinguish the 4.0.1 setup file from the 4.0 one.

  • @dhau  Thanks for your support. We are happy that all your guys are here with us to solv e the problem. You are right, we can share the problem with you and ask help from the users. 

  • @vagn_32   Happy new year all of you.

Sign In or Register to comment.