Home AOMEI Products Support

AOMEI Backupper Pro fails after WIndows 10 Anniversary Update



  • I'm a Backupper Pro customer, and I still cannot install it on a machine that has a clean install of Windows 10 Anniversary Edition - after almost 2 months - this is really unacceptable!

    Other forums are talking about this, and it has caused me to start looking at alternative products. Although I really like Backupper, it may be time to switch. 

    (BTW - Macrium Reflect gets the highest marks on TenForums.com.)

    Come on, Aomei, do something. You are bleeding (losing) customers. Very BAD!

  • edited September 2016

    I am also a paying customer, I have payed for the Pro version, with lifetime support and updates... I do not understand why it is taking such a long time to solve this problem.

    I cannot use my Pro version at the moment, I cannot make normal backups, my computer is at risk, I can lose all my data if I have a crash! Maybe I should switch, I will take a look at Macrium, because this is getting rediculous...  image

  • Sorry for the late. We are testing the problem, but we will fix it in the next new version. It needs some time, because we will do other improvement in the next version.

  • I understand that problems will perhaps be solved in the new version.

    But the question is: when will the new version come?

  • The same answer we sorry we testing

    When will the next version come ? ETA

  • I would like to try " Macrium Reflect ", rather than "naked".

  • edited September 2016

    Yes, better shield of Macrium Reflect than a non-working Backupper. AOMEI looks a bit like North Korea, they are also still testing missiles and saying sorry for failures... Now waiting 8 weeks for update of Backupper... ridiculous in my opinion.

    >sitting duck< image

  • Why oh why are you delaying a fix so you can release a new version with other improvements. This is not a minor but a major problem. If you gave a damn about your customers this would be a priority only fix with a quick release then work on other improvements. I am guessing when it is released it will be a major upgrade requiring people to pay to upgrade if they do not have a lifetime license. Very poort show guys. I for one are giving up on you and will not be recommended you to friends. I will stick with Reflect which at least works.

  • I've had a different experience with AOMEI Backupper Pro 3.5 after installing the Windows 10 Pro Anniversary Update (Version 1607) earlier this month on a test computer.  For me, scheduled backups have worked normally as long as I do not use the "Backup with Scheme" feature.  I had been using the "Space Management Scheme" part of that feature to create up to a set number of weekly differential backups from a full backup, after which a new full backup was automatically created.  But now, with the same settings, I get a new full backup every time the scheduled backup runs instead of any differential backup.

    Without "Backup with Scheme" selected and a daily differential backup scheduled for testing, I have gotten normal differential backups from the schedule until I manually run a new full backup, even when I shut the computer down each night between the scheduled backups.  I have not had to delete and recreate the backup schedule after a reboot.  And I have not seen the behavior of the scheduled backup running only four times.  Six daily differential backups have been created so far from the same backup schedule, and one of them ran even after I missed starting the computer until a few hours after the scheduled backup time.

    Of course, I would like to see the "Backup with Scheme" feature, especially the "Space Management Scheme" part, be returned to normal operation.  Note also that I see the same behavior from AOMEI Backupper Pro 3.5 on my main Windows 10 computer, which still has Windows 10 Pro Version 1511 with all updates for that version but not the Anniversary Update (Version 1607).

  • edited September 2016

    Sorry for all the inconvenience of the software with the WINDOS 10 anniversary version. Now we release the new 3.5 version which solve the related problems. Please try to install the new version to use. If you have the paid version, please contact the  [email protected] to get the upgrade version.  If you are the standard user, you can donwload it from this link.  http://www.backup-utility.com/free-backup-software.html Please uninstall the  program manually, reboot computer ,reinstall the problem, then reboot again. If you just reinstall the new version directly, maybe the driver will not be removed compeletly and you will get the same problem.Hope  it will solve your problem. But if you have another problems, please tell us to improve it. Sorry again for the all of that and also thanks for your support and understanding.

  • Why should we have to contact support ? Why isn't the upgrade push via check for upgrade ? Also the link provided above is for the old version 3.5 and dated 7/11/16.

    Please I need to use the software

  • @UpBear Sorry for the problem you encounter now. Please send us the screenshot of the scheme setting. And also hope you can give us the screenshot of the folder directory you save the backup image.

  • edited September 2016

    Where is the download link for the new version of Backupper Pro? (version 4.0?)

    I have contacted support and sent them an email; I get no reply and I cannot find a new version on the AOMEI website: still there is only version 3.5...

    Me thinks that first we were old sitting ducks, now we become very old guinea pigs for beta testing new version... >sigh< But where is the new version???


  • edited September 2016

    Ahem. Are you sure you've got your kernel drivers (i. e. ammntdrv.sys and amwrtdrv.sys) signed with an Extended Validation certificate from Microsoft?

    I'm asking because my Windows 10 AU is still saying that Backupper's drivers cannot get installed because they are not signed with an EV certificate.

    The actual problem is that on systems with UEFI Secure Boot enabled, and a clean installation (this isn't the case for upgrades of Windows, e. g. from Windows 10 to Windows 10 Anniversary Update) of Windows 10 Anniversary Update (i. e. version 1607), Extended Validation certificates for kernel drivers are required. Anything else won't work.

    I've noticed that the certificates of Backupper's setup file have been renewed to SHA1 and SHA256 certificates valid from 2016-09-21 to 2019-09-22. That in itself is good, but it doesn't solve the problem. Your have to get Extended Validation certificates for your kernel drivers issued by Microsoft (if I remember this correctly, Microsoft charges roughly 600 USD per driver for these - as they have to check the drivers in-depth).

    See the links in my post here for details.

  • Let's rephrase that slightly in order to make it more clear:

    Your have to get Extended Validation certificates issued by Microsoft for your two kernel drivers "ammntdrv.sys" and "amwrtdrv.sys".

  • edited September 2016

    @RiseT: Thank you for your information. I suppose you are directing this information to the people/programmers of AOMEI in order for them to get the drivers of the update signed by Microsoft in the correct way, that is with extended validation.

    But the non-signed drivers aren't the only problem. If you already have Backupper installed before the Anniversary Update the non-signed drivers shouldn't be an issue. Windows10 should only check for that if you newly install the program under Windows AU. So there is more going on with the program... more specifically the scheduled backups and/or backups with a scheme are failing after a reboot. Maybe the drivers do refuse to start correctly after a reboot, who knows...

    There is an entry in the Event Viewer regarding Backupper:

    "The description for Event ID 0 from source Backupper Service cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer. If the event originated on another computer, the display information had to be saved with the event. The following information was included with the event: Backupper ServiceBackupper Service in OnLogon"

    In the mean time, we - the customers - are still waiting for the update to get thnigs fixed. There is talk of a new version by the admin of this forum, but we are waiting almost 9 weeks now. I cannot use the program, my computer is vulnerable this way, and I am almost forced to look for another backup program, although I have payed for life long support for Backupper Pro.

    There still is no word of Customer Support, where I should be able to get the new version/update... Makes me all very sad and upset...


  • @renehoss: Just curious - are you using an UEFI system with Secure Boot enabled?

  • &RiseT: yes UEFI system with secure boot. May it is possible to make Backupper run correctly with secure boot disabled, but that makes my system vulnerable and can't be the meaning of running security and backup software?

  • edited September 2016

    After some more testing and again reinstalling Backupper Pro: it really does seem to be the option "backup with scheme" (which handles disk space management) which causes the problems (as mentioned earlier by UpBear).

    If I create a scheduled backup without "scheme" for disk space management the scheduled backup seems to survive a reboot.

    But it is just the option of disk space management (only found in the Pro version) that makes the program very useful to me... Well, back to the waiting game I suppose...

  • edited September 2016

    I have been contacted by support, they gave me a link, unfortunately this link goes to the old 3.5 version of Backupper Pro... so where is the new version? It still does not work!


  • @RiseT  Sorry for all inconvenience. You get the problem still. The problem might be because the drivers of the old version fail to be completely removed.
    Please uninstall the program manually, reboot computer, reinstall the program, then reboot again.

  • @renehoss. Also sorry. the fixed verion is also 3.5 not 4.0 version. If you get the problem again.Please uninstall the software mnually---restart the computer---reinstall the software--restart the computer. For the shcedule backup problem,our colleagues reply you with the email. Please send the log and the "task2.2.xml" file to us again. Sorry.

  • edited September 2016

    @admin: Thanks for your reply.

    1. I've uninstalled Backupper via Windows "Apps & Features". After uninstalling and rebooting, I've noticed that your uninstaller script leaves these drivers (and a couple of other files) on the system - even after uninstalling. So I deleted those driver files manually and did another reboot.

    2. After rebooting, I've ran your new Backupper setup. Again, I got the message that these drivers are not signed with an EV certificate.

    3. Then I examined your new "ammntdrv.sys" and "amwrtdrv.sys". Sorry to say, but they are indeed not signed with Extended Validation Certificates issued by Microsoft. Like the Backupper's setup file, they are signed with cross-signing certificates issued by Symantec. And yes - I'm sure that these are your new driver files as the Symantec certificates are quite new, issed at 2016-09-21, i. e. a couple of days ago.

    So again:

    Please get Extended Validation certificates issued by Microsoft for your two kernel drivers "ammntdrv.sys" and "amwrtdrv.sys". You just cannot do this with Symantec certificates. You have to submit your driver files to Microsoft's Dev Portal.

    Again, the background and the specifics how to do this are described here.

  • I tried to 3.5 version on the latest version of Windows 10, or the Anniversary edition. I still have the exact same problem I had since upgrading to Windows 10 Anniversary edition. When installing AOMEI Backupper it installs and gives me an error saying the drivers are not signed. If I selecton Windows 10 to "Reboot" it will reboot back to the desktop screen. BUT if I select to "SHUTDOWN" from the Windows menu and SHUTDOWN my PC and then restart it my entire system crashes with a blue screen telling me my PC needs to be repaired, only way for me to fix this is to restore my system from an Image backup using a competitors backup software. 

    I would like to use AOMEI Backupper and up until the latest version of Windows 10 that forces the certificate validation it worked fine, now it simply will not work and crashes my entire system when attempting to try and install it as I described above. 

    To be fair, I've had the same type of issue using a few competitors image backup software, I found one that does not have this issue and until Aomei gets this problem fixed "IF" I should say I will be using something else. 

  • When I say version 3.5 "It's the version the Admin said was supposed to be fixed" as of the last day or so, not the older version 3.5. Aomei should give a different number for a fixed version, if nothing else version 3.5.1 or something different.

  • edited September 2016

    As it seems there is nothing fixed yet. I have had contact again with Support, I emailed them my task file and log files, and again explaining them the problem. I hope this will help solve the issues.

    That I was able to install the 'new' 3.5 version (indeed why not make it 3.5.1?) was due to the fact that I had Backupper already installed prior to upgrading to Anniversary Update,... I think. It seems that Windows doesn't check if the program was already installed. Anyhow, at least I didn't get blue screens after reinstall.

    But apart from this driver signing problem (as explained extensively by RiseT) there is also the problem that scheduled tasks that have a scheme for disk space management (pro version only) simply won't run on the allotted time after a reboot. If I remove the disk space management scheme from the scheduled task the program runs fine even after having turned off the computer.

    Also there is information in Event Viewer regarding Backupper and the drivers that there might be some sort of corruption.

    So, serious problems I guess, and I just wonder if these problems are recognized by AOMEI, because 9 weeks of bug fixing without solution makes one wonder.

  • edited September 2016


    "That I was able to install the 'new' 3.5 version (indeed why not make it
    3.5.1?) was due to the fact that I had Backupper already installed
    prior to upgrading to Anniversary Update,... I think."

    The EV signing of kernel-mode drivers is only mandatory on (UEFI/Secure Boot) systems with a clean/fresh install of Windows 10 Anniversary Update (e. g. with a Windows 10 AU DVD using an empty HDD).

    Systems that have been upgraded (e. g. by Windows' update mechanism) from Windows 10 to Windows 10 AU on the other hand aren't affected by this new requirement (at least at the moment - might change in the future).

    This probably explains why you've had no problem installing Backupper.

  • edited September 2016

    @RiseT  Can you contact us and send the mail to the [email protected]? We want to solve the problem with Timeviewer? Can you do the remote assistant? @renehoss  For the version of 3.5 problem, we do not change it because we want to release the fixed version quickly. If we change it, we need to re-edit the software, it will take long time. For the prolem you get now, we will try to find it ASAP.

  • @RiseT In addition, could you try to disable Secure Boot and then run AOMEI Backupper again?

  • edited September 2016


    Installing Backupper with Secure Boot disabled:

    I will try, but I'm pretty sure that it will work when disabling Secure Boot. As I've written before, the requirement for Extended Validation Certificates signed directly by Microsoft only applies to systems with a) Secure Boot enabled AND b) a cleanly/freshly installed Windows 10 version 1607 or higher (both of these conditions have to be true at the same time)

    But that's not a real solution or an alternative to getting your drivers signed by Microsoft - it's just a work-around. In order to get that "Windows 10 Certified" label/sticker computer manufacturers put onto their computers, these manufacturers are required by Microsoft to enable Secure Boot out of the box. And since all newly sold computers will have Windows 10 Anniversary Update (version 1607) or higher pre-installed from now on, computers with a) Secure Boot enabled and b) a pre-installed Windows 10 version 1607 or higher will be the new norm. On all of these computers Backupper won't work until you get your drivers signed by Microsoft. You just cannot tell all these users that they have to disable Secure Boot (and weaken their computers' security by doing this) in order to properly install Backupper.

    It's very simple for you to reproduce this configuration and thus the problem on one of your own computers.

    What you need in order to reproduce this is the following:

    - A computer with UEFI and Secure Boot enabled

    - An installation medium (e. g. DVD) containing Windows 10 version 1607 (Anniversary Update) or higher

    - A connected empty hard disk as the boot drive (to install Windows 10 AU on)

    Freshly install Windows 10 from the installation medium on such a system, and I guarantee that you will run into the same problem.

Sign In or Register to comment.