Backerupper - amwrtdrv.sys causing BSOD on Windows 10

13»

Comments

  • Hello Tjsepka,
    Please try the following version:
    https://drive.google.com/file/d/1mMS49ygKoWFcEacDw6T6KDdZ-lQP6AUZ/view?usp=drivesdk
    Please first uninstall AOMEI Backupper you have installed via Control Panel, then delete ambakdrv.sys, ammntdrv.sys, amwrtdrv.sys under C:\Windows\System32, reboot the computer, install the new version we sent.
  • Here reference names are made to our previous posts. Everything here applies to Microsoft Windows 10.

    Successful unattended backups have been made on both System A and System B now for two days.

    Manual backups can be triggered with "ShortcutTaskAgent.exe" with no problems on both systems.

    To sum up our findings.

    1. If you use virtual drives (Storage Spaces) do NOT try to install Backupper to one of those drives. Install Backupper to the default "C:" drive only. It MAY work but it MAY NOT and cause problems. In our case the latest release of Windows 10, with the unmodified Backupper 5.8.0 installed on a virtual drive worked just fine. Another almost identical system caused no end of problems. Note that Windows Version 20H2 Build 19042.421 released just today claims to have solved the Storage Spaces problems referred to in a link in our last post.

    2. Manually purge older versions of Backupper and install the Backupper modified 5.8.0 test version. Earlier versions, especially 5.6.0, 5.7.0, and 5.8.0 (unmodified) may cause serious problems and loss of data.

    Exactly why and how these various factors inter-relate to sometimes cause problems we don't know but this is our workaround.

  • This is amazing. Can't solve the problem in three years?! Because of this BSOD, I had to switch to Acronis.
  • edited September 1
    The cause is indeed known for more than 3 years, and it is the file amwrtdrv.sys.
    The only version of this file that is working correctly is of the test version of Backupper.
    The file is dated 12-19-2019, 17:57 and is 27.360 bytes.
    This file is for Windows 10 only.
    Problem is that AOMEI wishes to keep Backupper compatible with both Windows 10 and Windows 7. The test version doesn't work well with Windows 7. The test version prohobits the BSODs from occuring in Windows 10 only.
    For some strange reason the technicians at AOMEI don't seem to be able to make a installation file that installs the "regular" driver on a Windows 7 system and the "test" driver on a Windows 10 system. That would solve all problems with the BSODs.
    The correction of this problem is so simple, and yet it takes a frustratingly long time to implement.
    Solution (workaround): Install the test version, copy amwrtdrv.sys to a safe place. Then install the regular version, find a way to copy the saved test version of amwrtdrv.sys to C:\windows\system32 (this could be done in command shell mode outside of Windows) and then reboot.
  • edited September 1
    In all honesty I don't know why AOMEI is bothering to keep compatibility with Windows 7, most software companies see Microsoft discontinuing support as a get out clause not to bother with previous operating systems and lets face it, it's not like these people can't still upgrade to Windows 10 for free, let the stubborn windows 7 users stick to whatever version is working for them and the rest of us get future updates without this BSOD issue or make 2 versions, if it is so hard for the installer to account for different operating systems. Pandering to users of previous operating systems is going to hold things back and cause this BSOD issue to make AOMEI Backupper not a viable backup software for most Windows 10 users, giving it a bad reputation and advertising it as compatible with Windows 10 right now is not really being honest. The test version does work for me btw, but it means I am stuck with that version until another test version comes out and it's not like I'm going to be informed when that is.
  • the solution is very simple. Since I no longer believed that there was a solution from AOMEI, I installed Macrium Reflect and the crashes are gone.
  • I have been using AOMEI for years, I installed this on a BRAND-NEW PC fully updated, and on the first automated task scheduler I got this error..

    If I use the service does this prevent this error?  Thanks
  • What's the compatibility with various editions of Windows server?
  • I was going to buy AOMEI but now I am not so sure....
  • edited October 8
    entilza5 have you tried the test version as mentioned back in this thread somewhere. It solved things for me. In all honesty since this problem has existed for years, it is high time it was resolved either by ditching Windows 7 support as that seems to be what is causing the issue or by having two versions where the windows 10 version is kept updated along with the windows 7 version.
  • edited October 13
    I have not tried but I can... I just got this crash on another computer... ok I will try this. 

    I'm going to the other lager thread, thanks
Sign In or Register to comment.