Backerupper - amwrtdrv.sys causing BSOD on Windows 10

2

Comments

  • In short we are laboratory mice! Even deleting the forum account is not possible.
  • @JO45 ;

    Just give up. This problem has been around since 2018. I was using Aomei for 2 years and thought it was a great product and recommended it to all my friends. I think I became proficient enough and tried to help as many as I could with the minor workings of the program on this forum that they made me a forum moderator and I appreciated that. I don't write very often on the forum now because I stopped using Backupper in Jan 2019. I couldn't handle a back up program that crashed every time a scheduled back up ran. I still visit the forum often and delete all the spam "Air Jordan" posts (of which there are many) but not fixing a bug this bad in just a few weeks is unacceptable.  
    What amazes me is the I still use Aomei Partition Assistant and find it be a first rate product but I guess Backupper must be handled by a different group of programmers.  
  • @ Wssddc,
    Generally, you don't need to disable the Vss service when you use AOMEI Backupper. Only to verify if the BSOD problem with the version we offered, you can temporarily disable VSS. If there is no problem, we will update the solution to the official version. The official version doesn't need to disable VSS.

  • edited June 17

    I installed v5.7 from the link provided by Admin earlier in this thread. The Backupper Service seems to have a problem when I shutdown or restart the computer, causing a lengthy delay. Event Viewer displays the following error message after restarting the computer: "The AOMEI Backupper Scheduler Service service did not shut down properly after receiving a preshutdown control” (Event ID 7043). If I first open the Services menu and stop the Backupper Server manually, the computer shuts down or restarts normally with no lengthy delay.

  • ;Winuser,
    Thanks for your feedback.
    Could you offer us the event log so that we check?
    In addition, "causing a lengthy delay"--What service is delaying? Could you give us a detailed description so that we check? 
  • And now we have version 5.8 and it still has the old corrupt driver in the installation files.
    The culprit file is amwrtdrv.sys and is of the year 2017.
    The test version of amwrtdrv.sys is of the year 2019 and works OK, it is not giving any BSOD.
    So please, insert this newer file into the installation setup.
    Why keeping the old file that is giving people troubles?
    I simpy don't understand anymore...
  • I also stopped to use Aomei, too petty.
  • Admin,
    The problem service was ABService.exe and it would cause the computer to hang on the restarting windows screen for 60-90 seconds instead of the 3-5 seconds it normally takes. Once the computer was done restarting, the Event Viewer would log Event ID 7043 and state  "The AOMEI Backupper Scheduler Service service did not shut down properly after receiving a preshutdown control.” I have since completely uninstalled this v5.7 and reverted to v4.61 which was the latest version that doesn’t cause BSOD errors for me. Sorry, but the event log is not available.

  • edited June 21
    I see the same message about the Backupper 5.8 scheduler service not shutting down as reported by Winuser (and taking longer than usual to do a system shutdown).  The service does shut down quickly if stopped from computer management.  I'm not using scheduling, so I stopped and disabled this service.  But just starting Backupper enables and starts it again.  OS is Win/10 1909.
  • Has anyone tried 5.8 Professional yet - does it fix the  Amwtdrv issue?  Thanks!
  • As for BSOD problem, please download the new v5.8 from here:
    https://drive.google.com/file/d/1Ns3vvcqTBgxnQGBaKdFdTPdnh3Dtdw5p/view?usp=drivesdk
    It is AOMEI Backupper Standard edition. If you have a license code, you can register on it.
    Please first uninstall AOMEI Backupper you have installed via Control Panel, then delete ambakdrv.sys, ammntdrv.sys, amwrtdrv.sys under C:\Windows\System32, reboot the computer, install the new version we sent.
  • @Winuser, sorry for the inconvenience.
    could you install v5.8 we sent and check if you will get the problem again?
  • I installed the test version listed above, including deleting the 3 .sys files first.  The scheduler service still doesn't shut down properly when I shutdown or reboot.  net stop "Backupper Service" works quickly.  Admin - can you split messages about this off into a separate thread?  It's a separate, less serious issue and it's likely to get lost in this thread.

  • @Wssddc Could you tell us why you need to close the Schedule service? If you shut down it, the backup can't start.
  • I stop the service just before shutting down or rebooting so the shutdown will be quicker.  Other than a delay and event log entry, nothing bad happens if I don't stop the service.
  • It seems the issue still exists in version 5.8, I was hopeful it was resolved, I have been stuck on version 4.06 since it is the only version that does not BSOD my PC, I installed version 5.8 with hope, but first backup performed with it....bam...BSOD. I am still debating whether to claim my money back under the money back guarantee, it's pointless me having lifetime upgrades if I am stuck on an old version and even the backup schemes do not work as expected, which I will cover in another post and these are why I upgraded in the first place. I know it must difficult to identify the possible cause when there are so many different machines of different specs out there, but in all honestly is there simply no way of getting an older version of the driver to work with the later versions of the software? I did some testing and putting the driver from 4.06 in place of the driver from v5.7 did stop 5.7 from doing any BSODs, the backups succeeded and verified without issue, restores worked fine on the three I tested though there would never be any way of knowing if there was actually any kind of file corruption as there are too many to test, however the Windows Event viewer did report an error coming from the backupper service whilst this driver was being used, so bordering on caution I simply reverted back to v4.06 which I haven't had any BSODs from.

    I am hopeful that this issue gets resolved, though looking how long it has been going on, it does not seem very likely, I like the new interface in the later versions, it looks much cleaner than v4.06 but I can't risk all these BSODs, they will inevitably cause hard drive errors in the long term, since there is disk activity whilst a backup is taking place.
  • @Frankthegeezer
    Version 5.8 doesn't fix the blue screen issue, did you try the test version? 
  • Hi, I was not aware of the test version, could you direct me to where I can get this.
  • Scrub the previous message, I looked back through the messages and saw the link to google drive, I didn't realize that was an official test version. I will give it a try and report back my experience.
  • I've installed the test version of 5.8 and, so far, no BSOD. I replaced the ABservice.exe with the file specified in a similar forum thread and my computer now shuts down and restarts normally. Should I refrain from following any update prompts when opening the program or will  both of these fixes (BSOD and shutdown error 7043) be incorporated into an upcoming update? Thank you.
  • I am a 'ditto' to Winuser
  • edited July 13
    I wanted to allow sufficient time for testing and I can confirm that the test version has resolved the issue in my case too. I have had 16 daily scheduled backups succeed without coming home to find a blue screen and also the manual backups I have done, have not had any problems. I am also curious whether to refrain from future updates if prompted or whether there will be integration, don't want to be back where I started next time there is an update. I am on Windows 10 v1909 64bit (OS Build 18363.900) for anyone interested.
  • Actually, the solution is not compatible with Windows 7 system. Our technician still needs to analyze further. 
    So, please temporarily keep the test version of 5.8 to use. If we solved the problem in windows 7 system, we will update the solution to the new version. We can't confirm if the next version will include the solution. 
    Once we release the version including the solution, we will tell you on the forum. Sorry for the inconvenience.
  • Actually, the solution is not compatible with one of our Windows 10 systems either.

    Two of our Asus systems here are using virtually identical components.

    System A
    Asus M4A785T-M motherboard with AMD 4 core 3.2Ghz processor
    "C: drive" - SSD 120GB
    "D: drive" - 3 x 500GB hard drives as a virtual 1GB parity array (Windows storage spaces)
    o/s - Windows Version 20H2 (19042.388)

    System B
    Asus M4A785-M motherboard with AMD 4 core 1.8Ghz processor
    "C: drive" - SSD 120GB
    "B: drive, D: drive, E: drive, F: drive, G: drive, H: drive, I: drive, X: drive" - 3 x 2TB + 13 x 4TB hard drives totaling 32GB virtual parity arrays not counting hot standbys (Windows storage spaces)
    o/s - Windows Version 2004 (19041.388)

    On both systems the Aomei software resides on the "D:" drive. The Aomei backs up only the "C:" drive. Aomei Backupper has been used on both systems for six years (since version 2.0.1). On numerous occasions there have been system problems or retrogrades which were successfully restored with no errors.

    System A operates properly to this day using an unmodified Aomei version 5.8.0. System B however, started having backup problems when "ShortcutTaskAgent.exe" first appeared. On this system, if this shortcut was activated the system would immediately spectacularly crash trashing the "C:" and "D:" drives. Then with version 5.7.0 and now 5.8.0, when a backup is activated by the Task Scheduler, the system immediately crashes once again trashing drives in the process.

    We have downloaded the modified Aomei 5.8.0 and replaced the three DLLs as suggested with the following result:

    "...
    Backup is initializing...
    Checking volumes...
    Backing up the information of storage device...
    Backing up of the volume 0 (C:)...
    Backup is initializing...
    Checking volumes...
    Backing up the information of storage device...
    Backing up of the volume 0 (C:)...
    Information Code:4140
    The backup driver works improperly, you could restart the computer to solve the problem.
    ..."

    We tried the suggested troubleshooting procedure ...
    "...
    Solution:

    1) Please restart the computer and retry to do the operation. If the error still appears,
     please uninstall the program manually and then reboot the computer to reinstall the
     software.

    2) Open elevated Command Prompt (run Command Prompt as administrator), enter the command
     net start ambakdrv then reboot the computer. Please also try to enter
     C:\Program Files (x86)\AOMEI Backupper>LoadDrv.exe command and reboot.
    ..."

    This procedure did not solve any problems.

    To sum up, we have gone from a very reliable backup system to one that rather than restoring data on troubled drives, instead, trashes drives itself! Unbelievable! The latest Aomei backup solutions were obviously not thoroughly tested and were not ready for release, even as Beta software. These releases are causing the very problems they should be designed to protect.

  • Hi KNet,
    Sorry for the inconvenience.
    As for 4140 error, could you send us log folder under the installation directory of AOMEI Backupper so that we check and analyze? 

  • Here I will make reference to systems "A" and "B" as per my previous post.

    One difference between the two systems not noted before is the backup drive which is a USB 3.0 drive on System B.
    System A backs up to "\\<server ip>\Backup\WinImages\..."
    System B backs up to "B:\WinImages\..."

    On System B we ran the Uninstall program. On completion there still were a few old files left on the "D:" drive where the program was installed. There were also a few old Aomei files left at C:\Program Files (x86)\Aomei. The system was then purged of all Aomei Backupper files.

    Then the modified 5.8.0 was installed.

    It was set up and run once successfully from the Task Scheduler.

    We the ran "ShortcutTaskAgent.exe" with success.

    We installed the modified 5.8.0 on System A with the same results.

    So all is good for now. We will monitor the situation.

    Attached are logs for System A (unmodified 5.8) and System B (modified 5.8 with new DLLs).

  • Hi KNet,
    Did you mean that error code 4140 has been solved after reinstalling v5.8?
    If you get the problem again, please send us the new log files so that we check.
  • edited July 22
    Those were the new log files that I sent. Yes, no more error codes.


  • ... no more error codes but no more Backupper on System B.

    Backupper missed scheduled backups during the night.

    Now The Task Scheduler will not start "D:\Program Files (x86)\AOMEI\AOMEI Backupper 5.8.0\ABCore.exe" <task ID> 0

    It produces Windows error 0xC000012F

    There are no entries in Windows Event Viewer.

    The ABService is not running. It is set for Automatic Start.
    After reboot the ABService is still not running.

    Upon investigation we found that none of the functions of Backupper will start including the main program.
    Any attempt to start any Backupper function produces Windows error 0xC000012F - "D:\Program Files (x86)\AOMEI\AOMEI Backupper 5.8.0\<dllname>.dll is either not designed to run on Windows or it contains an error."

    We feel there may be an incompatibility with Backupper and/or virtual drives like the one in which it resides and/or VSS and/or the o/s.

    Also note these:

    We have reinstalled the modified 5.8.0 Backupper to the SSD "C: drive" (C:\Program Files (x86)\AOMEI\AOMEI Backupper 5.8.0) and we will monitor the situation.
  • Here's my 2¢ on my 64-bit Win10 Pro Version 1903 (OS Build 18362.959):


    The fault appears to be driver amwrt.drv.  Mine is dated September 1, 2017, time 18:12, file size 38,320 bytes.

Sign In or Register to comment.