Home AOMEI Products Support

"Clean-up"...still issues...

Hi to all of you from Denmark :-)
Searched the forum, found this one here:
I have the same problems running Win11 (22H2) on a Lenovo Yoga. First of all: Everything works perfect,
and AOMEI backupper makes backup every night as scheduled. But it does´nt delete backups when
reaching the 10 backups as described below. I backup on a 512 Gb USB which is permanently attached
to the PC, and have som other things on it as well, so i think 10 sets of backups should be enough.
Settings else in the program: Full backup, no compression, just one folder (with subfolders) to backup,
amount approx. 30 Gb (Pictures, documents, install-files and several settings (*.inf) from a lot of programs.
Tried different settings to get it work, but i just get an errormessage when there´s no more empty space
on the USB-stick. The program does not delete the oldest back-ups at all.
I also tried to copy the annonced DLL, nothing changes at all.

Any solution so far? It´s of course not a big issue, as i can manually delete the oldest backups, but as long
as the program offers this function i think i should work :smile:


  • I am experiencing the exact same thing on Windows 11.
  • @ShelbyGT500, @RayD Please contact the support team via email. And, you might need to offer the log folder under installation directory of AOMEI Backupper and tasks2.2.xml file under C:\ProgramData\AomeiBR to check and analyze the problem further.
  • Thanks admin, done !
    Send to [email protected], hope that´s OK


  • So ! Now i tested over some days. Everything works fine! I just had to pass the back-up file thsat was created the day that i made the task in the Aomei Backupper.....and now it deletes all the files as wanted :-) Thanks a lot!
Sign In or Register to comment.