Home AOMEI Products Support

My PC fails to boot after installing latest paid for Backupper Pro v7.1.2

I have used Aomei backupper for some years with no problems.  My last copy which was a version 6.x one the 1yr licence had expired.  So I bought a new lifetime licence on the 22 Feb 2023.  

Its been a lot of grief.  After installing the new version (which I accepted would un-install the existing version) I find my Toshiba Satellite laptop with Windows 10 hangs up on boot.  Various diagnostics the laptop did failed to fix it.  Manually I asked to do a System Restore (windows) and that worked and I booted up okay.   Again did the Aomei install and licence key and when I shut down and started up again it hang at the Toshiba opening screen.

Did this again to confirm and yes.  I did NOT ask this new version to insert itself into the laptops startup screen as an option but it seems it has inserted something that maybe clashes with another program I have already got?  Laptop fails.

Is there a way I can have Backupper Pro without it fiddling with the startup ?


  • I had a thought and installed a copy of Aomei Backupper Pro v6.2.0 trial and that worked fine and did NOT affect the boot up one bit.   

    So I then tried to register it with my recent licence for v7 and it failed to accept it.

    As a fix (having tried v7.0.0 as well as 7.1.2 repeatably many times) and always getting my computer bricked so it won't boot) can I have a copy of v6.x and a licence code.   I think I am entitled to that at least after all the trouble I have had with my purchase of the current release of Backupper Pro on my Toshiba laptop.

    Where should I ask for this ?
  • @AndyT, Sorry for the inconvenience. Please allows our team to check and solve the problem.
    Could you contact the support team ([email protected]) and submit the problem again via email?
Sign In or Register to comment.