Home AOMEI Products Support

Backupper Pro Not Deleting Backups?

As per the post title - no matter what I try, Backupper Pro just will not delete backup sets as specified in the backup scheme (by quantity). I've reinstalled Win 11 twice in the past 6 months, but it's the same every time - I even put Backupper on first (and nothing else) after the reinstall and it still persists, so it has to be something to do with Backupper rather than a system/software issue.

Has anyone ever heard of or resolved this issue?


  • I am having the same problem under Windows 11.   I recall that Backupper used to clean up under Windows 10 - I just cannot recall whether it ever worked under Windows 11.

    I have tried different cleanup schemes - none seem to work.
  • I am having the same problem under Windows 11. Nothing I try works.
  • I'm having the same problem.
    1 Backup Task (runs weekly) set as:
    Incremental Backup, after 3 incrementals create a full backup
    Keep 2 Sets

    There are 4 sets on the drive....

    Another task (runs daily) set as:
    Incremental Backup, after 30 incrementals create a full backup
    Keep 2 sets
    There are 3 sets on the drive...

    Aoemi Professional 7.2.0 on Win11
    Any advice?

  • @Uptix, Please check if every set includes 1 full+3 Inc. If the version type and number are not correct, the "backup cleanup" will not work. Maybe some backups are not created completely due to some reasons, or you changed the backup scheme after some backups are created, which causes versions incorrect.
    Please try to manually delete these backups, and then close "backup cleanup" and save, then re-enable it. After that, please check if it will work.
  • Admin, thanks for your reply.

    Just to check that I understand you correctly -
    I have deleted the older backups leaving just one complete set, plus the set that is in progress.

    IE - for the weekly backup scheme I have one full backup + 3 incrementals, and this weeks full backup.
        - for the daily set, I have left the previous full backup + 30 incrementals, and the curent full backup and the 14 incrementals it has so far in this cycle.

    I have then edited the two tasks, turning OFF 'backup cleanup', saving the task, edit it again turning 'backup cleanup'back on.

    Is this what you meant?
  • @Uptix, Please delete all backup image files. And then, edit the two tasks: turning OFF 'backup cleanup', saving the task, edit it again turning 'backup cleanup' back on.
  • Thank you for the clarification.

    I have moved all the backup files to a different drive - the destination folders for both tasks are now empty.

    I have edited the two tasks, turning OFF backup cleanup, saved them, edited again turning backup cleanup back on, and saving again.

    With both tasks set to 'Cleanup by Quantity' and 'Retain 2 sets' I am expecting:

    The Weekly backup scheme should never exceed at the maximum,12 files:
    (the current Full backup and up to 3 incrementals, plus two 'retained' sets (2 Full backups + 6 incrementals),

    The Daily backup scheme should never exceed at the maximum, 93 files:
    (the current full backup and up to 30 incrementals, plus two 'retained' sets (2 full backups + 60 incrementals).

    I've set up a powershell script to run after each task (a nice Aomei feature in the 'options/Command' section in the backup task) to monitor the file counts in each task's folder.

    Thank you for your attention,
  • @Uptix, 'Retain 2 sets'---Generally, it will delete the first set backups, when the third set has been completed.
  • I have the same issue. I'm on Windows 11. Now my 20TB hard drive is full and can't backup anything anymore. Please help
  • "I have the same issue"
    Please create new post in forum, we will help you there.
Sign In or Register to comment.