Cannot mount or explore a verified image

NebNeb
edited July 5 in AOMEI Products Support
(for AOEMI Backupper Pro lifetime)

I did a partition backup of my data partition yesterday, including integrity verification. Everything went fine according to AOEMI. This morning I tried to mount and explore that image, and get the error:

Q:/ is not accessible.
The file or directory is corrupted and unreadable.

Any ideas about what might be wrong?

I'm currently moving that data from one drive to another. If anything goes wrong with the move, it appears now that I do not have a backup of it - gigabytes of precious family photos and videos. This is making me very nervous. There have been two or three little things that have sent warning signals about this software so far, and now that I can't mount a verified image, my gut is screaming 'Don't trust this software!'

EDIT: I desperately need to take a trust-able, functioning backup of this data once it is moved. If I install the free edition of Macrium Reflect for this purpose, the two backup programs won't interfere with each other will they?

Comments

  • Just an update: Macrium Reflect worked fine and did not conflict with AOEMI. I can breathe again knowing that I have a working backup of my data.

    I still have the AOEMI backup, if someone wants to suggest how I can mount and explore it?
  • Try using q-dir. Most people say that will work if Explorer doesn't. http://q-dir.com/
  • Thanks for the reply.

  • Just for information - I asked for a refund over this issue, because Backupper stated that the backup was verified (when it was likely corrupted), and that it was mounted (when it was unmountable). Further, it was just a simple full back-up of a data partition; not a more complicated system back-up, or incremental back-up.

    I know all backup software has its problems and failure rates, but I couldn't continue to use this software without accurately being able to ascertain whether the backups were functional or not (unless I manually mounted and explored each image myself). And now I don't think I could have confidence that the restore process would work, even if the image seemed OK.

    AOEMI were very good though. After asking for a refund, they first offered me technical support for the above issue, and then acted promptly when I pressed for the refund. MyCommerce/Digital River handled it within 24 hours.
Sign In or Register to comment.