Getting an error 4099 when trying to restore files.

edited January 2015 in AOMEI Products Support

I made a full file backup and formated my pc. Now I cant restore my files. Help!


  • Could you describe your problem in more detail?E.g.Whether there is a error prompt?

  • The exact error message that I get is:

    File restore initializing...

    Calculating the total number of files...

    File restoring...

    Information code: 4099

    Uninitialized component or function cell.

  • Hi X4mple,

     Are you trying to restore files to a fresh install version of Windows?

    Or trying to restore to the formatted disk?

    Are you restoring from backups created on a CD, or external HDD?

    There should be a log file created...find that and attach so that we can determine more for you.

  • I'm trying to restore to a fresh install of windows and i have the backup on a external HDD


  • X4mple,

    Please check your image by using Utilities--Check Image. Then post the result.

  • Sorry about the silence, I'll do it soon!

  • X4mple,

    Another suggestion that I have is to create a bootable medium either through Aomei PE Builder or Backupper, boot the computer from it then attempt to restore your image from there.  This way, if your installed OS is causing any issue, it shouldn't matter when restoring.

  • I am having the same problem.

    I am trying to restore the desktop after a new OS( Win7) install.

    I can see the files in the Explore Image funtion, but when I try to extract the, I get this:


    File copy initializing...

    Calculating the total number of the files...

    File copying...

    Information Code:4099

    Uninitialized component or function cell.


    When I check image, it seems to be intact:

    Checking private structures...

    Checking backup data...

    The image is valid and integrated.

    The operation has been completed successfully.


    If you need a log file to helpme, please instruct me on how to get it.

    Thank You!


  • Hello. I'm also having the same error codes and messages as above. This is on a fresh install of WIndows 7 64 bit, home premium. I verified image and everything seemed intact. I've tried using the PE Builder, and same results. I can't restore my files...and i have 51 DVD's backed up! :-( that was a whole lot of time. This was my first time using it. I gave it a try after reading some of the positive reviews. But me personally,right now I just feel I can't recommend this software to any one I know. Not sure if there's a way I can piece all of the backed up media into one folder, and then maybe try to restore from there? Any suggestions?

  • Find you log files under the following:

    C:/Program files x(86)/AOMEI Backupper/log

  • i'm having the same issue.

    I backed up user profile and tried to restore after laptop refomatted and installed Wins 8.1. I'm running Backupper Standard 2.8, updated to latest version but still not restoring. Message as follows;

    File restore initializing...

    Calculating the total number of the files...

    File restoring...

    Information Code:4099

    Uninitialized component or function cell.

    I have 100GB of data I need to restore and is irreplaceable. 

    This is not a good start to using your product. PLEASE HELP ME RESTORE THIS IMMEDIATELY

  • I suggest you guys make a bootable media with drivers added to restore the file backup image to a new location.

  • Same issue here.  Backed up a Win XP SP3 machine's user folders using file backup, now I've installed Backupper Pro 2.8 on a new Win 7 Pro x64 machine and am unable to make it all the way restore before getting this error.

Sign In or Register to comment.