Home AOMEI Products Support

AOMEI Backupper Pro - Full Backup Scheme will NOT delete older full backups

edited August 2018 in AOMEI Products Support
Hello, have spoke with tech support but still no luck. Been using AOMEI Backupper Pro on two Win10 machines. Creating lots of full backups. Problem is when creating a Backup Scheme - "Full Backup Scheme" will NOT delete any older full backups! The backup keep adding up. The only way to free up space is to periodically delete the older full backups from their folder location. Please advise. Still waiting for a solution.


  • Did you backup to NAS?
  • The backup location is a second local HD on each of the PCs, not NAS. Could it have something to do with the windows task service or built in task service. I am set to build in service and can switch to windows?
  • Did you send the log files? What does the tech support say?
  • Yes I sent log files a while back and there was still no resolution. I am happy to send log files again but I am seeing the same behavior on two different Win10 machines.
  • If there's still no resolution, I think they need more time to fix the issue.
  • Well it would be great if the developers could acknowledge there is a bug in the backup scheme module and they are working to fix it?
  • They are already aware of this.
  • Hello,
    what do you mean with "They are already aware of this."?
    - they know, that people have problems with the logic of backup schemes, but there is no bug
    - they agree there is a bug, but at the moment they don't work on it
    - they agree that there is a bug and they work on it

    I sent also log files. In my case the program tries a full backup instead of difference backup and doesn't delete automatically older files. After sending the log files, there is no response ...

  • Seems to be working with new product update. Installed Backupper Pro 4.5.1, Deleted the old backup job and images. Created a new full backup/full backup scheme and older backups are now deleting themselves as scheduled. Will continue to monitor. Thanks for the fix.
  • Bump-- For anyone else searching for an Answer to this old bug--> This bug is still going on in 2019 in Version 5.5.0. It works again after an update for awhile, then stops again.. apparently the only other way to get the backup scheme to work again is to delete, then recreate all your backup tasks, but then it eventually stops working again.
  • @hiredgunz48 Did you backup to NAS?
  • No Admin, external drives, but the external drives would have nothing to do with backupper's backup scheme working after deleting then recreating the previous tasks, then failing to follow the task settings next day or two again, and forcing another tasks deletion/recreation, at least for me... Thinking so would be like a city having traffic lights that all work as programmed one day, but next day they are not working as their programming dictates, and then wondering if the cars caused it... There are no errors reported by Backupper or windows 10 event logs for backupper failing to remove old backups according to the task settings. Nor any disk read or write errors, bad drive clusters or drive file system errors.
  • @hiredgunz48 Maybe the drive letter has changed? Did you check that?
  • edited December 2019
    No the drive letters haven't changed.. If it had changed, there would be a disk write error when attempting to run the task, because of the program not finding the correct disk to backup to... Any other questions that aren't relative to Backup Scheme being broken? I've watched the backup complete, and the old backup is NOT deleted as it should have been, which would mean that if the Drive letter was changed, there would have been NO backup in the first place, and since there WAS a backup, and the old backup is NOT deleted as it should have been, then Aomei Backupper Professional's Backup Scheme function is STILL Not working as it should...
  • If the drive letter is changed, the program will create a new full backup, no errors will be thrown, so the old backups will  not be deleted. Maybe you could check the issue more carefully.
  • If the drive letter is OK, please upload your tasks2.2.xml file in "C:\ProgramData\AomeiBR".
  • Welp, I had an external drive that somehow had it's drive letter changed about a month ago, and when I tried to backup as usual, Aomei backupper screamed about not finding a path to the drive listed in the backup task, then left a nice red error notice that the task failed... all the while NOT creating a new backup... but hey, thanks for your input.
  • I'd also done a restore on one of my drives, and when I tried to run a manual backup on that drive, aomei backupper again gave me an error notice and suggested I check the FAQ for a solution, and NO new, full backup on that drive either... Aomei Backupper would not let me just re-select the drive as nearly every other backup program will do, (EaseUS ToDo Home will even tell you there was a partition change and suggests you re-select the drive in the task with out deleting the task as aomei makes you do)... Since aomei doesn't have this feature, I had to again recreate the task completely, eventually leaving a mess of unorganized tasks after repeatedly recreating task because there is no feature to order the tasks by name or whatever feature..And, I'm not even going to mention the "hacking the Windows Registry VSS files to exclude files and folders feature" that may leave your C: drive unbootable if you unknowingly make an error...So, admin..perhaps you and your company could "check the issues more carefully" and let me know when you've actually gotten Aomei Backupper features up to the premium features standards your company claims in it's sales copy? 
  • @hiredgunz48 Did you get a 4123 error?
Sign In or Register to comment.