Home AOMEI Products Support

Rescue Disk Won't Boot

I’m running AOMEI Backupper Pro on an older BIOS machine running Windows 10. I’ve created several boot disks through AOMEI’s tools using windows PE and the download option. I created an ISO file, burned it to disk and verified it. When I try to boot to it, it just hangs with a flashing cursor. Right now, I have no usable rescue disk. What can I do? Thanks



  • edited May 29
    Welcome Bekanak, there are many ways to use Aomei WinPE utilities. I have made many Aomei DVD utilities that work well for Legacy-BIOS, UEFI-CSM, and UEFI-nonCSM PCs.
    "I created an ISO file, burned it to disc"
    Please create a DVD directly instead of creating ISO file.
    If that does not work, you could use free 3rd party tool ImgBurn to create CD/DVD utility, and then it can check your DVD after burn to confirm it burned correctly. Most Aomei users use USB drives, you could try using BU to create a 1GB USB utility.
    If your PC is old, you can use their old PC tool that combines 7 tools in 1 DVD.
    If you are a technician, you can also use Ventoy, a 3rd party USB creator
    Aomei (Win)PE Builder USB:
    Best for PCs before 2020, includes Partition Assistant, Backupper, Recuva, 7zip, OSF Mount, CPU-Z, Bootice, DiskMgmt.msc. Supports x64 portable apps. Does not support any additional drivers, such as some internal M.2 NVMe disks.
    Free tools not from Aomei:
    Ventoy - Best Multiboot USB Creator
    Put all bootable ISOs on 1 USB Stick, open source
    ImgBurn - DVD burner

  • edited May 30
    Try using a high quality DVD Disc brand, such as Verbatim.
    Confirm the DVD type ( + )   ( - )  matches the DVD player type  ( + )   ( - ).
  • I did try to make a DVD directly in Backupper, but it makes it to 99% and then hangs. I also tried the USB approach, but got exactly the same result as burning the iso file - nothing but blinking cursor. This would seem to indicate that the problem is not the media, but the content.
  • Follow-up note. I tried the Aomei PE Builder, and it worked. I have a bootable disk. Thanks for the advice.
  • edited May 30
    "I also tried the USB approach, but got exactly the same result"
    The USB drive must be formatted as MBR ahead of time.
    You could try reinstalling BU.
    Free tools not from Aomei:
    Validrive - Detect Fake USB Sticks

Sign In or Register to comment.