Home AOMEI Products Support

Bootable ISO change language

I just updated the bootable ISO from 7.1.2 to 7.3.4 and noticed the Windows' Explorer is in Chinese. Is it possible to change this?


  • edited March 29
    @Dfg555, We have optimized the issue. Please try to recreate the WinPE and check again.
  • edited March 29
    I just tried it and it is still the same. Am I suppose to delete the contents inside this folder first so that it downloads the updated version?

    Also I tried it on my other laptop and the DPI/Resolution doesn't seem to scale well. I can drag the window but the graphics seem to bug out - ROG FLOW X13 2021. Works fine on my older laptop - XPS 9Q23.

    UPDATE: Just tested 7.3.3 iso and it is working fine. No graphics bug and the resolution/dpi is scaled perfectly for the ROG FLOW X13 2021.
  • edited March 29
    You could also try their older WinPE USB utility, that includes BU.
    Aomei (Win)PE Builder USB: https://www.ubackup.com/pe-builder.html Best for PCs before 2020, includes Partition Assistant, Backupper, Recuva, 7zip, OSF Mount, CPU-Z, Bootice, DiskMgmt.msc. Supports x64 portable apps. Does not support any additional drivers, such as some internal M.2 NVMe disks.
  • @Dfg555, Please try to delete pe_env folder under C:\Program Files (x86)\AOMEI\AOMEI Backupper\7.3.4.
    And, press Win+R, and type into %temp% to open temp folder. You can try to delete all files/folders under the temp folder.
    After that, please run AOMEI Backupper to create WinPE bootable media again.
  • Ok that is working and I can see that it has English support now however the trackpad no longer works and the resolution is still not scaled properly for the ROG FLOW X13 2021. I think I'm going to stick with my 7.3.3 ISO for now as this one is flawless.
Sign In or Register to comment.