Home AOMEI Products Support

If I use PA 10.3 to migrate OS to SSD, will the SSD be bootable?

Hi. I used the PA 10.3 "Migrate OS" function. It completed successfully.

Win10 Home
ASUS X551M-X451; UEFI-CSM (from msinfo32); GPT (HDD)
PA 10.3

Question 1: If use PA 10.3 to "Migrate OS" to SSD, will the SSD be bootable? Or, should I use "Clone Disk" or "Clone Partition" instead?

I tried both UEFI boot options but neither worked. 

Question 2: If I create a BIOS boot options, is it:  \EFI\Microsoft\Boot\\bootmgr.efi?


  • Before I did OS Migration, I merged 2 partitions. 

    PA 10.3 partition merge log and OS Migration log attached. 

  • edited February 11
    Hello Russ, your Windows system disk is not booting after MigrateOS with PA.
    Yes, PA MigrateOS is best for system disks that contain Windows.
    "UEFI-CSM (from msinfo32); GPT (HDD)"
    UEFI-CSM is an old boot option that was designed only as a transition for Windows system disks that had the old hard drive partition table type MBR, but also wanted to boot into the newer UEFI mode. Thank you for your screenshot, I see both your disks are GPT. Windows disks with GPT should always boot in UEFI-nonCSM mode. Please turn Compatibility Support Module off.
    "Sandisk Extreme"
    At least 1 Sandisk extreme disk type had a major firmware update. Please check with Sandisk, with your external SSD serial number, to confirm your disk firmware is updated, or it may have problems. PCMag wrote about this.

  • edited February 11
    I disabled CSM in the BIOS. I moved the UEFI SanDIsk boot option to be first. This caused blue-screen.

    ASUS X551M BIOS is from 2014 - 10 years old.

    I didn't see any driver updates for the SanDisk Extreme SSD 2TB => maybe only for V2 SSD.

    I put some screen-caps below that show BIOS information. Maybe there are ideas how I can boot the SSD clone of this old ASUS machine. I can boot AOMEI WinPE on same ASUS machine => I used WinPE Builder 2.0.

    BIOS boot options:

    msinfo32 - ASUS

    msinfo32 - SanDisk SSD

    wmic - BIOS

    regedit - BIOS

    Reboot with CSM disabled - Blue-screen

    Thanks for any suggestions and help.
  • edited February 11
    PC 1 ASUS X551M-X451 2013 4GB RAM
    Disk 1 HDD GPT 500GB
    Disk 2 Sandisk GPT 2TB External USB
    You used PA MigrateOS Disk 2 source > Disk 1 target.
    4GB of RAM is not enough for Windows 10, please upgrade to 8GB. A 2013 Intel Celeron CPU will be very slow. If you combine those with an HDD instead of an SSD, your end result will be an extremely slow Windows 10 PC that will expire in 10/2025, and be no longer usable at that time. What is your use for this PC?
    The source disk 2, was the clone created from PC 1, or another PC? If it was created from a different PC, please skip to step 5.
    Thank you for disabling CSM. Now your motherboard can only boot in 2 modes, Legacy-BIOS, and UEFI-nonCSM.
    1) Please go to another working PC, use an empty USB drive to create a Ventoy USB stick, boot that on this PC 1, and please screenshot the home screen of that utility, in the bottom left corner, it will tell you if you are in UEFI-nonCSM, or Legacy-BIOS.
    2) Please disconnect source disk 2, and any other disks. Keep target Disk 1 HDD connected.
    3) That is good that you told the motherboard to boot in a certain order. I have seen many motherboards ignore the desired boot order, and because it can ignore your desired boot order, please use the Temporary Boot key to force it to boot the disk that you want.
    Esc or F8.
    Alternatively, you could instead use motherboard > Boot Override. Most motherboards do not have that feature, but some do.
    4) If target disk 1 is not booting using step 3, then please insert Windows 10 or 11 USB > startup repair.
    5) If it still does not boot, then please clone the disk again using BU > System Backup, with universal restore setting.

    Free tools not from Aomei:
    Ventoy - Best Multiboot USB Creator
    Put all bootable ISOs on 1 USB Stick, open source
    Windows 10 Official Download

  • “Why use old ASUS?”
    - have 3 other ASUS exactly same - guy owed me $$$ years ago
    - PC1 has office 2007 and Acrobat pro xi
    - test physical cloning on older machines

    Let me try ventoy and I will respond with info. 

    Thanks A. 

  • edited February 12
    Hello Russ, I understand you are using old PCs to test cloning and disk management. Yes, Ventoy fully supports Legacy-BIOS, as well as UEFI PCs. It boots almost any ISOs, Windows, WinPE, Linux, other. You could combine Ventoy with Aomei ISOs.
    "PC1 has office 2007"
    Replace with free Libreoffice.
    Backupper WinPE USB:
    Add custom drivers, such as NVMe, if necessary. Does not work with some monitors.

    Partition Assistant WinPE USB:
    Add custom drivers, such as NVMe, if necessary.

    Aomei WinPE Builder USB:
    Best for PCs from or before 2019, includes Partition Assistant, Backupper, Recuva, 7zip, OSF Mount, CPU-Z, Bootice, DiskMgmt.msc. Supports x64 portable apps. Does not support any additional drivers, such as some internal M.2 NVMe disks.
    Free tools not from Aomei:
    Hirens Boot PE 1.04 - live USB tool suite
    Based on Windows 11, includes 160 utilities, 340 new drivers, old BU 6.5.1, PA 10.2.2. Put custom drivers, into the “CustomDrivers” folder.
    Supergrub 2 - Boot Absolutely Anything
    Validrive - Detect Fake USB Sticks

  • edited February 12
    Thanks A. Here is the ventoy screen-cap of PC1. 


    Please post a link for making “AOMEI WinPE iso” for ventoy. 
  • edited February 13
    Thank you, your 2 screenshots show you are in UEFI-nonCSM mode, which is the best mode for GPT disks.
    If PA > MigrateOS feature did not work to clone from source Disk 2 USB to target Disk 1 HDD internal, and you are in the right mode, then you could try cloning again, but instead use PA > Disk Clone with sector-by-sector setting.
    Russ can you confirm you have tried using your startup Temporary Boot key to force it to boot the disk that you want? Get there with Esc or F8.
    Could you reply if you have also tried motherboard > Boot Override, if yours has that feature.
    Could you please clarify if your source disk 2 USB external was cloned from a different PC, than the PC 1 we are troubleshooting? Or was it cloned from this same PC 1 that is above?
    "Please post a link for making “AOMEI WinPE iso” for ventoy. "
    I have posted an Aomei article on that, above. Ventoy is a utility not from Aomei.
    You could use BU, PA, or Aomei (Win)PE Builder 2.0 to create an ISO file. Then put ISO files into Ventoy partition. If you are new to Ventoy, please practice using it on a PC with an empty hard drive, so if you make a mistake, you will not lose data.
  • Hello again. I created a PE Builder 2.0 iso and it booted nicely under ventoy. Very nice set of tools. 

    I tried the ASUS <esc> fast boot for both boot options. Neither worked. 

    I think the problem is PC1 and the clone SSD are both NTFS - boot volumes (“SYSTEM”) are FAT32. I believe ASUS can only boot FAT32 from USB. I’m trying to verify. 

    I can boot WinPE 2.0 iso. I can boot ventoy with Win10 iso or PE builder 2.0 iso. None are NTFS. 

    Ventoy is exFAT. I can boot Win10 iso > 4gb. 

    Cannot convert NTFS OS to FAT32 because of 4gb file size limit. 

    Right now - it seems like old ASUS limitation.

    thanks for your help. If I have other questions I’ll ask.  
  • edited February 14
    "Sandisk Extreme 55AE"
    Were you trying to boot an internal Windows installation from an external disk? It is not designed to do that. To properly boot Windows from an external disk, you have to convert it to a Windows-To-Go, that is a different type of windows. If you are trying to get a normal Windows installation to boot, it must be connected by SATA, or M.2. Not by USB. Yes, in rare cases, I have seen it work, but one is not designed for the other. If you cloned from an internal Windows disk, then the target cloned disk should also be internal.
    "Cannot convert NTFS OS to FAT32 because of 4gb file size limit."
    MBR Windows disks have a boot/system partition, usually at the beginning of the disk, and can use either NTFS or FAT32 file system. Almost always, they are NTFS, but in rare cases they are FAT32. GPT Windows disks have a boot/system/EFI partition, usually at the beginning of the disk, and must use only FAT32, they cannot be NTFS. In rare cases, an MBR Windows disk has no boot partition, the Windows:C NTFS partition is used as the boot partition. On MBR Windows disks, the boot partition must also have the "Active" attribute/flag set. However GPT specification does not not have an "Active" attribute/flag.
    "thanks for your help. If I have other questions I’ll ask."
    Good luck!

  • edited February 14
    Thanks A. 

    Could I use the PA 10.3 SSD USB clone of PC1 HDD_1 to migrate OS to PC1 HDD_2?

    As we have discussed in this thread, PA 10.3 SSD USB is clone that does not boot.
  • edited February 14
    "Windows disks with GPT should always boot in UEFI-nonCSM mode"

    You are mistaken. All my machines have csm on. CSM has nothing to do with the op problem.
Sign In or Register to comment.