Home AOMEI Products Support

Each partition on cloned disk allocated a drive letter

Using Partition Assistant Pro to clone c: drive which has 3 partitions, 499mb recovery, 99mb efi & 465GB System with only the 465GB allocated a drive letter (C:). Cloned drive produces, the three shown previously and a fourth which is the unused portion of the new larger SSD and is understandable. The issue is that each partition is given a drive letter rather than producing one volume. Also why is the partition information all cramped up and unreadable on the main display, apart from the volume information which takes up half the screen?


  • edited September 2023
    Windows system disk has 4 partitions:
    Windows C
    Recovery Environment WinRE
    The MSR is a hidden partition that does not show up in Disk Management, and is not formatted with any file system, it is a binary backup of BCD information, and is only readable by the Windows system, please do not do anything to it. From 1981 to 2011, that used to be an even more secret partition on the end of the disk, but the rules of GPT say that is not allowed, so they moved it to the MSR location now on modern disks.
    On some disks there could be unallocated space, that is not a volume or a partition, just empty. Do not mount the EFI, MSR, or WinRE with a drive letter, they are meant only for system use. In rare cases, Partition Assistant or Disk Management may mount them with a drive letter, please remove it.
    Starting in PA version 10, they changed their design scheme, to remove useless redundant buttons, but unfortunately also some of the text is impossible to see. Also, if I press "Properties" button, nothing happens. I hope they will fix that.
    Aomei WinPE 2.0 Builder USB:
    Partition Assistant, Backupper, Recuva, 7zip, OSF Mount, CPU-Z, Bootice, diskmgmt.msc. Does not support any additional drivers, such as some internal NVMe disks.
    Hirens Boot PE - live USB tool suite
    160 utilities, old BU 6.5.1, PA 9.2.1. To add custom drivers, such as NVMe, simply put them into the “CustomDrivers” folder. Hirens is not recommended in combination with Ventoy USB.

  • @NeilC, Were you using the latest version of AOMEI Partition Assistant? Did you perform system migration? or disk clone?
    Could you take a screenshot so that we check the problem further?
  • @Admin I am using version 10.2, I updated after having the same problem with the previous version.

    I used Clone Disk - Clone Disk Quickly - enabled SSD optimization

    Cloning Disk 2 to Disk 1 gives the below result

  • @aiArtisan Thanks, I guess the MSR partition is the16mb one shown as other. It's partition assistant mounting them with a drive letter. After a bit of googling, I could remove with diskpart but am new to this so not really sure what I am doing, hence why I bought an aio softtware for a pain free experience.
    I too hope they sort the readability issue.
  • edited September 2023
    How to delete partitions in Diskpart:
    Cmd > Diskpart > lis disk > sel dis # > lis vol > lis par > sel par # > det par > del par.
    Basic commands in Diskpart are easy. The Commands
    lis vol
    det par
    are not required, they just give you extra info.
    If you are in WinPE USB, you can always type diskmgmt.msc to open the graphical Disk Management utility.
  • @NeilC, "Cloning Disk 2 to Disk 1 gives the below result"---The steps are normal. So, what is your issue?
  • @admin My issue is that the source disk is recognized as a single drive "C", the clone is recognized as 3 seperate drives and won't boot. It's therefore by definition not a clone. I would like to know what either I or the software is doing wrong and how to rectify it, so I produce a bootable duplicate
  • @aiArtisan Thanks for your advice. I tried removing the partitions, except for primary. Also leaving the partitions and removing the drive letters. Neither worked to get the bios to recognize it as a bootable drive if secure boot is enabled or disabled. Noticed Partition Assistant had created an empty folder called Boot in the root directory and deleteing that made no difference either. At least I am learning stuff I knew nothing about a week ago.
  • edited September 2023
    NeilC, I'm glad you are poking around and trying things. I provided information, but I did not recommend any course of action, I did not suggest deleting a partition would make your disk boot.
    You could try to clone the disk again, using disk clone method.
    Could you please help us with some more info:
    1) Motherboard mode Legacy-BIOS, UEFI-CSM, UEFI-nonCSM?
    2) What is the PC brand, year, model #, desktop or laptop?
    3) SSD 2.5", SSD M.2 SATA, SSD M.2 NVMe?
    4) Version of Windows, 10, 11, Home, Pro, Enterprise?
    5) Please post a screenshot of Cmd > Diskpart > lis dis > sel dis # > lis par > lis vol
    6) Please post a screenshot of Disk Management diskmgmt.msc

  • Well, it was a case of umpteenth time lucky. Did nothing differently than before, but the bios recognized it as a bootable disk this time and works just fine. Disproving the theory that doing the same thing over and over again leads to the same result and madness.
    Thanks for your help.
Sign In or Register to comment.