Home AOMEI Products Support

File backup blocked by files "in use"

I'm a new user of AOMEI Backupper Standard, and I'm trying to create a file backup of C:\Users\\AppData and C:\Users\\Documents. I think these two directories will give me a pretty complete backup of my data, which I can restore on top of a less-frequent system backup to recover from a system catastrophe.

It isn't working because Backupper encounters files that are 'in use' -- even if no other applications are running -- even if no other applications have run since I booted. Some of the files "in use" are EXE files under the AppData directory. Microsoft apparently has forgotten one of the basic rules of system design accepted since the 1990s: keep programs and data separate.

But never mind that. Some of the specific files "in use" are astonishing, such as C:\Users\\AppData\Local\Microsoft\WindowsApps\bash.exe. This is a component of Windows Subsystem for Linux. I not only am not using WSL while I try to back up; I have not used it since I built this machine.

So: Is there any way to make Backupper back up files that are in use in a file backup? (My previous backup program, NovaBACKUP, had no problem with this.)

If not, is there a practical way to filter EXE files and other non-data files out of my backup set?

If not, can anyone recommend another backup program that doesn't have this problem?

I'm leaving NovaBACKUP because the company no longer sells it -- they only rent it by the month. I'd just as soon wear rented underwear. Any product that's available free, or is sold for a reasonable price, is a candidate.


  • Backupper WinPE USB:
    Add custom drivers, such as NVMe, if necessary. Does not work with some monitors.
    Aomei WinPE Builder 2.0 USB, includes: Partition Assistant, Backupper, Recuva, OSF Mount, CPU-Z, Bootice. Does not support internal NVMe disks, or other additional drivers.

  • @Orthoducks, Please try to reboot the computer, and then start the backup again. If it still said that some files are being used, maybe some system processes are using these files. You might need to skip these files. If you want to back up them, you might need to do the file backup under WinPE.
    Or, we suggest that you can do a system backup to back up the whole system partitions.
  • I rebooted and tried again, but got the same result. Backupper says that 158 files are in use. Its error box only displays three of them at a time, so I didn't try to get an overview of them, but they seem to include the entire data directory of the SQL Server database that one of my applications uses. SQL Server presumably is running in the background as soon as I boot. I probably can shut down the database engine to release those files, but not all of the files "in use" are in the database. How many processes am I supposed to shut down every time I do a backup, then restart afterward? How am I even supposed to find them all? This is not a viable solution. Booting Windows PE every time I do a backup, then restarting Windows afterward, is not a viable solution either. Running a daily backup should not require two reboots. Backupper has to do any better than this, or it's not a viable tool for anything but full system or partition backups. Which means that it's not a viable tool at all.
  • @Orthoducks, We also can't confirm which processes are using files. There are no other ways to optimize the situation.
    We suggest that you can use a system or partition backup way to back up.
Sign In or Register to comment.