Home AOMEI Products Support

Can't change destination drive/folder in Backupper 5.3.0

This is the srangest issue. When I click on the destination line I get a file selector with "Folders only" as file types.
But when I select a drive or folder and click open it justs open that folder - and does not exit the file selector.
How do I select a drive/folder and return to the backup program?  (I only have "Open" and "Cancel" buttons).


  • @LarsErikOsterud, Could you upgrade to the latest version to check it again?
  • Latest version can't clone GPT. And last time I tried it it messed up the UppFilters/LowerFilters settings (made my computer not boot). I managed to change the folder by editing the config file. But it is a strange issue, and happends on all my computers (two Windows 10 and one Windows 11).
  • @LarsErikOsterud, "Latest version can't clone GPT."---What error message did you get?
    ""last time I tried it it messed up the UppFilters/LowerFilters settings (made my computer not boot).---Did you mean that the latest version (7.0) has the problem? But, we have fixed it since v6.8.
  • Have you tried cloning with Partition Assistant instead? Are you using the free version? If you install the software, then uninstall it, it will give you a button to buy it at 50% off.
  • edited February 2023
    I am seeing the same problem as LarsErikOsterud, with the latest version (7.1.2). I can't select a destination for a backup, all I get is the "open folder" dialogue. Re-installing the software hasn't helped.
    I reported this problem back in 2020 and the support team were unable to resolve the problem then either.
  • @JohnD, "I can't select a destination for a backup, all I get is the "open folder" dialogue"---Backup feature will create a backup image file. So, it needs to select a folder as the destination.
    Please confirm what purpose you want to achieve.
  • Reply to Admin:
    I an trying to create a system backup on an external USB drive. But I have the same problem when trying to create a normal backup too. The destination comes up as "D:\" (which is a local drive). Can click this and choose "select local drive and path", which brings up the "open" dialogue box. I can navigate to my external drive, but the dialogue box only has buttons marked "open" and "cancel" so there is no way to select the drive and folder I want to specify.
  • edited March 2023
    In the dropdown, click Select a Local Path then click the computer icon in the left pane of the browse dialog that opens.
    Double click on the D partition and then click on the folder you want to save in to highlight it..
    Click Open
  • When I do that, the dialogue box displays the contents of D:. I can navigate to whatever path I like but the only dialog buttons are "open" and "cancel". There is no option to say "this is the folder I want to use". The only way I can dismiss the dialogue box is to select "cancel".
  • edited March 2023
    Select a local path

    click the computer icon

      double click the partition that has the folder

    click the folder to highlight it

    then click open

    and your selected folder appears as the destination

  • Yes, I understand the way it is supposed to work. But when I click on the 'open' button, the dialog box just displays the contents of the backup folder.  Here is a pic of an empty directory I want to put the backup in, but clicking on 'open' does nothing. The only way to get rid of the "open" dialog box is to click on 'cancel'.

  • @JohnD, Could you send us the log folder under the installation directory of AOMEI Backupper (C:\Program Files (x86)\AOMEI\AOMEI Backupper\7.2.0\log) so that we check the problem further?
Sign In or Register to comment.