Home AOMEI Products Support

AOMEI Partition Assistant suddenly hangs on start with external drive via USB

The problem did not exist earlier versions but started to suddenly emerge with version 8.9 as well as version 9.1

Upon starting AOMEI Partition Assistant the startup screen hangs eternally on "loading (*:) partition 2 on disk 8..."

Disc 8 through 11 (4 drives) are all single partition 1TB drives in a external RAID10 connected via USB3.  All drives are new and in excellent shape.
This problem did not occur with versions lower than 8.9.

Other hard disk partition managers, i.e. Paragon, Acronis Disc Director have no issue. 
So obviously it is a design bug in AOMEI Partition Assistant that needs to be resolved!


  • @Dorcom. Could you remove the external drives and run AOMEI Partition Assistant? When it open AOMEI Partition Assistant, then connect them again.
  • Tried that before, does not work.
    AOMEI opens but when external RAID is connected and "refresh" clicked, AOMEI does see drive.
    Upon AOMEI restart back to same old dysfunctional jazz.
    AOMEI App is not capable dealing with external drives connected via USB3 and hangs.

  • [SOLVED]
    The issue with AOMEI hanging with the external drive has been resolved.  There was a unbeknownst to me small hidden partition with no letter assigned.  Once this partition was deleted and merged with the existing problem disappeared.
  • @Dorcom, Thanks for your feedback.
Sign In or Register to comment.