Home AOMEI Products Support

8GB disk image restored to 32GB disk won't boot

I have backed up a disk - Compact Flash 8GB - using AOMEI Backupper. If I restore it to another 8GB CF, everything is fine, but if I restore it to a 32GB CF, the system (running XP) won't boot.
The 32GB CF after restore has an OS partition, a recovery partition, and the rest of the space is unallocated. 
The image contains an OS partition and a custom recovery partition. If I use the XP setup's recovery mode and run fixmbr, the system boots, but the boot prompt to press a particular key (F3) to launch the custom recovery process doesn't appear.

Normally, when I boot, I am presented with a message Press F3 to enter recovery mode. If I don't do anything, the system boots to the regular XP environment.

What is happening now (with the 32GB CF) is that I see the message:

Press F3 to enter recovery mode
ErroPress F3 to enter recovery mode

The error message is being overwritten. I have no idea what it is supposed to be. Pressing F3 does nothing.
Please help me fix this.


  • @Sam01, Could you boot the restored system and press F3 to enter recovery mode from another 8GB CF?
    Generally, our program can't handle the recovery partition. It will back up and restore the recovery partition as a common partition.
  • Sorry for the delay in responding. I just got access to the device. I checked with another 8GB CF. Everything works - recovery and all. Pressing F3 at boot up takes me into the PE based recovery environment. I didn't actually use the recovery mode - just chose to exit and restart in normal mode - but I'm pretty sure it will work. I never got to this stage with the 32GB CF.
  • @Sam01, Did you restore the same backup file to the 8GB CF and 32gb CF?
    Could you try to clear all partitions on the 32gb CF, and then do the restore again? When restore, please don't resize partitions.
  • Yes, same backup file - it's the only one I've got.
    I cleaned the 32GB CF with diskpart.
    I've tried without touching the partitions. Then I thought maybe the unallocated space was causing problems, so I tried adjusting the partitions. I even tried moving the recovery partition to the end of the CF, leaving the unallocated space in the middle. Nothing works. In every case, I get the error in the OP. ErroPress F3 to enter recovery mode
    I have to use fixmbr from the XP CD to make the 32GB CF bootable.

    I think a Microsoft tool was used to make the recovery partition. I'll try to reverse engineer that and see if there's another way to fix this. Thanks for trying to help.

  • @Sam01, Sorry for the inconvenience. We have submitted the problem to our technician to check and optimize further.
Sign In or Register to comment.