Home AOMEI Products Support

Back up continue to fail

Hi - my backups are all failing - no matter what drive I try to write to or from - since the last two weeks or so.  I get the following message but a restart doesn't help (it happens for both my C and D drives): 

"Backup is initializing...

Checking volumes...

Backing up the information of storage device...

Backing up of the volume 0...

Backing up data...

Backing up of the volume 0 done.

Backing up of the volume 1 (D:)...

Information Code:4140

The backup driver works improperly, you could restart the computer to solve the problem."



  • @Spodeworld, Sorry for the inconvenience.
    As for the error 4140, 1) Please restart the computer and retry to do the operation. If the error still appears, please uninstall the program manually and then reboot the computer to reinstall the software.
    2) Open elevated Command Prompt (run Command Prompt as administrator), enter the command net start ambakdrv then reboot the computer. Please also try to enter C:\Program Files (x86)\AOMEI Backupper>LoadDrv.exe command and reboot.
    3) Please open your Windows Security and Virus&Virus Protection and add "AOMEI Backupper" as an allowed app to make changes to protected folders. And, please close the Ransomware Protection in Windows Defender and retry.
    4), please type into Win+R, type into "regedit" to open Registry, navigate to the path
    select and right-click "UpperFilters"-->Modify, then check if there is the "volsnap" value under "ambakdrv". 
    If not, please add the "volsnap". After that, please check if you will still get error code 4140.
  • I did steps 1 - 3, and still having same problem.  

    Will move on to step 4.
  • @Spodeworld, If you still get error code 4140 after checking the above methods, please contact our support team ([email protected]) via email. They will help you check the problem further via remote.
  • Hi - Just went in to regedit.  I don't see "UpperFilters" 

  • I have the same issue. Backupper 6.5

  • @Spodeworld @SIW2,  Please download upperfilters.exe from the link. Then, run it as administrator to create the "UpperFilters". After that, please run AOMEI Backupper to do backup again.
  • The google drive link is not working.

    I had already tried adding the upperfilters reg entry manually. Stuck on starting windows.

  • Same here when I try to download UpperFilters 
  • @Spodeworld Please try the link  to download again: http://www.multcloud.com/share/08e6186e-d0aa-41c4-81a5-595d8073e5f5
    @SIW2, please power down your computer, then boot it again. If it still can't boot, please try to reboot into safe mode, then delete the UpperFilters, then boot again.
  • edited April 2021
    Hi - maybe I'm missing something, but this is what i get when I click the link.

  • @admin is there supposed to be a file to download from that link?  There's nothing there when I click on it.  Thank you for your help.
  • @Spodeworld Sorry for the inconvenience. Please first confirm if your system is Windows 10. If yes, please download and reinstall AOMEI Backupper from here: https://drive.google.com/file/d/1Pk8X0Kq2Vq71HFzZJE8IHc3BEtuU_2oj/view?usp=drivesdk
    If you have the license code, please use it to register the version.
  • Hi @admin I downloaded and reinstalled - same issue (it is Win10).  
  • edited April 2021

    the new version you linked worked in putting in the upperfilters reg entry. I was able to make a test backup image and mount it.

    On reboot, stuck on starting windows again.

    I used boot media to delete the upperfilters entry and then was then able to boot into windows.
  • Well, not sure what changed, but it started working again yesterday!  Thanks for all your assistance.
  • @Spodeworld, We forget to say: please reboot the computer after installing the version. 
  • @SIW2, Are you using the win10 system? Could you install the new version and then reboot the computer? If it still can't boot after reboot, could you allow us to do a remote on your computer?
  • Same problem here but with error: Information Code:4103
    This occurred recently. I have tried several disk and same problem. it runs for some time and then aborts after 15%, 25% 37%. The backup disk seems to be okay. no error reported and I copied lots of large files without a glitch.
    Now I doubt if older back ups are okay.
  • @AKoppa, Please contact the support team and offer the log folder under installation directory of AOMEI Backupper to check the error further.
  • @Admin. I tried another backup program and it failed too. So I run SFC /scannow and the Windows Resource Protection found corrupts files in the external disk and fixed. Then I tried to back up again with same results. But, in despite of the fact that I could copy several large files to the external disk I tried another external disk and voila! It worked just fine.
    In short, the problem was the external disk.
    Thanks for your help.
Sign In or Register to comment.