Problems restoring

I received a new PC recently.  A Dell optiplex 3070.  I installed Aomei standard and did 3 system backups.  1 after a fresh install. and 2 with various programs installed.  Today I wanted to restore the fresh install for the first time to try something out. I initiated the restore via windows and let it do its thing.  I selected system restore.  Chose all 3 partitions and basically let it do everything.  I only have 1 internal HD, plus the external which contained the image.  It took a long time to do what it needed to do.

When the computer restarted, Dell's OS recovery came up. It did a hardware scan and found no errors and then it wanted to go online to download the restore image to reset the computer.  It did not want to boot into windows. It absolutely refused to boot, nothing I could do. So for now, I am allowing Dell to do the automatic system restore (downloading via the internet, the image etc etc).

What did I do wrong?  How can I get my images to work if i make a backup? Is there something I am not doing?  I thought i should be able to simply choose restore, select my system restore image that I want and then let it automatically do what it needed to do, reboot and everything would come back up.

Comments

  • For now I am letting dell do the restore.  Once I get clarification from this forum I will try to restore from my image again and see what happens. 

    Before I did though  I had not created a recovery disk from that machines so I went to another machine to create it. I selected uefi. And had it create it with windowspe.  The dell would not see the usb to boot from it.  Did I need to disable secure boot to have the Dell see the usb drive to boot from?  Originally when I did the restore I did it from within windows. It did whatever it needed to do and then booted into its recovery consol. 
  • Here is a link to a step by step job aid for performing a system restore using Aomei Backupper.  https://www.ubackup.com/features/system-restore.html  You might read over the procedure and see if you followed the steps.

    Personally I always boot up my machine on a USB rescue media that I created on that specific machine to perform any restoral task.  I have found that by doing it this way I have the greatest degree of success because the rescue media contains the proper drivers and boot type for that specific machine. The creation of the rescue media and the type of rescue media is just as important as the backup if you want to successfully restore your system and be able to boot up the machine when you are finished.  First you have to find out what boot mode your machine is configured for.  Go to a command prompt and type in MSINFO32 and press enter.  Look down the list of items for one labeled as Bios Mode.  If the mode is set to UEFI then you want to create a WinPE UEFI rescue media.  If the mode is set to BIOS or LEGACY then you want to select the WinPE Legacy rescue media.  If your system bios is configured for compatibility (CSM support in the system bios) then even though the system information says UEFI it is really LEGACY.  One last point and one of the most important!  Always create the rescue media on the machine you are interested in.  One of the steps in the media creation process is to load the drivers for that unique machine onto the rescue media.  If you use a rescue media that was created on some other machine there is a good chance that your machine won't boot properly because some critical drivers may be missing from your rescue media.  I once used a rescue media that was created on a machine that contained a AMD chipset and Ryzen processor on a machine with a INTEL chipset and processor.  The restored system would not boot and I was left staring at a black screen with a blinking line for the curser.  So to be safe always create your rescue media well before you need it and from each unique machine that you have.  Most machine types have a function key that enables you to override the normal boot sequence.  On a Dell I believe that it is the F12 function key.  As the machine is attempting to boot repeatably press and release the F12 key until the boot override menu appears.  Then select the USB rescue device from the list.  I am not sure, but you may have to disable secure boot to be able to boot up the machine on a usb device. 

    With Aomei Backupper you have to create your backup image using the "System Backup" or "Disk Backup" selections because these are the only choices that create a bootable system disk upon restoral.  I remember when I first started using the product that I was choosing the "partition backup" option and it never would boot up on restoral.

    Hopefully this information helps.  If you have more questions let me know.  


  • I am running into another problem... I know I am supposed to create therescue media on the machine in question, but that is too late now.  Short of reloading the system and reinstalling aomei and then creating the rescue disk and starting over again....

    i checked the bios.  It is in UEFI mode.  I had to disable secure boot, so when i press f12 i get the option for removable media... otherwise i just get windows disc manager

    I loaded aomei on my other computer... went to tools, create winPE disc by downloading the image from aomeis servers.... it said it was complete, but when i went to view the USB key in explorer, there was nothing there.  No visible files.  i tried to boot off of it anyhow and naturally it said no boot .

    So tried to create a ISO. it created a 700mb iso file, which i then used rufus to create a boot USB in EUFI mode.  NOw i saw files on it in explorer.


    i tried to boot from that.  No errors stating that it could not boot anymore, but i just get a black screen, It never goes to WINPE for me to be able to continue the process. I let it sit there for 5 or so minutes but nothing changed.


    And as a FYI, i had created the backup using system backup.
  • @Ansset, Could you try to create WinPE bootable media via AOMEI PE Builder? It will integrate AOMEI Backupper you installed. Please download it from here: http://www2.aomeisoftware.com/download/pe/2.0/full/PEBuilder.exe
    After that, you can press F12 to boot from the WinPE media. Then, you can delete all system partitions on the disk, then perform the restore again.
  • edited December 2020
    I downloaded it, installed it, and ran it.... when it said it was done, I could not read the USB key at all.  Windows wanted me to format it.  So i went through the process again but using the backuper application instead of the WINPE creator.  Again it told me to format the key. windows explorer did not want anything to do with it.  So I tried a 3rd time, this time in a Vmware session. Same thing. 

    i then used PE builder to create an ISO... i then tried rufus in eufi mode to create the bootable USB stick.  That worked and i could see the file system when i view the contents of the stick in explorer.  However. once i select boot from USB device from the boot menu, i get a black screen. nothing happens.  Nothing loads.

    So i tried a different usb key with PE Builder... building direct to the new USB. This time windows was able to see it.  I was able to boot from it.  There must be something with my other USB key that aomei does not like.  If i format it in windows, it does work for data files, but no matter what i try with WinPE or rufus, it will not work.  But the new key does.  Not sure how that makes sense.

    I will try to do a restore from image and see what happens

    I came across this in a form post... should I do this?  and how can i tell if my drive is MBR or GPT?  the drive is a 256gb ssd.  I know that probaby does not help.  Are all 2TB or smaller drives ALWAYS MBR or can they be GPT?


    It would be best to use a clean disk. Follow the directions below. Use the procedure for your type drive; MBR use the first set or for GPT, use the second set of instructions. You can enter diskpart from the command prompt after booting from the Aomei recovery USB.

    You can simply use diskpart:

    2TB drives and smaller: (or MBR drive)
    1. Open the Start Menu, type diskpart, press Enter
    2. Type list disk, press Enter
    3. Type select disk X (where X is the number your drive shows up as), press Enter
    4. Type clean, press Enter
    5. Type create partition primary, press Enter
    6. Type format quick fs=ntfs, press Enter
    7. Type assign, press Enter
    8. Type exit, press Enter

    2.5TB drives and larger: (or any GPT drive)
    1. Open the Start Menu, type diskpart, press Enter
    2. Type list disk, press Enter
    3. Type select disk X (where X is the number your drive shows up as), press Enter
    4. Type clean, press Enter
    5. Type convert gpt, press Enter
    6. Type create partition primary, press Enter
    7. Type format quick fs=ntfs, press Enter
    8. Type assign, press Enter
    9. Type exit, press Enter

  • The easiest way to determine if the flash drive has a partition type of MBR or UEFI is to use the Disk Management tool in Windows.  Simply plug in your flash drive into a usb port, launch disk managment, position your mouse pointer over the flash drive disk number, click the right mouse button and select properties.  Then select volumes and look for partition style.  It will either be MBR or GPT (UEFI).  Ideally, if you follow Microsoft's recommendation for bootable flash drives, your flash drive should be 32GB or smaller.  I don't know if it matters but all of the ones that I have used have been formatted as fat32 or exFAT.  
  • edited December 2020
    In my case, the original USB was 8GB.... and I let the aomei software create the boot disc... and it never worked... it bugged out.  It worked just fine as soon as I put in a 16GB drive.

    What I wanted to know, is when I reimage a drive, do I need to run diskpart before I restore a system image or not? Originally I did not run diskpart, and when it finished, I did not have a bootable image. The Dell did not want to boot and the only thing I could do is let Dell do a system restore.

    I checked on another similar machine I have at home and it is GPT.

    I tried, and i ran into yet another problem.  aomei boots up from the stick now.  Problem is, it will only see the USB stick and the external HD with the image. It does not detect the internal drive.  The internal drive is a 256 SD NVMe drive.  When AOMEI made the boot drive, the only drivers it installed was for the wifi and the nic.  It gave no options for anything else.  So while I can select the image to restore, i cannot restore it anywhere.  Is there something I am missing?

    I did try diskpart, but when I do a list disk, it only lists the USB Key and the external drive with the image.


  • I just started using Aomie for the first time and unlike Acronis and other backup apps installed by OE on laptops, Aomie dosn't install a small protected proprietary boot sector on the HDD where it puts its recovery app. (that which Aomie puts on their Recovery Media).  USB's essential to boot into a restore app are a pain if the BIOS can't see them, not in UEFI,  bad slow Chinese dongles with fake size. or need mobo USB drivers installed. and for older BIOS and security you are left with CDs as the only dependable boot media to restore your Aomie backup. Aomie has options. You either select 'Disc Backup' which will be every Disc and partition on a physical drive, or you can select and choose an individual partions. I have 1 250Gb SSD partitioned into 2 drives - C & D where C contains Windows, Apps are on D BUT most apps write data to C so I used backup to restore both including the first Win sys boot partition. If you select partition backup, then in my case I can backup C, but that won't include the first small Windows boot partition or D. Once you make your choice you can't go back and restore more!

    I've been testing Aomie on a vanilla Windows install that I don't mind breaking. If you make a true disc image i.e sector by sector copy, that's a mirror and any file corruptions will get backed up. I haven't tried it with Aomie, but acronis has a safety feature - if the hdd has a corrupted format it spits out a corruption error and you have to checkdsk it first before the backup.

    When I created my Aomie recovery discs on CD (WinPEbot & Aomieboot) the write process bombed at the end but the tray ejected and the burns were good. However, numerous event errors related to the operation were logged afterwards so something is a bit flaky?

    If you use Rufus to create your bootable flash drive using a disc image and go the Linux option, it's no longer a Windows FAT drive but a bootable Linux flavour Ext4 or similar and can't normally be read on in Windows. That doesn't matter because it's only there to boot up Aomies restore app. catalogue your drives and find the Aomie backup file image.

    Even though I created Aomie bootable media and have set it to boot first in AMI bios, I often have to press F8 during bios boot to make sure I'm booting from it. Once you see their code running through and after a (long) wait, the Aomie restore screen eventually appears asking for the backup file. That's another downside of not using a fast protected partition - booting anything from cheap chinese flash memory with read times as slow as 10mb/S can take forever. There was a previous comment about using large USB drive when 650mB on a CD is plenty cos they only use about 411mb. The bigger the flash the larger the block size making it slower reading small files. IMHO most problems are OS file corruption and a protected partion rarely gets destroyed unless the disc itself is bad.

    I assumed Aomie would boot from a protected hidden partition which was my first mistake, I chose restore and ignored the screen wanting the recovery disc, which fortunately I had created. I don't know if their disc is keyed to one PC with its mobo drivers or portable allowing the same disc to recover an image saved on another PC, I could test that? Aomie appeared to 'restore' or so it seemed without the recovery disc, but at Windows re-boot I got the Windows Manager black boot screen up and nada. That was the lightbulb moment whe I realized that Aomie cannot restore without a working recovery disc, which is a pain because their app. should never appear to do a restore without it.

    I also had a Windows system backup and rescue CD as backup if Aomie failed. That has worked for me everytime without uncertainty.

    I may be wrong, but if your recovery disc/media from that PC is ok AND you used Disk Backup (ALL sectors) it should restore as a cloned drive with the same format as before whatever it was. If you only backed up the C drive and not the small system file of about 100Mb at the start, Windows may not start. Then you have the problem of trying to create that. Check your BIOS settings, mine is set to UEFI but legacy compatible MBR so I can always boot a flash drive however it was formatted.  If your BIOS is fixed at UEFI you can be fairly certain Windows installed as GPT by default, unless you converted it. If you still aren't sure, Rufus a bootable flash as UEFI and another as FAT32  to see what works. The last time I Rufused a UEFI boot flash, I had to copy some small files across from another working Windows PC for a uefi boot.

    Hope some of this helps.


  • My computer is set to UEFI and CSM (legacy compatibility) so I have to choose the WinPE Legacy option when creating my rescue media. 

    With Aomei Backupper I have found some of the terminology foreign to me so it has taken some getting used to for me to understand that I had to perform a system backup or a disk backup to create a backup that would boot when I restored the image.  Your understanding about a disk backup being similar to a cloned disk is for the most part accurate.  With the backup options there are some files that are not copied because they get regenerated with each boot so it is not an exact clone.  However, the disk partition structure and sizes are the same.  The only time that I use disk backup is when my primary drive has several partitions on it.  Then I have to use the disk backup so that I get all of the partitions on the drive.  I really haven't found a good explanation as to when you would need to do a partition backup.
  • Here is where I stand now....

    - I fixed the USB boot problem by using a different USB drive to have aomei create it.  It now boots.

    - My original image was a "system backup".  It created an image with 3 partitions on it.  See the attached image.  I assume, correct me if I am wrong, but I believe I created the proper image. I think all I should need to do is restore the system partition, reboot and it "should" work.

    - My computer is UEFI. I disabled the legacy compatibility in the bios of my dell.

    - When I press F12, I see 2 options. 1) Kingston USB and 2) Windows manager (or something like that)
    - If I press the windows manager option, it loads Windows 10. (i had used the dell recovery to get a working OS again. So it will load Windows 10. I just want to put my image back and not the default Dell image.
    - If I press the Kingston USB it loads aomei (no windows PE)

    - I can select my restore image, and it shows all 3 partitions.  I assume this is all I need to do when i do a system restore.

    - On the following screen all I see is my USB stick and external drive with the image on it. I do not see the NVMe drive.  It lists c: as the external and d: as the USB stick. Naturally, I cannot proceed from this point.

    - I am sure the drive is GPT, because I have another identical machine, and I looked at it and it was GPT based on what windows told me.

    So right now, I am not sure what to do.



  • I would turn compatibility back on and see if it makes a difference since it was on when you made your backup.  However, that means that you need to make a WINpe Legacy rescue media to get it all to work together.  Or use Aomei WinPE creator to make the rescue media (it will choose the correct type automatically).  The three partitions are what I would expect to see on a UEFI machine.  When you click on next you should see your NVMe disk.  Otherwise you can't restore the backup.
  • When I first made the backup, I did not have compatibility turned on. I had secure boot enabled.  By having secure boot turned on, compatibility mode is by default turned off because I cannot have both options turned on. In order to turn on compatibility, I must turn off secure boot.


    I created the USB recovery disk using the Aomei program and selected UEFI.  If I select legacy, will that show the NVMe disk? I am not sure why aomei cannot even see the disk, but I know I was on UEFI when I first made the image.

  • Can you boot up on the UEFI media and select the system backup option?  I am curious to see if you can see the NVMe disc then.
  • I left my PC at work because I was working on it there as I had the time.  However, I doubt it would see it, because if I go to a command prompt from the WinPE, and run diskpart only the USB stick and external drive show up.

    The only thing to try now would be to recreate the USB stick in legacy mode, to see if that would make the NVMe drive visible.  Though my computer is currently in EUFI mode.
  • I'm on Aomie Pro and I thought at first my Restore screen looked different to yours but I'm new at finding my way around. I have one 250Gb SSD split into 2 drives.My OS lives on Drive C. Installed apps with dependencies on the OS (which is most) live on drive D. Because of these dependencies I always have to recover both drives. Backups, source apps and anything big, 'created',  media or streamed media live on a separate 1Tb partitioned drive. I chose the Aomie disk backup incremental scheme. Now I see my Aomie Restore screen tells me my drive is Basic MBR which it must have got from the backup snapshot? Tha's probably because ages ago I realised that non of my trusted recovery utilities and disc tools worked with UEFI and that need overode using UEFI and acquiring new tools to manage it. When my drive is restored I no longer see the small size efi files in root, but they are there in Windows\boot folder, which I think are used to retrospectively convert (downgrade!) if you want to. 

    I agree some of the option choices are hard to understand and not always where you expect them. As with other backup recovery apps you have to try them out and make sure what you get after recovery is what you expect. On a non-critical Windows PC with not a lot on it, I would find and save the licence info, create the Windows recovery media (and test it!) then do a Windows full backup (clone) to another drive to use if Aomie didn't backup and restore as expected. Too many people set up the backup scheme and schedule only to find months later they can't recover. I had this happen with Acronis. Their default backup is always C and you have to add additional drives to the profile. In my case backing up the OS drive C and not D with dependent apps recovered a non working system. The worst thing MS ever did with Windows was to  allow app developers to store their data inside the Windows OS structure.

    I remember when creating USB sticks with Rufus et Al to boot recovery tools with the bios set to UEFI, I had to add  some folders & files to the stick which I copied from a working windows drive formatted UEFI. The stick has efi system files on it making it different to a normal bootable FAT memory stick, but it still boots in a non-efi system.

  • Ok I managed to get things to work.....

    - had to create bootable usb via aomei and select legacy
    - in bios:
    -- disable secure boot
    -- enable legacy boot
    -- still kept UEFI enabled though

    Now I was able to boot the USB and have it see the NVMe drive.  I ran into some other issues, and hoping the reimaging works.

    - I selected my system image.  See screenshot from an earlier post.
    - on the next screen I saw 3 drives.  USB + External + NVMe
    -- the NVMe drive showed something like 5 partitions on it. (I had used the online Dell recovery tool to reinstall the OS).
    -- At this point, I could not simply select Disk 0. Aomei wanted me to pick a specific partition. Somehow I do not think this is was going to work.

    - Exited there and went back to home
    - tools / command prompt

    1. From the command prompt, type diskpart, press Enter
    2. Type list disk, press Enter
    3. Type select disk X (where X is the number your drive shows up as), press Enter
    4. Type clean, press Enter
    5. Type convert gpt, press Enter
    6. Type create partition primary, press Enter
    7. Type format quick fs=ntfs, press Enter
    8. Type assign, press Enter
    9. Type exit, press Enter
    - from home screen, hit reload to reload the drive.

    - started the restore process again. This time when i selected the drive i wanted to restore to, i selected the one large 238gb partition labeled as c:

    - on the next screen it listed the 3 partitions with a green arrow pointing to one partition.  Again, not sure if this is correct or not.

    - I unchecked universal restore because the image was made on this machine, so the hardware has not changed
    - put checkmark on "SSD alignment"

    - started the process.

    - Success....  and i was able to boot into my reloaded image.

    - However, I noticed that I now had a 145MB unallocated partition.  Not sure why. And all windows disk management would allow me to do is create a simple partition. There was no option to join it to c:\.

    - So I went back to restore again, did the steps listed above (the numbered steps) and stopped at step 5.

    - restarted the restore process.  This time it finished with a 15gb partition that was unallocated.
    - so I redid the process a 3rd time doing steps 1-9 again.

    - is there a way i can incorporate that 145mb partition into c:\ ?

  • @Ansset, have you booted from the restored system? Could you take a screenshot of Windows Disk Management so that we check?
Sign In or Register to comment.