Cloning to a drive with bad sectors

I am trying to clone my HDD to a new SSD using AOMEI PA, however every time I do I get an error 34 indicating bad sectors on the destination drive. I have scanned the drive with the same program and indeed it detects bad sectors, so I tried to use the "Check partition amd fix errors by using chkdsk.exe" function. After that the next scan (not fast one) didn't show any damaged sectors, but trying to clone the drive again still turned up the exact same error 34. Can I somehow still get the Partition Assistant to clone the drive to the damaged one, or is there some other method I could achieve this?

Comments

  • I don't know if I would have a lot of faith in a backup that was stored on a drive with bad sectors.  Even if you could map and exclude the bad spots there is no guarantee as to the health of the other sectors on the drive.  Especially since SSD drive controllers use a technique called wear leveling to distribute writing across the flash blocks of the drive so all blocks will begin failing at the same approximate time.
  • From what I read it is normal for an SSD to have some bad sectors as soon as they leave production line, and the one I have is brand new.
  • The Matt, What you say is true that it is okay to have a few defective sectors on a SSD drive.  However, when you format the drive those defective spots are supposedly mapped out and replaced with a good spare.  If the defective sector is being detected and is not being mapped out then the drive must have used up all of the spare sectors that were available.  Since the drive is brand new then it would seem to me that formatting or initializing the drive should resolve the defective spot on the disc.  If not then I would want to RMA the disc and request another one.  Just saying.
  • @The_Matt,  Please run the "Disk Test Surface" on AOMEI Partition Assistant to check if there are bad sectors on the SSD. If there are no bad sectors on the SSD, please offer us the log folder under the installation directory of AOMEI Partition Assistant so that we check and analyze the error further.
    In addition, please also try to use AOMEI Backupper to do the clone:
    Download: https://www2.aomeisoftware.com/download/adb/AOMEIBackupperStd.exe
  • I have run that function before and after using "Check partition amd fix errors by using chkdsk.exe". In the first scan there were bad sectors, in the second scan there were none (I used the full scan, not the quick one, both times). Just to be sure, I run the surface test again today, and it still didn't find any bad sectors.
    I will try the other program and get the logs tomorrow when I next have access to that computer.
  • The log folder of Partition Assistant is attached in "log - PA.rar". Most files in it are from my various attempts at getting it to work some other weird way, but the newest one is of a "proper" attempt by using the Disc Copy feature.
    I tried using the Backupper as instructed, but while restoring the backup the process was also stopped by an error 34. I attached Backupper's logs too, in the file "log - Backupper.rar".
  • @The_Matt, Thanks for your information. According to log, it seems that it boots into reboot mode to perform disk clone in AOMEI Partition Assistant. Could you remember that you select WinPE mode or Preos mode?
  • I'm pretty sure I tried both as part of my troubleshooting.
  • @The_Matt, Did you also get the error code 34 when it reboots into Preos mode? If yes, could you send us log files under C:\AM so that we check?
  • I got error 34 in both situations, however I can't find any such folder, only a hidden C:\AOMEI folder that contains two files that don't look like logs.
    Every time the PC was rebooting after the failed attempt the reboot took over 15 minutes before I would eventually decide to force-restart the PC. Could it be the reason no logs were generated?
  • @The_Matt, please try to create WinPE bootable media via AOMEI Partition Assistant or AOMEI Backupper, and then boot the computer from WinPE to do the clone features.
    Make WinPE bootable media: https://www.diskpart.com/help/make-bootable-cd-wizard.html
  • edited August 26
    I did so, with both Partition Assistant and Backupper from bootable USB drives, getting error 34 both times. I attached their logs in the zip, though they are the still just logs from their respective "log" folders since the C:\AM folder still has not appeared. This time I did not have to force-restart the PC, it all booted as it should.
  • Have you tried to create WinPE bootable media of AOMEI Partition Assistant, and then boot from WinPE to do the clone?
    Did you still get the error code 34 under WinPE? If yes, we need to analyze the logs under WinPE. Please boot into WinPE media to do the clone again, if you still get code 34, please Click "Windows Command Line", Input "notepad", Click File-->Open on the txt document, find the log folder are in "Computer\Boot(X:)\ Program Files\AOMEIPartAssist", Copy the log folder to another drive.
    After that, please boot into the computer, and then send us the  log folder of WinPE.
Sign In or Register to comment.