Backup image from SSD system disk can't be restored

I have two "disks" in my setup. Each is a raid-0 array of two disks, being:
1: 2x SSD 240GB each -- system volume
2: 2x HDD 1TB each -- data volume

I recently tried to upgrade this 2x1TB array with a backupper backup+restore with an intermediate disk, and it worked flawlessly.

But the same full-disk, all-partition disk backup didn't work when I restored the system 2x240GB SSD array into a single 640GB HDD (GPT as well -- well, it wouldn't matter as I suppose the image also stores the disk's GPT layout).

It also uses UEFI with a 450MB recovery and 100MB fat32 UEFI partitions (inherent from windows 10 basic partition layout).

The backup takes a significant amount of time to restore (well, I'm restoring from a USB 3.0 HDD to a USB 3.0 HDD, and I backed up with "high" compression settings, so that's to be expected).

The first attempt failed before completion (I then just ensured firm cable connections and tried again overnight); the second attempt then worked fine. I had all the partitions and files in place. So it was time to try. Remember I was switching from SSD to HDD -- this was just a test to see whether the backup would work in case I needed it. My SSD is in good working condition.

I then completely unplugged the SSD disk and let boot through the replacement HDD. I didn't convert partitions to use the remaining space.

The boot started but never finished. I was never able to see the logon screen and just the circling balls all the time. That same HDD in GPT + UEFI used to boot fine the Windows 10 (and windows 8 before) installation media.

I didn't mark the "universal restore" checkbox as the only thing that changed was the SATA port in the motherboard and the hard disk hardware, nothing else. According to the AOMEI Backupper System Restore FAQ article, I only need to check that if restoring from a backup from another system.

Besides USB booting, I also disassembled the disk off its USB3.0 case and plugged directly in a motherboard's SATA port and I got the exact same result, so guessing something else must have gone wrong with the backup.

Both the backup and restore processes went (reportedly) flawless and I couldn't see any obvious error messages; tips on debugging the failing/stuck boot would also be appreciated.

My backup method was not System Backup, but rather the Disk Backup method. According to this, it should work: "That means if you back up a system disk via Disk Backup, after restoring it, the system can boot normally." (from the Disk Backup faq article).

Any ideas?

Comments

Sign In or Register to comment.