Differential disk backup restoration with Linux boot media

I was trying to do a disk restore in the Linux boot environment.  The files do not display a date and time so there was no way to tell which was the full backup and which were differential backups.  When I tried restoring one of the backup files it turned out that it was a differential backup since it completed very quickly.  I'm not sure what actually got restored  - I didn't check.  I gave up trying to understand what the screens were telling me.  The disk being restored was my GPT Windows system disk, with its standard recovery, boot, etc. partitions.

Fortunately I had a full backup from the day before otherwise I would have been screwed.  I believe all of my data might have been lost!  The restore process must be clear and flawless so people don't lose everything.  Maybe a restore wizard for each restore scenario?  I don't know the answer.

I also think there needs to be a detailed tutorial written on the restore process for all restore schemes in both the Linux and Windows recovery environment.

Comments

  • It is recommended to use the WinPE version.
  • I only used the Linux version because the PE version I wrote to a CDROM appeared not to work.  PE just took a very LONG LONG time for it to finally launch.  At other times, Windows responds to the disk saying to insert a bootable media.  I've learned to cycle power on the machine is the only way to get out of that scenario.  I think it gets confused where to look for the boot media.  Version 4.6.1 won't export an iso file (I have this noted in another post).
  • Is there a place in the documentation that details how to do a disk restore for an incremental backup and a differential backup?  I couldn't find any.
  • BTW did you try the legacy version of WinPE or the UEFI version? It appears that you need the legacy version since Linux only boots on legacy systems. So you must have a legacy system.
  • @Tjsepka Is this what you were looking for? https://www.backup-utility.com/help/disk-restore.html 
    Look at the bottom under tips. What it is saying is if you have incremental backups you need them all and with differential you need just the last one (along with the full they are related to).. OR...… when you list the backups, in steps 2 and 3, if you have incremental or differential backups, they will be displayed there and you should pick the one you want to restore your backup from.
  • edited December 2018
    @JohnnyboyGo There is no provision to select either WinPE or UEFI when creating a Linux bootable media.
  • @Flyer:  I did notice after posting the comment but I don't believe its in the User Manual, which is where I first go.  The information needs to be in the manual.  Anything that's needed to work with the software should be in the user manual first, and what's on line should match what's in the manual.  Right now information on using the software exists in two places, thus it suffers from a lack of a single point of maintenance, causing confusion.  And most importantly, all of the documentation must be available in the recovery environment through a help system.
  • edited December 2018
    @Tjsepka. That is not what I asked. But I reckon you did try the legacy version of WinPE.

    I recommend you try making another WinPE disk on another 32 bit computer. Preferably on Win7.
  • @JohnnyboyGo:  I found the UEFI WinPE CD I made on 11-24-2018 with Backupper version 4.5.6 and tried booting from it today and it didn't work.  Right now, Backupper won't build a WinPE bootable USB or export an ISO image (see my topic

    "Unable to create USB bootable media").

    The checkbox for "Download WinPE creating environment from internet" doesn't work....

  • Tente atualizar o programa.
  • @Vagn_32:  Version 4.6.1 "Create Bootable Media" does not DOES NOT WORK for any WinPE media whether it be legacy BIOS of UEFI mode.  Additionally, the checkbox "Download WinPE creating environment from internet cannot be unchecked.  The "Select Bootable Disc Select Bootable Media" and after checking any of the "Storage Media" options dialog window just closes after clicking next and nothing else happens.
Sign In or Register to comment.