AOMEI PE builder apparently can't find downloaded WinPE creating environment

Hi,

I installed AOMEI PE builder version 2.0 on my Win XP Pro SP3 32 bit system, and the first time I ran it, when it started to initialise the WinPE creating environment, I manually downloaded the WinPE environment 32 bit zip file by clicking on the link in "if the download speed is too slow, please click here to download the creating environment and unzip it to the installation directory of the software". I also clicked on the question mark at the end of that line, which said that the files should be unzipped to the directory specified in "C:\Program Files\AOMEI PE Builder 2.0\DownloadPath.ini". I then ended PE builder as I wasn't able to continue with it at that time.

A few days later I got back to it. The DownloadPath.ini file specified "C:\Windows\TEMP\PB Download\x86", so I unzipped the WinPE zip file to that directory, retaining the directory structure in the zip file. I then started PE builder again, and when it got to the WinPE creating environment screen I removed the tick from "download WinPE creating environment from the internet" (since I had previously downloaded it). However as soon as I did that, the "next" box at the bottom of the screen changed colour from brown/orange to dark grey, and when I clicked on it, nothing happened, i.e. the "next" button was inoperative. This would appear to indicate that it couldn't find the WinPE files I previously downloaded and unzipped.

I tried copying the unzipped WinPE files to a different directory and changing the DownloadPath.ini file accordingly, but I got the same problem.

How can I get the AOMEI PE builder to "find" the unzipped WinPE files? Do I have to change the directory structure after unzipping the downloaded zip file, or remove 1 or 2 layers? It's now "C:\Windows\TEMP\PB Download\x86\WinPE Env\x86\ISO", with the ISO subdirectory containing one file (bootmgr) and 2 further subdirectories (Boot and Sources)

Tim

Comments

  • Please don't removed the tick from "download WinPE creating environment from the internet".
  • I have tried exactly the same thing, with no success. There is very little support information about where to extract the downloaded files and what folder structure to use. You need to to add more information so we can understand.

    Can you please explain by example where the downloaded files should go? Is it any one of these:

    ..\PB Download\x86\WinPE Env\x86\ISO
    ..\PB Download\x86\Boot & ..\PB Download\x86\Sources

    Does the build process look for a local file-set before attempting to download from the internet? It should look inside "PB Download" first.

    The process should also give the user some feedback when it runs like:
    ..."searching PB Download for downloaded images...."
    ..."local image found/not found"
    ..."using local image"/"downloading image from internet"

    Thanks
    Gary




  • Hi Gary, did you find the DownloadPath.ini file?
  • Yes that was the easy part. The problem is your documentation just says extract the files into the PB Download folder. The image zipped files have lots of sub-folders and it doesn't say what level to extract into the folder listed in the INI file. I think I've worked it out now but you really need to add more documentation for this area. It shouldn't be that hard.
  • I ended up restoring the tick to "download WinPE creating environment from the internet" as suggested, even though I didn't want to since I had already downloaded the WinPE creating environment and my internet download allowance is rather limited - I most certainly don't want to redownload it each time I run AOMEI PE builder. Anyway, with "C:\Program Files\AOMEI PE Builder 2.0\DownloadPath.ini" set to the default of "C:\Windows\TEMP\PB Download\x86" I watched what happened, and the WinPE creating environment was installed to “C:\WINDOWS\Temp\PB Download\x86\ISO” and subdirectories. Hence, the WinPE creating environment files in "WinPE Env x86.zip" should be extracted from the ISO directory down, retaining the directory structure of the zip file, and added to the directory specified in DownloadPath.ini.

    The generated rescue disk (iso) ampe.iso wouldn't boot my Win XP Pro SP3 32 bit system, but I found out that was because the PC doesn't support PAE (Physical address extension). But that's another story...

    I also have a Win 7 Pro SP1 64 bit system, and I want to create a rescue disk for that system. Hence I set the [ISO_X64] WorkPath in DownloadPath.ini to "C:\Windows\TEMP\PB Download\x64", and using what I had found out when creating the 32 bit rescue disk above, I unzipped the WinPE environment 64 bit zip file to “C:\WINDOWS\Temp\PB Download\x64\ISO” and subdirectories.

    I ran AOMEI PE builder, but my first try wasn't successful. On the "Download WinPE creating environment from the internet" screen, I ticked the "create 64-bit version of Windows PE" line, and then removed the tick from "download WinPE creating environment from the internet" line, since I had already downloaded the 64 bit creating environment file. When I did that, the 2 "create xx-bit version of Windows PE" lines disappeared, which perhaps should have given me a clue. Anyway, the "next >>" box was greyed out, i.e. I couldn't click on it - just the same as when I tried the 32 bit version, but this time with the (presumably correct) directory structure for the 64 bit WinPE creating environment files.

    The fact that both "create xx-bit version of Windows PE" lines disappeared when I removed the tick presumably meant it didn't know whether to create a 32 or 64 bit rescue disk.

    I eventually decided to leave "Download WinPE creating environment from the internet" ticked, without being connected to the internet since I didn't want it to download the creating environment again, and see what happened. Somewhat to my surprise, it worked - from the messages displayed, it looks like it didn't try to download the WinPE environment; and even if it had tried, it wouldn't have succeeded since I wasn't connected to the internet.

    The generated 64 bit rescue disk ampe.iso successfully booted the Win 7 64 bit PC.

    I definitely agree with Gpf (Gary) that the documentation for all this could be improved.

    I also think that if you don't want to download the WinPE environment from the internet, you should be able to remove the tick from "download WinPE creating environment from the internet", but still be able to specify whether you want a 32 bit or 64 bit rescue disk created.

    Tim
  • Thank you Tim, we will try to improve the documentation.
Sign In or Register to comment.