AOMEI Partition Assistant - access failure error?

I have a problem with AOMEI Partition Assistant. The program was working fine and now an error is displaying that will not allow access to the program.  The error is " Sorry, no disk found. Some hard disk drives may be locked by other programs, which caused the access failure. Please close the programs and try again!"
I have tried rebooting the system, reinstalled the program, tried system restore (before the error occurred) nothing seems to work to clear this error. Any ideas please?

Comments

  • PA 7.0?
  • Was on V6.3 upgraded to V7, still the same problem.
  • Did you try the WinPE? Same error?
  • Please could you explain how to check with WinPE?
  • Bit of an update.  When one of the hard drives are disconnected which is a Toshiba 3TB Sata Drive, the problem clears.  This hard drive is only about 8 months old. Is this drive possibly faulty? or can someone recommend some software to test the drive?
  • I guess, no, it's not the hardware, but the software which is faulty.

    This hapened to me today: I tried to clone a windows 8 GPT disk (1TB - 250GB occupied) to a 500GB SSD. To do so I mounted both the source and the target disk into a second computer with AOMEI Partition Assistant (Payed version 7.5.1) to do an offline clone, and used the "clone disk" function, double and triple checking that I selected both the source and the target disk correctly before applying the changes.

    To my surprise, AOMEI Partition Assistant complained that one of the disks was locked, and offered to install Windows PE. Though the partitiions - to my best knowledge - were not locked, I had no chance but accept. After copying something somewhere the computer did reboot, and I expected Windows PE to start up, but right after some AOMEI splash screen I got an error that PE could not start, and wether I wanted to start some PreOS blablabla, with a 60 secounds countdown and no chance to say "no". I accepted, and this step failed too, my computer rebooted and came up with Windows 10 like normal - whatever PreOS would have been, I didn't ever see it.

    Since then, whenever I fire up AOMEI Partition Assistant, I get this message: "Sorry, no disks found. Some hard disk drives my be locked by other programs, which caused the access failure. Please close the programs and try again". The computer has been rebootes several times, no change.

    Note that I can use the clone function of AOMEI Backupper or any competing disk cloning tool any time, so I suspect there isn't really any software locking my disks, it seems to me like AOMEI Partition Assistant puts some lock flag somewhere, and fails to clean it up, if the PE environment fails to run properly.

    Any instructions welcome on how I can clear this magic flags, if they exist, so I can use AOMEI partition wizard again.

    Armin.




  • Hello ArminLinder,
    Did you still get the error "Sorry, no disks found. Some hard disk drives my be locked by other programs, which caused the access failure. Please close the programs and try again" after you remove the two disks? 
    If yes, could you try to uninstall AOMEI Partition Assistant manually, then reboot the computer to install it again?
  • edited November 17
    Yes, both the source and target disks have been disconnected, and the computer rebooted several times, but the message still persisted.

    I followed your suggestion and re-installed AOMEI Partition Assistant 7.5, and now the problem is resolved.

    Best regards, and thanks for your support, Armin

  • @ArminLinder, We suggest that you can upgrade to the latest version to use. Please download the latest version from here: https://www.diskpart.com/download.html
Sign In or Register to comment.