Disk Backup - really unexpected behaviour

Hello friends,


I'have bought Aomei Backupper pro and I have come across 2 major flaws which I cannot solve on my own :/


1) Using disk backup on my main disk (NVME) is performing ok, however, a disk backup of my second disk is really slow. It is like 65 MB/s on a Samsung SSD 850 EVO. I checked my SSD using CrystalDiskMark 6.0 and is performing as expected, so I assume the problem has to lie within the Aomei Backupper.


2) On both disks,  incremental backup takes almost as long as a full backup, which kind of defeats the purpose.


Destination for both backups is a third, internal disk. (This third disk cannot cause the problem because my main disk backups there too and the performance is ok as stated above)


Backup checking is turned off.



Can you please assist ?

Thank you

Comments

  • I am just performing an incremental backup again. It takes > 1hr to complete on second drive.

    On main drive, it was < 1 minute.


  • Here I am again, I have disabled Nextcloud and disabled Windows Defender.

    Still the incremental backup of the second disk takes > 1hr to complete.

    Please advise what should be done.

  • edited January 6

    Try (incremental) backup using WinPE bootable media. Is it faster?

  • @ Johnny : Thank you, I created a bootable media on a USB stick. Then tried to do an incremental backup. It takes > 1hr, so nothing changes :/ :/

    Are there any logs I can review ??

  • edited January 6

    Take a look in the program files directory were Aomei is installed. There is a log folder.


    We know now that it has nothing to do with running software on your operating system, like AntiVirus or something.

  • Thank you again.

    I am now really really frustated about buying AOMEI Backuper Pro.

    I tried "Backup Files" > Backing Up my Development Files directory + my local development environment (XAMPP). It runs 15 minutes. My command line 7zip script takes 3 min at most :(


    Back to the incremental backup problem:


    Backupper7.txt:

    https://gist.github.com/creativeworkx/50efe0ae28d137dea37f48d55df8f1fa


    ABCore18.txt:

    https://gist.github.com/creativeworkx/598e6abf65bfe8da96b99fbc44f29082


    Backupper6.txt:

    https://gist.github.com/creativeworkx/ab05954c2b3ab94930a735a01d112f76


    Thanks!

  • edited January 6

    You're are right. In my experience the incremental backup of my development files takes only a few seconds to a minute. Don't know what's wrong. How many GB are we talking about that take > 1 hour?

    Maybe forum member Admin (from Aomei) can help you. I guess in China they have weekend now too. You could also mail Aomei's support.

  • Hey,


    the dev stuff is < 1 GB. I even tried to exlude *.git for testing purposes - but it did not help. It still takes about 15 minutes for the dev stuff only, my 7zip batch script is way faster.


    The > 1 hour data is around 180 GB. But every run of incremental takes as long as a full backup, which kind of ... is weird.


    What puzzles me additionaly is the incredibly slow speed (65 MB/s) on a fast SSD (850 EVO).


    I hope support team reads this, otherwise I will try to contact them on Monday.


    Thanks

  • edited January 6

    Speed is based on read and write disks and memory and CPU speed etc.. The source may be an SSD but if the destination disk is a slow HDD than the whole process is slow.

    1 GB is nothing, should take a few seconds normally. I too have an SSD and backup to an external USB connected HDD.


    65 MB/s is not slow. 1000/65 is 16 seconds.

    Wait a minute. Did you do a sector by sector backup and/or use high compression? Did you alter something in the backup options? Don't.

  • "destination disk is a slow HDD than the whole process is slow."

    "65 MB/s is not slow. 1000/65 is 16 seconds."


    You are right, that's why I stated above, that I also backup my "main" disk (disk a) to the exact same disk (disk c) My only problem is disk b.


    So my setup is


    disk a > disk c (main disk, works perfectly fine)

    disk b > disk c ( the slow one)




    So basically I get:


    - DISK A > DISK C: 300MB/s, really fast. incremental does take a few eye blinks

    - DISK B > DISK C: 50 MB/s, incremental takes exactly as long as full backup


    For DISK A & DISK B I use this setup:


    - encryption is off

    - compression is normal

    - intelligent sector backup is used

    - use vss is activated







  • Hello,


    I did a clean install of windows 10 (including formating disk)

    the behaviour remains the same.. this is really frustrating, and I hope, the support team can look into this.

    I digged a bit deeper and found out, that there were 2 VSS erros in the event view:


    Volumeschattenkopie-Dienstfehler: Beim Abfragen nach der Schnittstelle "IVssWriterCallback" ist ein unerwarteter Fehler aufgetreten. hr = 0x80070005, Zugriff verweigert
    . Die Ursache hierfür ist oft eine falsche Sicherheitseinstellung im Schreib- oder Anfrageprozess.

    Vorgang:
       Generatordaten werden gesammelt

    Kontext:
       Generatorklassen-ID: {e8132975-6f93-4464-a53e-1050253ae220}
       Generatorname: System Writer
       Generatorinstanz-ID: {ebb0be21-06c5-45e0-ab3c-50e9fa1a33bf}


    So, I hit cmd.exe as Admin and ran " vssadmin list writers"

    The output was : every vss writer was marked as "stable" and no error was returned.






  • Your second disk is NVME too?

    We are working on the fast incremental backup technology, and we believe incremental backup will take much shorter in future versions.

  • Admin, and by second disk you mean the Samsung SSD 850 EVO? That is the most popular SSD for some years now.


  • disk b > disk c ( the slow one) => disk b is the Samsung SSD 850 EVO

    ..

    ..



    but maybe the problem lies within the VSS errors I get, everytime when I try to run a backup.

    Can you please have a look into this ?



  • Update :

    For the first time, the incremental was considerably faster than the full.

    And guess what, this time, there were no VSS errors in the windows eventlog.

    WIll give it another run tomorrow.

    Absolutely no clue what could have caused this now to function properly. My PC is in the exact same state as yesterday. I even checked windows updates => none installed today.


  • edited January 8

    VSS? I asked you to create a WinPE disk, run it and do a backup from this WinPE. You said it makes no difference. Correct me if I'm wrong, but when booted from the WinPE all disks are like data disks, not touched, not in use, by the running OS. So VSS is of no meaning. @Admin, am I right?


     I created a bootable media on a USB stick. Then tried to do an incremental backup. It takes > 1hr, so nothing changes

    Or dit you only Create but then run the normal Aomei, not from the bootable USB?


  • I agree VSS is of no meaning.

    The reason why the backup took so long is not clear yet.

  • edited January 9

    @Johnny: surely I booted into WinPE and the behaviour was there as described.

    What I was refering to in my yesterdayˋs post was the default usage of the software running in Win10. There - contrary to the previous attempts, no VSS errors were present and incremental worked just fine.


    To sum it up:


    Round 20 attempts in Win10 : incremental and full take the same time. For the last three attempts I monitored eventlog and VSS errors appeared as soon as I started the backup. I also checked vssadmin and all the writers reported OK. I even downloaded the standalone VSSDoctor from Acronis -> All Checks successful. 


    Round 5 attempts in WinPE : Incremental and full take the same time.


    Last attempt yesterday in Win10 : incremental was considerably faster than a full backup and NO errors were present in the eventlog.


    I will do a set of attempts today in Win10 and in WinPE.


    Thank you for being so helpful.


  • I wonder about the 1000/65=16 seconds. But it took much, much longer. What is he doing the rest of the time? Is it hanging on a certain percentage? The percentages may give a clue of the process it is doing a that moment.

  • As far as the "unsuccessful = slow" iterations are concerned, I don't think he was hanging on a certain percentage.


    But:


    I just finished a new run of backup jobs in Win10-mode (not in WinPE). And both disks, were extremely fast on the incremental. (As would be expected, because of the raw speed power of the nvme, and the still fast speed of the EVO SSD).

    So, right now everything works as planned for me in Windows 10. WinPE I have not tested yet.


    Right now, I can think of a possible cause.. Will give it a try and get back to you soon           


  • My attempts to re-produce the slowness were not successful, everything just works now in Win10. No errors, Incremental is way faster than full. I absolutely have no clue why.


    I will hit WinPE in next runs.

  • So, back I am :)


    What did I do :


    - created a new WinPE environment using PE Builder 2.0

    - booted into the WinPE ENV


    Now the fun begins:


    - I was not able to perform an incremental backup on my second disk.

    "The specified volume 0 hasn't been found or has been changed".

    "The specified volume 1(E:) hasn't been found or has been changed."

    "Information Code: 4123"

    "All partitions that need to be backed up have not been found."


    - I was able to perform an incremental backup on my main disk.



    So I fired up Window Console and hit diskpart


    I then re-assigned all drive letters to the letters I use in my regular Windows 10 installation.


    I tried to create a incremental backup on the second disk again.


    It failed with the exact same error message.


    So I guess, I somehow need to change the volume ordering for it to resemble the one I use on regular Win 10 because obviously, assigning the same letters is not enough (disk backup, not partition backup) but I have no idea how to manage this.


    Any idea how to proceed? Thank you!





  • You could perform a full backup + incremental backup in WinPE.

  • Hallo my friend,


    I can do that for a test run, no problem.


    But how do I restore my regular Win10 made backups if the volumes are different? This will result in a state where I cannot restore them, am I right?

  • edited January 10

    You can import any adi file through "path" in WinPE restore (or in the normal Aomei) , it automatically connects and remaps the drive letters. Mind this is only temporary. When actually booted from the restored disk, the drive letters are back to normal.


    image


  • back again :) :)


    Here are the complete stats.

    Percentage means progress in selected backup mode.


    Windows 10


    Main Disk - Full - 30 % : 250 MB/s.

    Main Disk - Full - 50 % : 200 MB/s


    Main Disk - Incremental - 30 % : 561 MB/s

    Main Disk - Incremental - 50 % : 570 MB/s


    Data Disk - Full - 30 % : 96 MB/s

    Data Disk - Full - 50 % : 95 MB/s


    Data Disk - Incremental - 30 % :403 MB/s

    Data Disk - Incremental - 50 % : 397 MB/s


    => Speed in Win 10 is good.

    => Incremental is substantially faster than full, as expected.

    => The behaviour were incremental equals full backup speed cannot be reproduced any more. Cause: absolutely unclear, see my previous posts. Even no windows updates were installed.




    WinPE built with AOMEI PE Builder 2.0


    Main Disk - Full - 30 % : 150 MB/s.

    Main Disk - Full - 50 % : 156 MB/s


    Main Disk - Incremental - 30 % : 154 MB/s

    Main Disk - Incremental - 50 % : 159 MB/s


    Data Disk - Full - 30 % : 86 MB/s

    Data Disk - Full - 50 % : 84 MB/s


    Data Disk - Incremental - 30 % : 156 MB/s

    Data Disk - Incremental - 50 % : 155 MB/s


    => WinPE is substantially slower than Win10.

    => On main disk, incremental is as slow as full backup. No speed advantage whatsoever.

    => Incremental backup speed is faster than full backup speed, as expected on data disk.

    => As mentioned above, WinPE is way slower than Win 10 regular mode.





Sign In or Register to comment.