Home AOMEI Products Support

OneKey Boot Error with PCIe NVMe drive

edited September 2017 in AOMEI Products Support

I installed OneKey Recovery on my SSD - PCIe NVMe Samsung.  It installs and I created a backup, but when I try to boot ito the Aomei recovery environment, I'm getting an error (I'm assuming because it can't load/find the ssd)


load segment 0x0  system type 0x0  sector count 0x1  Load RBA 0x1f  boot type 2=1.44M floppy

non-system disk or disk error

How do I correct this?  I also tried booting from the Aomei PE Builder.  I added the NVMe drivers in the build wizard, but when I try to boot, it also errors - how can I load the drivers for PE Builder for this ssd?


  • Did you install the microsoft nvme updates into winre, before installing the Samsung drivers?



  • The Windows install is fine.  It's the PE that Onekey creates that fails.  I don't know where OneKey pulls drivers from to build the PE or if it is pre-bundled, but the PE doesn't see the NVMe drive.

  • cpohts   Do you have GPT System or MBR  system installed?  if it is MBR, please unhide the AOMEI Recovery Partition, and share OneKey_PE.iSO to Google drive/ onedrive and  send details to [email protected]

  • I uploaded 2 ISOs to dropbox and emailed the links.  One has the injected NVMe drivers

  • The laptop I'm working with is a ThinkPad T470s, Win7x64 on NVMe drive.  The OEM ships GPT.  I converted it MBR, fixed the boot, so it does load into Windows successfully.  I used the native T470s W7x64 GPT to create a bootable image from Backupper.  This loads successfully.  I then created a bootable ISO using PE Builder.  When this boots, I get a BSOD the app was unable to start 0xc0000000d.

  • I found the fix.  I had to inject drivers into the boot.wim in the ampe.iso file in the OneKey Recovery install folder.  This allowed OKR to see the NVMe drive and load one creating the first backup file and recovery partition.

  • Update, this fix allows OKR to reboot during the first backup and create the recovery partitoin with subsequent onekey_pe.iso but the embedded WIM inside also lacks the drivers for NVMe.  I'm going to try to follow the same steps to inject drivers into this PE.

  • Solved.  I didn't inject drivers into the onekey_pe.iso WIM file.  I renamed the ampe.iso that I already updated and copied it into the recovery partition. Booted perfectly and sees the hard drive, able to backup and recover!  Until Aomei updates the WIM files for NVMe drivers, this workaround to add them works!  FWIW, to avoid the command line (for speed), I used DISM GUI to update the WIM files.

Sign In or Register to comment.