Corrupt or Invalid Signature error on download of Free Standard Edition

No matter what site I attempt to download the latest AOMEI Partition Assistant Standard Edition from I always get the following error:


I have tried this link which is on the AOMEI site: 

I have also tried this link: 

 on  and selected the Download Now button.

I always end up getting the signature is corrupt or invalid.  Has anyone else had this issue?  I can't believe I am the only one because I've received it at work and at home.

Thank you for any help.



  • edited September 2016

    The digital certificate "PAssist_Std.exe" is signed with is valid until 2016-06-26, in other words the certificate has expired. So what you experience is not really surprising.

    Additionally, the certificate is using SHA1 as a hash function, which is outdated and not considered secure anymore (see e. g. Wikipedia).

  • Sorry for this problem. You can try to download it with the Google Chrome with no errors.

Sign In or Register to comment.