Home AOMEI Products Support

Inaccessible boot device

I have replaced my system SSD (Intel 750 PCIe) with a Samsung 950 Pro.

I realize it's a different SSD but still I was hoping I would be able to restore my system image backup. I've tried having the 'Universal restore' option both checked and unchecked but regardless when I restart my PC after the restore I get the notorious bluescreen in Windows 10 with the message inaccessible boot device.

I then tried booting from the Windows 10 installation media and chose the repair option for startup problems but to no avail...still same problem.

Any tips without having to reinstall Windows and all my applications? 


  • edited April 2016

    From your bootable media, go to the Windows command shell (Utilities), and type

    dir c:

    bcdboot c:\windows /L en-us

    (where c: is the drive letter of your windows installation. In the bootable media, it might be not c: but another drive letter.You have to find with dir c:, dir d: and so on, until you recognize it from its contents: Users, Windows, Program Files and a few others. /L is for the language code).

    The problem is quite normal, and is caused by the way Windows handles booting. Your c: partition is usually perfectly restored, but the boot method does not know where it is (c: is the "inaccessible boot device" from the error message). Startup repair does not fix it. Universal restore is not the issue. Technically it DID boot halfway, because you received the blue error message.

    (There could be another issue with GPT but please try the above advice, and if it does not help, I or someone else can give you the additional quick instructions regarding MBR and GPT. But it DID boot into the error message, therefore I doubt that it is the GPT issue. And as far as I know, SSD are not configured as GPT)

  • Many thanks for trying to help me out, much appreciated!

    Tried what you suggested and had my hopes up when it told me the boot files were successfully created but then when trying to boot I still got the same error message so looks like it's still some other problem.

    Would restoring using the universal restore option be the best option in my case where I'm using the same hardware except for the new SSD or would my chances be better restoring without the universal restore option?

  • Maybe I should also mention that my original SSD I'm replacing was partitioned into 2 partitions if that matters.

    The disk is 400 GB where I had a 100 GB for the system and the remaining 300 GB as a data partition.

  • edited April 2016

    no 100GB / 300GB it does not matter. Are you sure you don't have other partitions, like a 100MB or a 500MB partition? Universal Restore does not matter at all (this would come much later, it is about drivers).

    You should take out the original disk. There should be only one disk. Are there more disks, and if yes did you get the right one?

    Please do also


    list disk

    and see if any disk has a * in the GPT column, and how many disks are there.

    if there is only one, do


    sel dis 0

    lis par

     and see how many partitions

  • edited April 2016

    when it tells you inaccessible boot device, it should also tell a file name, for example

    \windows\system32\winload.efi  ?

  • After doing the restore I disconnected the disk where my system image is located so at this point the only disk that is connected is the new disk.

    I tried the disk part commands you suggested and they showed 2 disks. Disk 0 is my new SSD with a size of 476 GB and it does have a * in the Gpt column. Disk 1 is my Windows 10 USB stick with the bootable media with a size of 14 GB.

    Selecting disk 0 followed by listing its partitions shows me 3 partitions as seen below:

    Partition 1 Recovery 449 MB

    Partition 2 System 99 MB

    Partition 3 Primary 97 GB

  • It doesn't reference a file. It just tells me with a sad smiley that my PC ran into a problem and needs to restart and that they will do it for me.

    Below that message they suggest I should search online for the error message INACCESSIBLE_BOOT_DEVICE if I want to know more.

  • I need to catch some sleep now but will continue to look into this tomorrow when I get home from work.

    Again, big thanks for trying to help me out! 

  • WebMaximus , 1, Please try to restore it with the unniversal restore.

                            2, Change the new SSD as the first boot Ans amend the bootable mode.                             UEFI is for GPT and LEGACY is for MBR.

                            3, If it also failed, send us the screenshot of the error page.

  • edited April 2016

    First .. thank you for the precise descriptions!

    The disk layout is GPT, and the partitions are the expected ones with the right designations (in diskpart terms). You may cross-check that partition 2 is the ESP partition.

    here are a few solutions (it seems an ACPI vs. IDE issue here, not a boot software issue)


    It is sad that the boot manager actually gets started (the smiley message seems not from firmware), but cannot proceed.

    How to cross-check that partition 2 is right for GPT?


    sel dis 0

    lis par

    sel par 2

    det par

    ass letter=s


    dir s:

    it should tell somewhere that the partition is FAT32, its directory contains EFI and boot, its partition type, which is characteristic of ESP, is C12A7328-F81F-11D2-BA4B-00A0C93EC93B

    I cannot really comment on the ACPI / IDE question. I do have experience in the boot layout and tried to assist along that line. It seems rather not be a boot layout problem. It interesting that Windows PE on your stick, and probably Windows does have the right drivers for IDE?, but the boot manager does not have. I would conclude that firmware detected the new hardware and configured it for IDE. I also would conclude that the former SSD also was GPT (not MBR), and that the computer has UEFI firmware (because: of the ability light-blue smiley screen, and because: system recovery restored a SYSTEM and RECOVERY partition).

  • I'd like to ask what computer it is, or what motherboard?

  • I wonder if the problem is I'm using Intel's driver for the 750 in the image. Maybe if I put my old disk back, replacing the driver with Windows built-in driver instead and then do a new backup/system image it will solve the problem.

    I think I'll give it a try, will let you know.

  • MSI Z170A Gaming M7.

  • Removing the Intel driver for the 750 resulted in having the very same issue with the 750 so this makes me suspect it indeed might be a driver issue where Windows are trying to access the Samsung drive using the 750 Intel driver in the image. Still drivers should not be an issue when using the universal restore option or did I miss anything?

    Will see if I can find how to go back using Windows built-in driver without ending up with a non-booting PC because I do know I've been able to use the built-in driver in the past before I replaced it with the Intel driver.

  • As a diagnostic attempt you could boot from a file... The file is on your hard disk at \efi\boot\bootx64.efi and at \efi\microsoft\boot\bootmgfw.efi . You may try both. I expect that it executes and presents the smiley, with no difference. Before remove the USB stick. You surely know how to change boot order, because you are able to boot from the stick, booting from a file is there.

    Did you see device preferences in firmware setup (however it is called) to see that ACPI is enabled?

    I remember that the 950 does not need a special driver, NVMe is built into Windows..

    When you put in your old 750, could you verify what partitions it does have. And what does Backupper propose to back up (CANCEL afterward). It should be three partitions. Could you verify from the Backupper bootable media what partitions it proposes to recover? It should be the same three partitions (CANCEL afterward).

    Please be aware that the smiley occurs at about quarter of boot. It does not even complain about BCD not found, it does not complain about \windows\system32\winload.efi . It complains before that...

  • edited April 2016

    universal restore is for windows and hardly for the boot process.

    I checked and the MSI Z170A Gaming M7 does have "UEFI BIOS", this means usually UEFI firmware (not BIOS firmware).

    for the PCIe m.2 ports there can be RAID0 and RAID1 settings.

  • edited April 2016

    you are right to replace the 750 driver with the microsoft default driver.

  • OK, I thought I read in the description for the universal restore option it was to make sure your computer will boot even when a system image is restored to different hardware and guess I was assuming that had to do with drivers used to boot the computer such as disk drivers in my case.

    Anyway I just figured out how to get rid of the specific Intel driver for the 750 and without ending up with a non-booting PC. Rather than just uninstalling the driver hoping for Windows to replace it with the built-in driver I had to first uninstall it and then before rebooting the computer manually pointing out MS's built-in driver and then reboot the PC.

    So at this point I have my old Intel 750 installed and now using MS's built-in driver so will now proceed with making a new system image backup. I'll then get rid of the 750 and replace the Samsung SSD and do another attempt restoring the new system image to the Samsung SSD.

    Will be very interesting to see what happens and will of course report back in here. Keep your fingers crossed will you :)

  • Success image

    With the Microsoft Standard NVM Express Controller rather than the Intel driver in the system image the PC booted on first attempt after the restore!

    Many thanks for all help along the way guys !!

  • It was a strange error message and you found a unique solution!

  • Yep, I agree but in a way I guess the error message was correct because obviously it will be a touch match for Windows to access the boot device when not using a driver compatible with the device which was the case here. I only wish I would have thought of this earlier but of well...at least a new experience and I learned something new.

    Most of all I'm more pleased than you could possibly imagine I didn't end up having to perform a full reinstallation of my PC!

    Take care!

  • edited April 2016

    The error message was quite disturbing, because it boots without the driver anyway. In my opinion only after winload.efi gets called, it does even know where to find the driver. Firmware finds, as far as I know, the boot manager and this finds BCD and decides what OS to load (without multiboot there are three items to choose from: OS, Winre, resume), and then loads this winload.efi. These steps happen without the driver. Only then it may switch to loading and using the wrong driver, and failing. The error message tells the failing point into much earlier.

    It is really good that you found it.

    +To distinguish at what phase it causes the problem, whether it is in the
    boot manager, or on loading Windows, one could make the boot manager
    multi-boot. The most easy way is to add the Windows Recovery OS loader
    to the boot manager's display order. For the present issue the
    opportunity has gone, of course. We would have gotten a stop point between the Windows boot manager, and the Windows boot loader.

  • Yep, I'm just very happy I got it working but good thing if this issue also might give some info that can be used for others or in future versions of AOMEI Backupper.

    Have a great weekend!

  • Thanks for all your guys. We will try our best to improve it.

  • A customer has an XPS 8700 Dell Desktop computer.  He bought it with Win 8.1 and in December 2015 downloaded and installed Win 10.  Last week the computer stopped booting with the Error Code: Inaccessible Boot Device.    I have been working on it for several days - below I have listed steps taken so far with the results.  The customer replaced Kaspersky anti-virus with PC Matic.  In researching PC Matic I discovered it is a Registry Cleaner.  I believe it probably deleted a windows file or corrupted/deleted one or more Registry Entries.  Have not been able to prove it.
    Steps were taken so far:
    1. Used several Rescue disks to troubleshoot.
       Kaspersky Rescue disk 10:  Graphics Mode.
          a. On the menu - Computer - shows all files on the hard drive
                           - Registry Editor:  Verified explorer.exe value is in Shell.
          b. Ran WindowsUnlocker:  Found 2 suspicious registry values and deleted them
       Rebooted:  Still receive:  Inaccessible_Boot_Device
      Other Rescue Disks (Hirens and UBCD) - not very successful running anything.
         UBCD: Run Dsrfix v 3.12 - Run with DSRFIX /f - alert reference partition table not in sync.  Boot code does not match Dell MBR.
    2. F12 Boot:  Ran diagnostic - everything came up clean.
    3. Booted up in Safe Mode with Networking (regular Safe Mode also works) and the system came up.
      a. Ran the below utilities to clean up the computer.
          . Ccleaner:   Not much to clean up, Registry very few items
                            Disabled most Start-Up programs - later enabled all I had disabled - rebooted - still a problem.  
                             Deleted Pc Matic and all related products.
         . Adwcleaner:  Only a few registry entries were deleted.
         . Malwarebytes:  Found one Trojan.  Trojan dnschanger etc .
         . Tweaking.com - Windows Repair
         .  Tweaking.com - Simple system tweaks
         .  Process Explorer - with Virus Total - everything looked good.
         . Crystal Disk Info:  Status - all looks good.
    Bios Settings: (left settings as shown below - changed some and tested, did not change anything
       .Advanced Tab: SATA Mode: AHCI  
       . Boot Tab: Secure Boot - Disabled
                       Load Legacy OPROM - Enabled
                       Boot Mode: UEFI - also tried legacy, did not change results
                       First Boot Device: USB Floppy
                       Second:              UEFI - OS
                       Third:                 USB Storage
                        Fourth:              Internal ODD
                        Fifth:                 Onboard NIC
                        Hard Disk Drives:
                                        First Boot: UEFI OS
                                        Second Boot: Windows Boot Manager
                            I tried reversing these to see if a difference, saw no difference
     Performed a System Restore from Safe Mode with Networking:
               . The System Restore took 1.5 hours to complete
                  then rebooted, but same results which are:
      Finally with all of the above When I boot the following sequence occurs.
        .Receive DELL Black logo Bios Screen - sometimes appears twice
        .Receive 1 audible beep - thus BIOS check is good.
        .Goes to Orange Screen with rotating dots in a circle - keeps spinning
        . Displays message: "Please Wait for Local Session Manager
        . Now just loops forever and ever, and even ever.
    Googled Local Session Manager:  Shows: windows\System32\svchost.Exe -k DCOM and needs a file: lsm.dll
       program is:  lsm.exe running inside svchost.exe DCOM
       I verified this running in Process Manager and searched for lsm.exe and lsm.dll in system32 and found them.

       .Does anyone know of a possible file and/or registry entry that may have been deleted or corrupted by, my guess, PC Matic that I could be directed to change or reload.
       . If not does that mean I need to either get a repair or install disk for Win 10?  As Win 10 was downloaded, the customer has no repair disk or no win 10 install disk.
       . Would this be an item that the customer must pay for, or will Microsoft wave the fee - As the customer did not know to create one, my guess is he must pay for this.
       . I am hoping for a solution to modify the Registry.  If not then which way is better, completely reinstall Windows 10 with a purchased disk, or perform a Repair process after saving his data.  I am guessing the same disk would do both.

    Any help would be greatly appreciated.  I have gone as far as my knowledge will let me, and am hoping for someone on the forum with a MUCH better knowledge of the internals of the operating system than I have.

    Thanks for reading, and definitely thanks to anyone who responds to this post.
  • bootdevice A customer has an XPS 8700 Dell Desktop computer.  He bought it with Win 8.1 and in December 2015 downloaded and installed Win 10.  Last week the computer stopped booting with the Error Code: Inaccessible Boot Device.    I have been working on it for several days - below I have listed steps taken so far with the results.  The customer replaced Kaspersky anti-virus with PC Matic.  In researching PC Matic I discovered it is a Registry Cleaner.  I believe it probably deleted a windows file or corrupted/deleted one or more Registry Entries.  Have not been able to prove it.
Sign In or Register to comment.