Backupper and Partition Assistant on same bootable USB?

Well the title says it all...
Is it possible to create a bootable USB with both the AOMEI Backupper and Partion Assistant?
If not I would like to suggest that you add the feature - it would be nice to have both great products on the same USB-stick...
«1

Comments

  • Hello albert,

    Thank you so much for your support. We are going to release such a tool in the near future. Please keep tuned in the updates of our products.

    If you have any other qustions or suggestions please feel free to let us know.

    Best Regards,
    Kim
    AOMEI Support Team
  • It is possible - I have done it. You need imagex.exe from Microsoft to be able to add the files. You also have to be careful and not mix up 32 and 64 bit versions. I have a bootable USB stick with Backupper and the Partition Manager on it plus an application to start the network so I can mimage over the network. It would be great if the backup and partition PE software was available on it's own for download in both 32 and 64 bit versions. It would save me having to extract things from the boot.wim file!
  • Thank you very much for the comments Kim and Andy! I'll look forward to the new Tool, and in the meantime I might try to make my own with imagex...
  • edited May 2014

    You can use this:


    (new version https://www.dropbox.com/s/li54wz1ywli4d13/aomei-pev7.zip )


    D/l the zip, rt click it >properties>Unblock>Apply>OK.


    Then just rt click it again and select Extract. You will get a folder called aomei-pe. Inside is another folder called BIN and a file which says Run-me-as-admin.


    Obviously, rt click it and run as admininstrator.


    It will look for Aomei Backupper 2.0 and Partition Assistant 5.5


  • Hi, unfortunately your PE-Builder does not work for me. I ran it as admin under a german Win 7 64-bit. Does it only work with an english Windows?

    Pit

  • I could fix it by my own. For all those here with a german Windows edit Run-me-as-admin.cmd as follows:

    Replace "Architecture" in line 126 with "Architektur" and also replace "ServicePack Build" in line 858 with "Service Pack-Build".

    After these two changes creating of wim/iso worked like a charme (tested with Backuper 2.0 Standard and Partition Assistant Pro). But when I boot from CD there's "SIW2 Easy PE x64" Boot Menu with not working buttons for BU and PA and when I boot from wim file (that's what I would need here) PA automatically starts and there's no possibility to start BU. Is it also because of language problems?

    Pit

  • Sounds like Aomei was not added to the mount folder. 

    Are program files and program files (x86) called something different in German?







  • edited April 2014

    I will need to see if there is a way round that.


    Thanks.








  • As far as I know system paths are always language independent.

    Pit

  • edited May 2014

    I think this may do it. Thanks for testing. image

    (new version https://www.dropbox.com/s/li54wz1ywli4d13/aomei-pev7.zip )

  • No, I'm sorry...

    Regardless of I use "Architecture" or "Architektur" in your new skript there's always a syntax error at the same line. That's the last output:

    DISM /get-wiminfo /wimfile:"E:\AOMEI-PE\WinRE.wim" /index:1   1>"WIMINFO.TXT"
    for /F "SKIP=7 tokens=6* delims=: " %a in (wiminfo.txt) do (SET WADATA=%a  & goto :warchok )
    (SET WADATA=(x64)"  & goto :warchok )
     IF (x64)" EQU (x86) SET WIMARCH=x86 (

    Pit

  • edited April 2014

    Thanks. 


    I gather from that you are using a 32 bit wim file.I have fixed the typo on line 129 which was causing that issue.


    It is a bit complicated as it will support vista and newer ( might be ok on XP, not tested).

    Also should be fine with either bit version winre.wim, boot.wim, winpe.wim


    This will leave a small folder called mount-7z . In case you want to check afterwards .


    https://www.dropbox.com/s/juewlzi4z6ta3qz/aomei-peV3.zip





  • It's a fresh install of Win 7 64-Bit. The syntax error hasn't gone:

    DISM /get-wiminfo /wimfile:"D:\AOMEI-PE\WinRE.wim" /index:1   1>"WIMINFO.TXT"
    for /F "SKIP=7 tokens=6* delims=: " %a in (wiminfo.txt) do (SET WADATA=%a  & goto :warchok )
    (SET WADATA=(x64)"  & goto :warchok )
    IF (x64)" EQU (x86) SET WIMARCH=x86 (

    Pit

  • I tried it on DE 7x64. Fixed. Works fine now. image


    https://www.dropbox.com/s/oacwkph2m8rqdy0/aomei-peV4.zip



  • edited April 2014

    I also have a much bigger project. Same kind of thing, Bin folder and runasadmin.cmd.


    That requires 7x64sp1 dvd .Any of the MS client dvd's will do. They contain all the images.  Point it at the dvd in the dvd drive, or mounted iso in virtual drive.  It creates winpe with explorer, wireless, sound, etc.



  • Hi SIW2, again I'm sorry...

    Creating itself now works (again) and also there's your menu now when booting the wim but  the buttons for PA and BU still don't work. The AOMEI folder of the wim only contains adi.ico, the PA folder wnd.ini only. Think that's not okay?

    Pit

  • It works fine on my DE 7x64 installation. What are the exact paths to your aomei products?



  • Hi SIW2,

    sorry, everything is fine! I checked your script and saw that you (of course) only check c: for AOMEI files and because my applications are installed on d: they weren't found. I copied the folders to c: and... voilà!

    We should ask AOMEI for a registry key with the install path. :-)

    Thanx for your work!

    Pit

  • Thanks for the feedback. image

  • edited April 2014

    Suggestions always welcome.Good idea. I will look at getting it to check systemdrive first, then if not found, query the registry.

    Very few people would have installed to a different drive, but probably worth doing anyway.



  • edited April 2014

    This should do the job. It will get paths from the registry if they are not on systemdrive as usual.


    Also double checked to make sure iso will be both bios and efi bootable (unless the .wim is 7x86 of course)


    https://www.dropbox.com/s/arfwn0hk3dpwczt/aomei-peV6.zip


  • edited April 2014

    Great, it detected my installs on D: image

    But there's still one problem: my registered BU is not registered in the wim. Maybe there's a license file outside the program folder? When I create an ISO with BU itself it's registered.

    For adding drivers with dism I would recommend to use the /forceunsigned switch. Better an unsigned driver than none.

    Pit


  • That is strange. My registered BU works fine.


    What edition of BU do you have ?



  • It's a Technician Edition. PA Pro works... Maybe Kim can tell us whether there's something special with that.

    Pit

  • Tech edition is working fine here.


    Perhaps something didn't copy across from your other volume.


    Does it work if you copy the entire folder to your %systemdrive%\program files (x86 ) first?

  • It doesn't matter where it's installed to, BU remains unregistered in the PE.

    Pit

  • Found it: your script copies the contents of the WinPE64 subfolder but also AmCore.dll from the "AOMEI Backupper Technician Plus Edition 2.0" folder must be included because it's relevant for activation.

    Pit

  •        /(|
    ( :
    __\ \ _____
    (____) `|
    (____)| |
    (____).__|
    (___)__.|_____
  • edited April 2014

    You might like to try this. Needs the installation dvd.


    https://www.dropbox.com/s/6zn921fn40on497/pe764v15.zip




Sign In or Register to comment.