Windows to Go Creator

I used the Windows to Go Creator Wizard to create a bootable Windows 8.1 USB hard drive. After setting the boot sequence so that the USB hard drive is first the computer did indeed boot to the USB hard drive and Windows 8.1 started, configured my devices and restarted. Upon this restart though, the USB drive was bypassed totally and the computer booted to my "C:\" drive. The USB drive is recognized by my computer and shows that 6.42GB was installed on it. How come this happened?


  • Hello mdonah,

    We are so sorry for the delayed response. Could you please tell us what is the size of your USB drive? To create Windows To Go, needs at least 13GB disk space.

    Best Regards,

    AOMEI Support Team

  • Is this to make a bootable AOMEI Backup utility or to make Windows 7 or 8.1 totally bootable from a thumb drive?  How could you make the entire OS bootable since if you boot to different hardware Microsoft will ask for you to re-validate.  Where is the Windows to Go wizzard?

  • Hello Andrew,

    This function is to make Windows 8 (not Windows 7 and other older Windows) and later versions totally bootable from a USB thumb drive.

    "How could you make the entire OS bootable since if you boot to different hardware Microsoft will ask for you to re-validate."

    It needs the support of Windows. Only Windows 8 and its later version supports this.

    You can find this function in AOMEI Partition Assistant Standard Edition (freeware) and paid versions, like in the picture below:


    If you have any other questions please feel free to let us know.

    Best Regards,

    AOMEI Support Team

  • I had used an 80GB drive for the Windows to go wizard initially and it didn't work. I had a160GB drive that I tried the wizard with and it does work. Apparently, Windows 8.1 sees that size or larger drive as fixed instead of removable. The installation DVD won't allow installation to a USB connected drive but the Windows to go wizard apparently overcomes this obstacle.

    I've only run Windows 8.1 on my computer though. I don't currently have access to another computer I can try running Windows 8.1 from the USB drive on.

  • Hello mdonah,

    Thank you for your information. Could you please tell us what is the model number of the disk that did not work.

    If you have any other questions or suggestions please do not hesitate to let us know.

    Best Regards,

    AOMEI Support Team

  • Unfortunately, I can't get the specific model number. The model number is HM080JI if that helps. It's a Samsung SATA drive that came in a USB enclosure when I purchased it. Of note, to me, is the additional capacity it has (74.56GB instead of the usual 74.53GB).

  • Hi mdonah,

    Thanks a lot for your support. I will report it to our testers, so that they can analyze the problem. In my opinion, there should not have such a problem. As you said, after complete creating Windows To Go, the usb drive only be recognized that 6.42GB was installed on it, so the create process may have not been completed successfully. Maybe you can re-test it.

    If you have any other questions please do not hesitate to let us know.

    Best Regards,

    AOMEI Support Team

  • Good news!:) I tried again with the Samsung drive but plugged it in to a rear USB port on my Dell Precision M70 instead of a side USB port and it worked! Apparently, my computer sees the rear ports as primary ports and the side ports as secondary and if I want to boot an OS, I have to plug in to a rear port.

  • Hi

    I wanted to report that the Windows To Go Creator doesn't seem to recognise the win8 & win8.1 wim files that come with the US Windows upgrade downloads from Microsoft. A screenshot on your instruction page shows the file being named Install.wim -- renaming the boot.wim in these downloads had no effect.

    I tried the Windows To Go Creator with a win8 install DVD, a win8.1 install DVD, a win8.1 install USB stick, ISOs created from the 2 DVDs, & the win8 boot.wim in the original ESD I downloaded from Microsoft when I purchased win8. The DVDs & USB stick were all created using win8 & win8.1 web setup downloads from Microsoft, & the DVDs were used for 4 installations so they should be good.

    Unfortunately the Windows To Go Creator presented an error message that it could not recognize the wim file in every case -- when I tried using the ISO files it said it failed to extract the wim. I tried the Standard [free] version, & yesterday's GOTD, and I tried them in win7 64, plus 2 VirtualBox VMs, one win7 32 bit, & one win7 64 bit.

  • I'm having the same problem as above. Windows 8.1 doesn't have an install.wim file, it has only a boot.wim..  How can I get Windows to Go Creator to work

  • You will have to extract the .esd to a folder, then you can capture the folder as install .wim.

    To extract, you need either the newest dism version ( which you will have with build 17031).

    Or you can use winntsetup, nice and easy.

    To capture the folder you extrac

    ted it to, you can use several tools, the new dism, or nice and easy, Gimagex.

  • To mikiem and asawyer :

    The windows to go creator is for installing from install.wim to a usb drive. 

    It seems you do not have install.wim. You may have install.esd, whch MS has recently started pushing out to the public.

    Currently, there are no available complete 3rd party tools which handle .esd files correctly.

    Windows to go creator does exactly what is is supposed to do.

    MS have moved the goalposts.

  • edited May 2014
    People are working on it , at sourceforge for example.

  • I plugged a Kingston Traveler to my computer to try with Windows To Go Creator.

    My computer (Windows 8.1 64 bit) recognized the USB drive, and I can copy/move data to this drive, but AOMEI tool cannot recognize the USB, even I pressed Refresh button couple of times.

    Could you give me a suggestion?

  • I tried to use Windows To Go creator - the process has been reported finish.

    But when I tried to boot my laptop with this USB, nothing happen. It comes to my normal Windows as regular.

    I tried with Ubuntu in USB and it works, so I do not think there is any problem with my USB port.

  • There is an important point to remember about Windows to Go.  It requires that the drive show up as a hard disk rather than a removable drive.  Windows to Go certified thumb drives do this.  Ordinary ones do not. 

  • i might be a bit behind here... but i finally got the windows to go creator to work... but it wont boot on my asus tablet.  it works on my windows 7 pc however... is there some reason this wouldnt work on a device already running windows 8?

    Thank you,


  • Mcfallderrick,

    Be sure that the Windows 8 tablet is setup to be able to boot from the USB device.  Also, make sure that it's configured for the type of boot setup you're using (UEFI or MBR).  Instructions for how to do this should be available from Asus for the tablet.

  • Hello friend, I read that your Windows To Go Creator creates an image of windows on an external hard drive but only Windows 8 and 8.1. If I wanted to instead create a copy of Windows 7 how can I do? Obviously trying with your program tells me that the iso that use is not Windows 8 and does not go forward. Can you recommend a program that is similar to yours, but I can use it for Windws 7? thanks

  • Robytotem,

    Windows to Go is a feature of Windows 8/8.1.  It is not supported with Windows 7.  You can create a PE with 7 using Aomei PE Builder, but this is not the same thing. 

    PE Builder

  • I am trying to create a 'Windows To Go' install on a Monster 3.0 256GB SSD USB 3.0 drive using a OEM 8.1 disk as the source for INSTALL.WIM file.  It completes successfully but when trying to boot on a number of different computers it seems to start attempting to boot into the USB but gets a BSOD error, fails, and restarts.  Also the drive is listed as a REMOVABLE DRIVE in Disk Management as well... Any ideas?    

  • me too have the same problem, at the start its look like getting so smooth, it didnt boot, in my first try i used 16gb Sandisk cruzer edge, and in my second one i used 40gb fujitsu but gave same result on boot.

  • Windows to Go creation was working fine using a USB 3.0 adapter cable

    connected to an external SSD: Win10 64-bit "Redstone 2" version 1703, build Wanted to update to latest "Redstone 3" version 1709, which (from previous experience) requires a complete re-format and re-install, due to it being an external USB bootable drive. Attempting an "in place" upgrade results in a non-bootable drive.

    However, after that was all finished upgrading, ended up with Windows 10 S (version 1709), instead of Windows 10 Pro (version 1709). The .iso file title is: "16299.15.170928-1534.RS3_RELEASE_CLIENTCOMBINED_UUP_X64FRE_EN-US.ISO"

    which should have resulted in Windows 10 Pro being installed, and not Windows 10 S.

  • Update: Rufus was able to correctly install Windows 10 Pro "to Go" on an external USB drive, via providing a pop-up windows that allows selecting from among about 8 or 10 different Windows 10 versions, such as: "N", "S", "Home", "Pro", etc.. AOMEI needs to consider adding that kind of feature.

Sign In or Register to comment.