Problem with Keyboard layout

Hi


Today I tested to restore a HDD from backup. I created a Windows PE Bootable Disc and stored it to an USB stick. Booting from this USB stick is no problem, but the keyboard layout is wrong.


I am using german version of AOMEI Backupper. However, I life in Switzerland. In Switzerland the main language is also german but the Swiss keyboard layout is different to Germany (because we have multiple officially spoken languages in Switzerland)


So, normal usage of my AOMEI Backupper is fine, it is (rather poorly translated) german and the keyboard layout is Swiss.

But when I boot from AOMEI Bootable Disc then the language is german but the keyboard layout is Germany (not Switzerland).

The main problem you will face when you like to connect to your NAS with Username/Password and the password contains special characters. It will be very hard for you to find any special character on a Swiss keyboard which is treat like a German keyboard.


Best Regards

Wernfried











Comments

  • We are not sure what the "keyboard layout" is, can you say it in more details?

  • Same here, had to adapt password strategy.

    Keyboard layout  / mapping in Belgium is AZERTY iso QWERTY definition

  • edited May 2017

    You can open cmd prompt and use wpeutil

    https://technet.microsoft.com/en-us/library/cc765969(v=ws.10).aspx


    To make it easier, just export your keyboard setting in your running windows


    reg.exe export "HKCU\Keyboard Layout\Preload" "keyboard.reg"


    Then add keyboard.reg to windows\system32 in your bootable wim file.


    Load the setting by adding this as the first line in windows\system32\winpeshl.ini:


    regedit /s keyboard.reg


Sign In or Register to comment.