How do I make a USB boot stick? (Win 10)

Hello everybody,

I recently upgraded to the Creators Edition of Windows 10 (Win 10 Pro 64, legacy mode, hard disks MBR formatted), but I'm not happy with it and want to go back.

Luckily I made a backup of my hard disks with AOMEI Backupper 3.2 before on an external USB harddrive.

My problem: How do I make a USB boot stick? (My PC has no CD/DVD drives)

- I tried AOMEI Backupper > Utilities > Create Bootable Media > Linux, and I was able to boot my PC with it, but it doesn't recognize my external USB harddisk where my backups are located. It only shows the USB boot stick, my internal harddrives C: and D: and some LAN thingy. But my external USB HD "E:" isn't there.

- Then I tried AOMEI Backupper > Utilities > Create Bootable Media > Windows PE.

I downloaded the 1.7GB KB3AIK_EN.iso, extracted it to a folder and ran StartCD.exe.

I installed the Windows AIK successfully, but AOMEI Backupper doesn't recognize it. It says "Windows AIK is not installed".

Afterwards I updated AOMEI Backupper to the latest version (4.0.3), but the problems persist:

- the Linux USB boot stick doesn't see my external USB harddrive

- I can't make the Windows PE boot stick because it says "Windows AIK is missing".

What should I do?


  • Your upgrade of 10 may have messed up the winre entry. That is why Backupper is asking for AIK- it can't find winre.wim.

    You might try opening an admin command and type:

    reagentc /disable

    (press enter)

    reagentc /enable

    (press enter)

  • edited May 2017

    When do you plug in the external hard drive? Before the boot or when Aomei from boot CD is running? In the latter case you should click the two round arrows next to Menu to reload the disks. Wait a minute for Aomei to recognize this disk and then choose Path in the Restore tab. The external disk is displayed as /mntxxxx.. Not as drive E: or any other letter.

    I tried Linux with a MBR and with a GPT external disk. Both were recognized.

  • Oh... normally Backupper should make a Windows PE boot stick on Windows 10 without asking for the AIK? Interesting.

    I did as you suggested, and both times reagentc told me that the operation was done successfully.

    Looking at my disk manager I can also see a hidden 450 MB Recovery Partition. (It says it's empty... but the Disk Management app always says that, even when it's not empty, I think.)

    However even after disabling and re-enabling it successfully, AOMEI Backupper still doesn't want to make a Windows boot stick. It stillk asks for the AIK.

  • edited May 2017

    I never needed other software (like AIK) to create a WinPE iso. It always worked directly from Aomei. You can also make a WinPE drive on another computer. The only thing that won't work is a 64 bit CD on a 32 bit computer.

    By the way, you don't even need a USB drive to Boot from the Iso. I made, for test purposes, a multi boot (using EasyBCD) with entries pointing to the Aomei Linux en WinPE isos. Just restart PC and choose the Iso.

  • Thanks, I see.

    I still have a Vista (32 bit) laptop that I barely use any more with which I made a AOMEI Backupper USB boot stick some time ago.

    Do you think I can use that 32 bit Vista USB stick in my Win 10 (64 bit) PC to restore the backups? If I understand correctly, only the other way around (64 bit stick in 32 bit PC) doesn't work, right?

  • edited May 2017

    Yes big chance it works.  32 bit OS on a 64 bit computer is no problem. You know, most software is 32 bit. But 64 bit OS or other software on an old 32 bit computer can't run.

  • Update: Looking good so far. The Linux/Win PE USB boot sticks
    apparently don't like my external HD on a USB 3.0 port, but USB 2.0
    seems to work.

    More precisely:

    1. I
    used my old Vista 32 Win PE USB boot stick and it seemed to work. That
    one however seemed to jumble up my partitions (it gave everything wrong
    drive letters, and my normally hidden 450 MB recovery partition got its
    own drive letter which it normally doesn't do and so on).

    Could I
    still use that to recover my Win 10 Pro 64 bit system? Maybe, but
    because everything was in disarray, I didn't want to test it.

    However there was another problem: My external USB hard disk (1 TB, USB
    3.0, NTFS/MBR formatted) containing my recovery images still didn't
    show up, just like when I tried the Linux USB boot stick.

    some time however I found that my external HD will show up just fine if
    I plug it into a USB 2.0 slot - both in a Linux and Win PE USB boot

    I don't know why both Linux and Win PE don't like USB 3.0
    (the hard disk works fine and error-free under Windows 10 with USB 3.0),
    but whatever...

    I think I will use my Linux USB boot stick (the
    old Vista Windows PE one looks a bit sketchy to me, as described above)
    and my external HD in a USB 2.0 port to recover my images now. Might
    take quite a bit longer to recover a 300 GB image via USB 2.0, but it'll
    hopefully work at least.

  • There are two points we need to clarify:

    1. Windows 10 needs ADK, not AIK. You could download ADK for Windows 10 from here:

    2. The 64 bit WinPE can be used on a 32 bit PC, actually, it has nothing to do with the current operating system. Unless this computer only has a x86 based processor(this kind of computer is very rare now).

    Your Vista WinPE doesn't have USB 3.0 drivers, so it cannot recognize your external hard drive, we recommend the Windows 10 WinPE.

  • Drive letters shown in bootable USB or CD are not important. It is only for that moment in that Operating System. Restore should work just fine.

    Glad to know it was the USB 3.0 that misbehaved.

  • edited May 2017

    The 64 bit WinPE can be used on a 32 bit PC, actually, Unless this computer only has a x86 based processor

    That is what I meant. 32 bit OS is usually found on old x86 PC's. I Call that a 32 bit PC, which it is of course. I did not talk about the current OS. A 64 bit WinPE cannot run on a 32 bit PC. (PC = hardware)

  • Thank you, JohnnyboyGo, we appreciate your active participation.

  • Thanks everybody!

    I was ready to restore my system with the Linux bootable USB stick (worked right out of the box, but only supports USB 2.0).

    But after downloading the ADK (which took a while, because it's 4.4 GB big) I was able to make a Windows 10 WinPE bootable USB stick with Backuppper, and with that one my external HD even works on a USB 3.0 port.

    Great! When I'm done, I will make sure to keep the bootable WinPE USB stick in a safe place for the next time I might need it... :)

  • Hi!

    I am also about to restore a Windows 10 64-bit (1809) backup from a Linux bootable USB, but have a question beforehand. Since the USB only boots in legacy mode, will it correctly restore my GPT system? I am hoping that it will not convert it to MBR! Would someone please clarify. Thanks!
  • @me_myself_i ; Yes, it will correctly restore your GPT system.
  • Thanks admin, but the restoration does not work! My NVME/GPT destination disk is not seen in the "Partition Restore" window, almost certainly because I am booting up in legacy mode. Is there a solution to this?? Backupper was happy to backup my system, but refuses to restore it! This is not good.
  • I created a Windows PE boot disk, but USB (NTFS) will not boot. Only a DVD will. Any ideas why? My computer supports USB boot, is in legacy mode with secure boot off. It should work!
  • @me_myself_i ; So did the Windows PE boot disk recognize your NVME/GPT destination disk?
  • Yes it did, admin. Thanks!
  • @me_myself_i ; Did you export the ISO and use a 3rd-party software to burn the ISO to USB?
  • I created the USB media two ways. First, using Aomei directly, and then burning the ISO with RUFUS. The DVD was burnt using Aomei directly.
  • @me_myself_i ; Is it a Legacy boot ISO? Please try another burning software like UltraISO.
Sign In or Register to comment.