Home AOMEI Products Support


I want to run "net stop MSSQL$databasename" as pre command
and "net stop MSSQL$databasename" as post backup command in Server Backupper.

How am I supposed to enter it in Configure user command window?

When I just enter "net stop MSSQL$databasename" in command field it prompt me that working directory must be entered and whatever combination of information I provide to "command", "working directory" and "arguments" command execution fails.

Can you help me with how to enter given command so it work?

Some examples on Help guides would be awesome as well.


  • How about c:\windows\system32\cmd.exe for the command
    /c net stop... for the argument
    c:\ for the working directory?
    (I don't have the paid version at home, and we haven't upgraded to 5.0 at work yet, so this is just a guess.)

    At work, we use the command line version in a .bat file and stopping and starting MSSQL would be straightforward except the cmd line version starts something else and then terminates, so we periodically check that other aomei programs have finished before restarting MSSQL.

  • edited August 2019
    Thanks. I tryed your idea but it did not help.
    I got cmd to "start" but it does not start fully. It just opens black application window with no text output and with no input available.
    I got to that point with
    - command: cmd.exe
    - working directory: C:\Windows\System32
    - arguments: none

    however I split "net stop MSSQL$databasename" to end of command and arguments still no luck.

  • Can you show me your settings of Pre/Post-Command?
  • I tried lot of different options, this is last I tried.
    Is there any page with working examples as I may be doing it completely wrong?

  • The same for me, running a bat file to shutdown the pc in post-command is not working. Nothing is happening after the update is done.
    If I run the bat file manualy, everything is ok..
  • I had the same problem running a post command for the program sleep.exe.  When I typed the command C:\sleep.exe it would not run. When I would use the browse option to locate the program it ran. Go figure.
  • Please try this:

  • edited August 2019
    Thanks, your example work fine.
    Some in application popup example over "?" or something would be good for UX.
Sign In or Register to comment.