Home AOMEI Products Support

Partition Assistant Standard SSD Secure Erase

I've tried on two different machines running Win 7 Pro 64-bit.  Four different SSDs.  Secure Erase wizard says my drive is locked.  I unplug as directed (power, sata, sata, power), hit next, says it is successful.  The drive structure disappears from Partition Assistant and from Windows.  I reboot and its as if Partition Assistant did nothing.  The original drive contents are all there!  Help!


  • Hi, please upload a screenshot of the error.
  • I'm not sure what you would like to see.  There is no error message.  It acts like it did the Secure Erase on some virtual drive, because the contents appear to go away until the next reboot of the machine, or until I move the drive to another machine.  Then the partitions and files are all still intact.  It did NOT erase the drive.

    I used the word locked above.  I believe the actual word was frozen.

  • Could you tell us the brand and model of your SSD?
  • On a Dell Optiplex 780 I tried a Toshiba TL100 SSD.  On a Gigabyte GA-B75M-D3H motherboard I tried Silicon Power A55, Crucial MX500 and PNY CS1311 SSDs.  All acted identically.
  • Any thoughts on this?
  • Sorry, no idea.
Sign In or Register to comment.