Home AOMEI Products Support

Unable to boot / Windows can't repair after disk backup restore to replacement drive

edited February 2018 in AOMEI Products Support

The machine is running 64-bit Windows 10 home whose HD failed and I replaced it with a different, smaller drive that I had on hand.  It too was in a machine running Windows 10, but that shouldn't matter and there's plenty of space even though it has less capacity.

The backup type was a Disk backup with licensed AOMEI Backupper Pro.   After restoring, the mackine won't boot and Windows is unable to fix the problem.  In another foorum topic I saw a similar situation and I trieduplicating the fix, but it didn't work.  Here are the details of what I did and also posted in that topic.

I have what I believe is the same problem but when I go through the steps after entering:

bcdboot c:\windows /s L: /f UEFI

I get the error:

Failure when attempting to copy boot files.

Is the problem locating the source files or is it writing to the destination, or something else?

My letter L drive is FAT32, type Partition, size 101 MB, Status Healthy unlabeled, and has the following directories:



My letter C drive is NTFS, type Partition, size 164 MB, Status Healthy, labeled Recovery and is empty.

My letter G drive is RAW, type Partition, size 16 MB, Status Healthy and unlabeled.

letter H drive is NTFS, type Partition, size 232 GB, Status Healthy,
unlabeled and is where where my Windows directory (and others) resides.

Any help would be greatly appreciated as I have emailed AOMEI tech support, haven't heard anything back and the machine is down.


  • I found the most helpful information at the link below.  It didn't solve these two errors:

    BOOTREC /FIXMBR which resulted in an error about a missing element which was fixed by first running:

    bcdboot c:\Windows /s <boot letter>: /f ALL

     and the error

    Failure when attempting to copy boot files.

    which I fixed by copying theme where they needed to be (sorry - I don't remember the exact details and if I do I'll update this thread).

    Here's the link:


    I'm almost back to where I should be.  In the process, drive letters were assigned to volumes that needn't have them, making them appear when they don't or shouldn't look like user accessable drives.  I'll try fixing this by deleting the drive letter under Windows disk management.

    The other thing is that in the process of rebuilding the BCD it found a Windows.old since the machine went through an update and hadn't yet been celaned out.  It was added to my boot choicesand was not bootable resulting in a TSOD (Teal screen of Death).  I fixed this by using msconfig32 at an administrative command prompt.

    I'm not sure if I covered everything here because I'm going from late-night memory.  I suggested to AOMEI's tech support response that I belive Backupper Pro needs to address this by itself.  Here's the correspondence (sorry about the bad formatting, I did a copy & paste and don't care to clean it up):

    I didn't change anything in the BIOS and I don't believe there is
         a provision to do what you suggest.  This problem also occurred on
         my desktop machine when I needed to restore my system disk to an
         earlier state because of a problematic Windows update and there
         were no restore points when it made the update.


    I'm mostly back up and I suggest you might look at my post in the
         forums where I added a lot of detail on how to fix this.  I think
         Backupper Pro is missing some functionality in the restore
         operation that needs to address this situation.  I believe the
         information I posted in the forums is well beyond the capability
         of most users.



    On 2/27/2018 1:56 AM,      [email protected] wrote:




    Thank you so much for contacting us.After
               reading your email below I guess that you find an disk
               backup image file stored on an external disk , connect
               replaced disk on this dead pc,boot the dead pc from bootable
               disk created by Aomei Backupper to perform disk
               restore,right?If so,did you change boot mode after doing
               disk restore?What I mean is if your replaced disk is MBR
               disk,then you need to go to BIOS to set it to boot based on
               Legacy and if it is GPT disk,set it to boot based on UEFI
               after doing restore.So would you please delete delete all
               partitions on target disk first and retry disk restore.After
               doing restore,you can see it is MBR disk or GPT disk via
               Aomei Backupper.


    Have a great day. 


    In case this email does not fully answer your question, or you would like to contact us for any reason, simply

     reply to this email.

    Best Regards,


    AOMEI Support Team

    Optimize System, Optimize Life



    What do you think of my support?


    What do you think of our products?





    From: Tom Sepka

    Date: 2018-02-27 11:17

    To: support

    Subject: RESEND: Need detailed instructions
                     after replacing failed hard drive

    I'm using Backupper Pro (licensed version).

    The hard disk in my laptop with a UEFI BIOS failed
                     and after replacing it I'm trying to restore it from a
                     disk backup.

    The replacement disk came from another machine that
                     was running Windows 10, but that shouldn't matter
                     since I expect it to be overwritten with my restored
                     disk backup.  I tried doing a disk restore after
                     booting from my AOMEI boot disk, but apparently I
                     didn't do something correctly because the machine
                     won't boot.

    What is the proper step-by-step procedure to restore
                     my disk backup to the replaced disk, keeping in mind
                     that it came from a a machine already running Windows
                     10?  I don't know anything about how it was
                     partitioned or formatted and I don't care because I
                     expect the disk restore process to take care of
                     anything it needs to in order to restore my backup and
                     when it's done make it bootable again.

    Even though the replacement disk is smaller than the
                     original, the amount of space used easily fits on the
                     smaller disk.

                     haven't heard anything back and need urgent help as I
                     have a machine down.  While waiting for a response, I
                     tries the following based upon a similar situation
                     discussed in the forums:

    I have
                       what I believe is the same problem but when I go
                       through the steps after entering:

                       c:\windows /s L: /f UEFI

    I get
                       the error:

                       when attempting to copy boot files.

    Is the
                       problem locating the source files or is it writing
                       to the destination, or something else?

                       letter L drive is FAT32, type Partition, size 101
                       MB, Status Healthy unlabeled, and has the following



                       letter C drive is NTFS, type Partition, size 164 MB,
                       Status Healthy, labeled Recovery and is empty.

                       letter G drive is RAW, type Partition, size 16 MB,
                       Status Healthy and unlabeled.

                       letter H drive is NTFS, type Partition, size 232 GB,
                       Status Healthy, unlabeled and is where where my
                       Windows directory (and others) resides.

                       help would be greatly appreciated as I have emailed
                       AOMEI tech support, haven't heard anything back and
                       the machine is down.







    Virus-free. www.avg.com


  • edited February 2018

    Hard to read all that so I may have missed something...but..if your current backup is formatted GPT and using EFI and the disk you are using to restore to was formatted MBR, you will not be able to use it as it is. You need to clean it and convert it to GPT in diskpart. If you need directions how to do this (very easy) just post that.

    I can personally vouch that is the case as the first restore I tried for a friend's new PC from his old HD which was GPT would not restore to a used spare SSD that was MBR even though both were running Win10. I cleaned the SSD and converted to it to GPT and the restore worked fine. I had never seen a GPT disk until that point. I learned a lot from that experience. (Thank you @JohnnyboyGo!)

  • I bought the machine used with W10 installed and I never cehcked to see how the disk was GPT or MBR.  I just did a disk backup of it since my only interest was disaster recovery.  Should it fail, I'd replace it and blindly do a restore and expect to be back up and running again.  The replacement disk came from a W10 machine and I didn't know or care if it was MBR or GPT because I expected everything there to be overwritten.  And if it needed to be formated I expect the restore software to seamlessly deal with it.  Hopefully that's how backupper's restore function works.

    Prior to the final restore attempt I did a diskpart > clean on it and then ran the restore operation.  I do know that the backups previously made from the drive that died were shown by backupper to be MBR and the replaced disk is MBR (at least now it is, don't know what it might have been before.

    So after the last restore I still had no boot and Windows could not repair it.  I resorted to command line bootrec /fixmbr, /fixboot, and /rebuildbcd.  These threw a couple of errors, one being not being able to find the boot files and the other a complaint about a missing element.  I don't recall the exact details and wording.

    I was able to copy the boot files to where they needed to be (again I don't recall the exact details.  The error about the missing element was fixed by entering:

    bcdboot c:\Windows /s <boot letter>: /f ALL

    That one took some digging to find based upon the missing element complaint.  I didn't know if it would help or hurt but since I was still dead in the water I gave it a try and after tha I was finally able to boot.

    I ended up with 2 boot options because 2 installations were identified:



    I told bootrec /rebuildbcd to only keep the c:\windows one because the other one was from an update.  It added both anyway so when I booted I got a choice of which one to boot.  Only c:\windows work as I expected and I used msconfig32 to get rid of the other one from my boot choice and so now I don't have to choose and I am pretty much back up and running.

    One of the tings left over is that drive letters were needlessly assigned to all of the volumes and they show up as drives.  I'll go back and get rid of their drive letters.

    As always, observations and comments are welcomed.  I hope this makes a bit more sense now.

  • Glad you got it to work. You seem to have a good grasp on this. I'm not sure what you had or have now but if you're happy with it.....

    As a side point, I recently did a test DISK restore to a spare SSD and it added a letter to my system recovery partition. I contacted support and they told me this was a program glitch that they were aware of but had yet to fix. Not great but removing the letter like you plan was the only remedy.

  • Everything was fine until now when Windows tried to do its latest update, Feature update to Windows 10, version 1803.  Here's what happened:

    Windows 10 couldn't be installed
    Windows can't be installed because this PC has an unsupported disk layout for UEFI firmware.

    I tried to convert the disk to GPT as outlined in this link:

    It didn't appear to do anything except to return to the command prompt.  I tried in both a command prompt window and by booting into the recovery environment using the Backupper Pro recovery disk.

    The MBR-to-GPT conversion problem was resolved with a copy of Partition Assistant graciously provided by AOMEI.

  • I have the same issue.

    Dell PC, Windows 10x64, UEFI boot.

    The Dell partition structure is possibly different from standard with the recovery partition & diagnostic partition but Dell is a very common brand and other manufacturers most likely user a similar structure.

    Using USB WinPE based AOMEI backupper 4 I make a full disc backup on a spare hard drive connected via a USB adapter.

    I then remove the hard drive from computer and fit another of the same nominal capacity.

    I run Aomei Backupper disk restore which recreates the partitions.

    The PC will not boot.

    The fix I found:-

    I have the original drive and a Win10PE USB boot tool.
    From this I run Pauly Bootice to take a backup of the Partition table of the original drive.
    I apply this to the clone.
    The PC now boots.

    However I could only do this because I had the original drive. If I only had the backup I could not have done this.

    I don't know what would happen if the drives were different capacities be they larger or smaller.

    Aomei Backupper needs updating to include the same functionality as Pauly Bootice that will work when the replacement drive is a different capacity to the original.

  • Today I applied the same backup file to a smaller hard drive.

    Again this did not boot.

    However applying the Partition Table did not work either.

    After wiping the drive and applying the image again what did work was from the Win10x64 USB tool drive running a batch file a colleague wrote containing

    bootrec /scanos
    bootrec /fixmbr
    bootrec /fixboot
    bootrec /rebuildbcd
    bootrec /scanos
    The first boot was very slow but after that faster.

    The drive cloned was AF while the smaller drive was not.
    While irrelevant since I was purely testing I don't know the implications of applying the image from a AF drive to a non-AF drive.

    Likewise I don't know how Backupper processes applying the image from a non-AF drive loaded with Win7 or later to an AF drive.

  • @delta925 Do you remember the boot error?
  • Admin,
    I did the restore again.

    The screen says
    A required device isn't connected or can't be accessed.

    Error code

    My thought is the issue is that Backupper is not correctly identifying and restoring the details of all the partitions.
    In addition to the small first partition and the main OS partition there are others for diagnostics and recovery. In the layout some are between the small first partition and the OS partition. The system I am using was originally Windows 8.1 and upgraded to 10. This ought not to make a difference or if it does Backupper ought to cope.

    I have another system that is Win10 Pro out-of-the-box to experiment with as time allows.

    What I did find today was that Macrium Reflect 7.1 can restore to the same 500GB drive and it is bootable that with Backupper was not bootable. Macrium can not restore to a smaller drive without spending time with the configuration, I will try when I have more time.
  • edited June 2018
    Disk layouts of the original 500GB drive and the 320GB drive as restored from the image ( repair not attempted ). Do these help ?

    On the layout from AOMEI the source has four partitions with a *, on the clone there just one with the others allocated drive letters instead.

    The small 40MB partition is not showing on the clone.
    Also notable, but probable not affecting boot, is that the 750MB  partition has been grown to 1.06GB.

    Your staff ought to be able to replicate this with Dell or other branded systems.

  • @delta925 Thank you for the information, we will analyze the problem.

  • The original and clone disk structures as seem by Bootice and Macrium Reflect with the drive as the second drive and the system booted from Win10PEx64.
    For the first post the drives again were a slave but the system booted from Win7PE x86. That PE build does not have Bootice and Macrium Reflect.



Sign In or Register to comment.