Home Storage Guides, Tricks and Tips


I’m sure that many people like me have encountered such problem: when install a new 3tb disk into computer, only 746gb (not 745gb or 747gb, but exactly 746gb) shows. Through surfing the internet and shifting from forum to forum for solutions for this, finally, I am able to grab some. Now, I’m trying to put my accomplishment here to see whether I can give a hit or not.

Let’s go directly.

To begin with, we’d better make some matters clear. Firstly, to make full use of the 3tb storage space, we must make the disk a GPT style. Furthermore, for most Windows users, they can only take full advantage of 3tb hard drive if their motherboard supports EFI/UEFI BIOS. Otherwise, they have to set the 3tb disk as a secondary storage device. 

More about 3TB hard drives

External drive or internal disk?

Then, we should know what the role the drive plays, an external disk or an internal one, when the issue occurs. If it serves as an external hard drive connecting via USB, the problem may be caused by the enclosure of the drive. The USB controller must support 3tb hard drive. If it really is the controller problem, we can update it to fit 3tb storage. Sometimes the manufacturer of the USB-SATA bridge chip (eg JMicron, Oxford, PLX Tech, Cypress) in the enclosure will provide a firmware update. 

If it is not resulted by disk enclosure, we can give up external hard disk to internal drive. Once a user with a Hitachi drive has encountered this problem and did solve it by installing it directly into the machine, formatting it there, and then putting it back in the external enclosure.

Yes, we can format the disk in GPT and partition it into a few separate Partitions (better NTFS). Or, initialize it in Windows Disk Management in the GPT partitioning scheme.

User Experience 1:

A user ever had such experience (provided the system has standard controller for any windows 7 x64 based computer):

1. Create a partition on the 3tb drive using a partition softeware. Make the left side 1tb and the remainder behind the partition.

2. Run windows 7 x64 install disk (with the 3tb drive being a secondary drive another hard drive had windows 7 x64 already installed) and format both parts of the 3tb but leave the partition.

3. Take out install disk and reboot. Open “computer” and he sees that the first part of the drive shows 97.6gb and the second part shows 2.6tb total space. This is the entire 3tb without updating any drivers or new controller.

However, in some cases, we may only have to update system driver. There are a lot of users confirmed that they succeed by upgrading their Intel Rapid Storage Technology (Intel RST) drivers from version to 10.1. If does not have a network connection, the easiest thing to do is use the manufacturer’s installation media which often has older versions of things like Intel RST drivers.

After upgrading RST, go into the disk management utility (Not just my computer) to see that pc could now see the additional un-partition drive say 2.2tb, deleted the 746gb volume and then re-partition the entire 2.7tb and then my computer bit could see the full 2.7tb.


If the related driver and adapter are included in when buy the disk of 3tb, the disk must be installed to computer according to instruction. Besides, the driver necessary for the disk should also be installed correctly. Only in this case can it ensure the whole capacity of the disk be recognized by computer.

User Experience 2:

Another user has also solved this issue in his way.

[Firstly, I'm running Windows XP 32 bit on an EVGA/NVidia 780i motherboard. I recently installed the Seagate st3000dm001 (3TB) drive just like the op but it only showed 746gb no matter what. I even tried boot CDs for Seagate's DiscWizard and others. I could get the full 3tb to show in these boot cd applications, but they would refuse to show in the actual XP operating system. 

Finally what did it was changing the SATA drivers to the generic windows drivers. To do this, I simply did the following:

- Open device manager

- right click on "nforce Serial ATA" driver and selected "update driver."

- Click "No not this time" for "can windows connect to windows update", then Next->

- Select "Install from a specific Location, then Next->

- Select "Don't Search, let me choose which file to install", then Next->

- Select, "Have Disk..."

- Select a generic option. In my case it was "Primary IDE Channel" or, alternately "Standard IDE hard disk controller" or something similar along those lines.

- Important: be sure to complete this process for each entry of the nforce sata drivers. Defer the Reboot request until you've done all of them. 

- When you reboot, your system will reinitialize each or your hard drives.

- Install DiscWizard, and initialize the full 3tb. 

- use Disk Management (Right click on My Computer, select "manage") to create the desired partitions. ]

OK, until here, if a new 3tb hard drive only showing 746gb, we may format and partition it or update/change the drivers. If it’s an external disk, its enclosure must agree with its size, or you have to install related drivers to recognize it. This is all I get, so I’d like to stop here. If you have other solutions for this problem, welcome posting it under this essay!


  • I know this is old [and perhaps solved] but I'm posting my solution on a few of these "New 3TB drive showing as 750GB" threads because I never found this specific [super easy] fix posted anywhere. 

    Updating the ATA Controller driver via Device Manager was my first idea but it always said "up to date" so I tried many many other things until coming back to the driver. As it turned out, the latest RST driver from Intel [13 something] was not compatible with my ATA controller chipset [Asus P8P67 Pro MB, Win 7 x64, with version 10 Intel RST driver] so it wouldn't self-install/self-update. Intel chat ended up providing a link to a legacy version of RST [12 something] and installing it solved the issue immediately.

    The link to the Intel RST Driver that worked for me is provided below. The SetupRST.exe from there is all I used. Good luck.


Sign In or Register to comment.