Restored successfully, but my computer won't boot

The SSD drive on my Lenovo T450s (running Windows 10) died so I purchased a new one.  The new drive is an equivalent SSD, just larger.  I booted to an AOMEI boot drive, ran the restore option and restored a system image I had stored on an external hard drive.  Everything went fine with no errors, and the software reported that the restore was successful.

However, the computer won't boot.  I get a black screen with just a blinking cursor.

Since I first did the restore using the universal restore option, I tried it again without checking that box.  But I get the same blinking cursor result.  It appears that Windows doesn't know where to find the boot info on the new drive, but I can't figure out how to fix it.

Can anybody provide some guidance in fixing this?  Thanks.

Comments

  • On restore, Backupper erroneously assigns the 'C' letter to the small System partition from which WIN10 boots. It then assigns "D" to the main WIN10 partition. The System partition should not have a drive letter assigned to it. If it does the computer won't boot. This is an ongoing bug with Backupper which AOMEI does not seem interested in fixing. To fix this after a Restore, while still booted via the AOMEI boot drive or disk, use the Partition Assistant on the boot drive or go to a Command prompt and run Diskpart. Then remove the drive letter from the System partition and assign "C" to the WIN10 partition. The computer should then boot OK.
  • edited October 2018
    Or...if your PC is an UEFI machine you need GPT formatted disks to boot. If your new SSD is formatted MBR (the default) it must first be converted to GPT. If you made a Disk Backup that is done for you by Aomei. But  you wrote I made a System image, so I presume you made a System backup. In that case you must convert the disk to GPT yourself using Diskpart. Diskpart is in the Aomei utilities menu of the bootable media. You can check the current MBR/GPT style in Aomei too. See image. BIOS machines need MBR disks and UEFI needs GPT disk to boot.

    B.t.w. I never had the problem Chris described. I even tested this week 10 Restores in different scenario's. They all went well. As fas as I understand Drive letters are not assigned by Aomei but by Windows at first boot when restored on other disk or through the registry if restored on the same disk. 


  • That's interesting JohnnyboyGo. I did this re-assigning of drive letters once when a restored HD (from a disk backup) wouldn't boot and I inspected the restored HD using Backupper's Partition Assistant and noticed the odd drive letters. It then booted OK so I assumed that the drive letter re-assignment had fixed the problem. I've since done the drive letter re-assignment each time I've done a restore without seeing if the restored HD would boot anyway. Maybe it would and the first time I fixed something else without realizing it.
  • Thanks for the replies. So I tried renaming the drives with Diskpart, but it didn't fix the problem. I haven't tried reformatting with GPT yet.  I'm not sure the original system disk was formatted that way. My BIOS is set to boot legacy mode first, which would lean to an original format of MBR, correct? I don't recall formatting that drive as GPT when I first set it up.  

    It it takes a long time to restore the image, but I guess I'll try it overnight. If it doesn't work is there something else that could be the problem?
  • edited October 2018
    @facilman92: If the original disk still functions you can check the partition style when you connect it through USB or when installed internally through the Aomei boot disk. See image above. Or with Diskpart->list disk. GPT disks are marked with an *  in the GPT column..... Oh, it died, pitty.
    New disk and old disk must have the same style. 

    My BIOS is set to boot legacy mode first

    legacy is BIOS/MBR. Can your BIOS boot legacy first and UEFI second? I've never seen those. My computer is either legacy or UEFI.
  • edited October 2018
    @Chrisj Drive letters seen in the bootable media are completely different than when booted from the internal disk itself.
    Note that when booted from DVD or USB the OS is on that DVD/USB disk and all other disks are seen as data disks.
  • Changing to GPT didn't work. I cleaned the drive, switched it to GPT and restored the image. But I still have the same problem with getting the blinking cursor. My BIOS can boot with legacy or UEFI. Neither setting worked, but it was originally set to legacy first, so I do think my dead drive was MBR. Any other ideas for fixing this?  It's frustrating that the image restored properly but the system just can't figure out how to boot. 

    I agree that changing the drive letters in Diskpart seems to have no durable effect. Any changes I make don't seem to get permanently assigned, and they revert when I boot back with the bootable media. 
  • What kind of SSD you're using now and how big is it? 
  • It's a Transcend M.2 SSD with 256 GB
  • edited October 2018
    Is it seen in BIOS? Can you do a fresh install of Win10? I've no experience with m.2.
  • Yes, the BIOS sees it fine.  I was able to do a fresh install of Win10 on it before restoring the image.  Nothing special about an M.2 drive.  It's just an SSD on a card instead of in a housing.  It works the same as any other SSD once installed.
  • edited October 2018
    Don't know what went wrong. You made a system backup, right? That consists of a system partition and a C partition.  Can you explore them in Aomei Utilities menu? No errors?
    Then I would try to install Windows 10 again on a Cleaned SSD (with Diskpart). This gives you a clean system and C partition. Next you can try to restore only the C partition of the backup onto the fresh C partition, resulting in new system + old C partition. See if that boots.

    Or, divide your SSD in two partitions: C. fresh install of Win10, D. restore of only the C partition of the backup
    Then in new Win10, create a dual boot menu with EasyBCD by adding the OS on D to the boot menu. Boot and choose the restored OS. Normally it should boot unless your backup is broken.

    Select No if you want to restore only 1 partition: Next you can select the partition and the destination.
    Untill now you always selected Yes, right?


  • Yes, I was always selecting yes to install the system image.  I'll give this process a try and see if it works.  I'm heading out of town so might not be able to finish soon. Thanks for all your help.  
Sign In or Register to comment.