Access Denied - Unable to Open Folder After Backup

Hello, I backed up my C drive because I needed to Reset My Computer to Factory Default. The backup went well and I am able to browse and access almost all files except one folder where all my documents are. Here is what happens when I try to access:

1. I get this message:
      "You don't currently have permission to access this folder.
      Click Continue to permanenly get access to this folder

2. I click on Continue.

3. Then I get this message:
     "You have been denied permission to access this folder."
     To gain access to this folderyou will need to use the security tab.

4. I have given myself Full Access from the security tab to everything that I can think of including of course the folder
    I need but cannot acces because obviously its an image and permission cannot be overwritten.

Any help is appreciated.

 

 

Comments

  • Hello hgrivera,


    As for your problem we feel sorry, I suppose the problem happened after you mounted the image as virtual drive. In order to access this folder, you may have to restore the image to a destination, the destination could be another place other than the original partition. 


    Once again, we are so sorry for the inconvenience. We will do our best to improve it in the future. 


    If you have any further questions or suggestions please feel free to let us know.


    Best Regards,

    AOMEI Support Team        

  • I'm also experiencing the same problem.


    If I understand your answer correctly, the only to recover files from the my documents folder is the restore my whole drive? That is very impractical since I formated my computer because I my drive was bloated with useless things. There are no other ways?


    Again, any help would be welcomed. 


    Gabriel

  • Folks


    This seems to be the same issue that I had and was able to partly resolve by copying the folders out of the backup.  On Win 7 this was C:\Users\Username.  I couldn't open the user folder but could copy and past to my new machine.

    All the best


    Michael

  • Hi hgrivera,

    As for your question, you may try as Synchronicity said or as another moderator darylsonnier's advice in http://www.aomeitech.com/forum/discussion/538/cant-access-windows-7-user-folders.

  • It is a windows limitation.


    The workaround is to copy the folder you want from the mounted image to a writeable drive.


    Or use a file system driver which ignores windows permissions

    http://www.hobeanu.com/accessgain/


    The dev is not going to pay to have that signed, so it runs under 32 bit windows, and win7 32 pe and win7 64 bit pe.




  • edited September 2014

    There maybe another option. It is possible that the current install of Windows has assigned a different user SSID to the installation to the onet contained in the image. A clue to this will be that the folder reports itself as containing zero bytes.


    If this is the case, the folder can be accessed by changing the security descriptor of the folder.


    To do this follow these steps.


    1. Right click on the folder that won't open and select properties.


    2. Click on the  Security tab and clickon the Advanced button.


    3. From the Permissions tab, highlight your user name in the list.


    4. Ensure that there is a tick mark in the 'Include inheritable permissions' box.


    5. Click on the Change Permissions button.


    6. Make sure that your user name is still highlighted, there should be a tick in the box (at the bottom of the user list form) Include etc, also tick the 'Replace all child object permissions' and click on the OK button.


    What should now happen is Windows should now change the SSID of the folder, to your new SSID. Depending on how many files are in this folder it make take some time.


    When it has finished you should now have access to the folder.


    Colin

  • Does not allow alters the permissions . The folders are mounted read-only.


  • There is a quite simple solution actually. Just use a different explorer program (like Q-Dir for example) to view and access the files in the mounted disk.

    Here is the link to Q-Dir: http://www.softwareok.com/?Download=Q-Dir

  • I know this reply is late but I've only just discovered this work around after seeing this thread. Just run CMD as Administrator. It will allow you to browse all the directories of your Backupper drive, includings the ones in question. You can even use 'dir [filename] /S' to search for files.

  • @gem Thank you so much! Nothing worked for me, until I read your comment and installed q-dir. Now I'm able to copy files from the image without restoring the drive. Thanks!!!

  • Hi, 


    I have read this thread and any other related threads I have found.  I have spent hours on this, but even when using q-dir I can't access the files.


    I have a desktop that crashed, and am trying to access the backup on my laptop, that is Windows 10.  Is that the problem? 


    Any suggestions?  I can't copy the folder, I get errors that I can't access it to copy it.  Can't access it directly or change permissions. Can't access it through q-dir.  As happy as I've been with Aomei, if I can't access my backed up files, it really doesn't do me much good.        

  • I have same problem as taralist. I've made disk backup of Windows 10. How can I solve this please??


    I thing it's essential problem, especially if there are all my important data. These misunderstanding makes me thinking about functional alternatives. Even paid.

  • I've tried ALL the options mentioned in this thread. For some folders, copying worked fine, which was the easier solution.


    However, for a specific nasty folder, only the "system driver that ignores windows permissions" option worked. The driver, as mentioned by a previous poster, is here:

    http://www.hobeanu.com/accessgain/


    Since I have a x64 version of Windows 10, I had to go into Advanced Boot Options, then select DISABLE DRIVER SIGNATURE ENFORCEMENT, and then I could install the driver as explained in its readme file.


    I attached the driver only to the virtual partition where my back-up was mounted, and then BAM, magic, EVERYTHING was accessible.


    The driver is easily unattached, so I believe it is a good option, instead of the last resort of creating a new partition in my drive just to "recover" my old partition to copy one or two files...


  • Thank You Very much everyone fr all the usefull replies - Q-Dir dit it fo me (Thanks gem)  as far as accesing individual files. I was not able to copy full folders, but was abl t access files individually and I now have acccess to several critical files I use. Thanks again.

  • I'm using Windows 7 Pro, and backed up my data drive with AOMEI for the first time last night.  The file & folder permissions on the DATA DRIVE were wiped out, and I've spent hours replacing permissions--sometimes file by file.  What could have caused this?  Would I have to expect this if I use AOMEI again? 

  • Sorry for all of that. Actually, the image made with Aomei Backupperare not accessible  through q-dir. You need to restore or explore it with Aomei Backupper.

  • Clarification:  The permissions that disappeared were to folders & files on the data disk of my pc.  (My data files, etc., reside on a separate hdd from the program hdd.)  I wasn't attempting to view the backup image--which was saved to a separate external drive.  Even administrator permissions were gone. 

  • Sorry for the misunderstanding.

    What action you do?

    Partition backup or disk backup or file backup?

    You said you have no permission.

    What your permission you refer to?

    Also when you loss the permission?

    After you fifnishing the backup or restore action.

    Waiting for your reply.

  • edited January 2016

    The Q-dir from #8 works fine but you need to make a shortcut to the Q-dir.exe and run this as an administrator. Than the user files will be accessible and open. Once you know that you need to check "Run as administrator" many other programs with an Open File box will work. Even VB or FileZilla or Word or Excel and in those you can also copy and open the files just like in Eplorer. Alas, Run as Admin in Explorer itself does not work, but many other programs do.

  • Mark: By Word I mean a shortcut to winword.exe and Check Run as Admin.

  • Aomei Backupper will just be run under the Administrator account.

  • edited January 2016

    #21 Don't understand what you mean, Can you elaborate on that?



    I tested system backups of C: drives (holding the OS) on 4 PC's:  Vista, Win7, Win8.1 and Win10 and I explorered every backup on every machine (4x4=16 tests).


    I focused on the Users folders like Documents and Pictures. Are they accessible on every machine through the Explore option in Utilities, using Windows Explorer. This is important if your computer is broken and you buy a new one probably with a new OS on it. You want to extract the user files from the backups.


    Well, on Vista and Win7 every of the 4 backups was fully accessible. No problem.


    On Win8.1 and WIn10 the User folder was only accessible for the own backup, not for the backups of the other 3 PC's. 


    But the trick to make e.g. Win7 backup Users->Document accessible on Win10 was to use CMD.exe, Winword.exe or Q-Dir.exe running as Administrator. Then all 4 backups were fully accessible in Win8.1 and Win10.


  • edited January 2016

    This messenger suggest in first place doing file backup for data, and as much as possible off-load user data to other partitions thus reducing the size of c:. Doing system backups and the like of (C:+auxilliary) only for the purpose of backing up Windows and Programs (that cannot be secured with file backup), and doing it not daily.


    After the fact, as is the question of this thread, Users folder can be explored, and Desktop copied from there, using the Backupper 3.2 bootable media, which does not enforce protection.


    As a side note, on file backups, pay attention to some folders in Users\appdata, for example profiles
    that contain mail data, or move their location to a data partition. I move Windows Live Mail folder to the data partition, and do back up the Outlook folder hidden in Users\appdata, depending on what the system has.

  • edited May 2017

    Another option - most folders can be accessed as the system user.

    run an admin command prompt and execute psexec with the following parameters:
     PSEXEC -i -s -d CMD

    This makes another command prompt run as the SYSTEM user.


    Inside the system user prompt execute xcopy and copy all the files from the read only folder to another directory - make sure to use /C argument on xcopy e.g.:
    xcopy f:\Users\OldProfile c:\myolduser\ /E /C /H so it will continue on any errors.


    Useful links:

    MS blog running as SYSTEM

    PS Exec

    xcopy arguments


    I find it better to use psexec a well known app than other utilities that are unsigned or I've never heard of.


  • If you use Q-Dir remember to right click and run as admin

    If you are exploring image it is read only so you cant change permissions

    There is also a utility called Take Ownership,  you can find a download that will add the registry value to the registry that makes it available in the right click menu - it takes awhile on large folders - google it.   You  can view the contents of the .reg file to make sure you are comfortable running it


Sign In or Register to comment.