Home AOMEI Products Support

OneKey Recovery tool is not compatible with windows 10

edited June 2017 in AOMEI Products Support


I installed onekey recovery on windows 10 Home 64bit , build 1703.

I can't run the program because windows block it with error message: amwrtdrv.sys  driver is not digitally signed.

How can you say the app is working on win 10? did you test it in your laboratory?


  • This problem only occurs in Windows 10 1607 and later version, we have released a test version to fix the problem. Do you use the Standard version or Pro version?

  • Hi,

    I also have installed Onekey on my computer as I think it is a great compact tool for restoring the system. My system was running on Windows 10 Pro 1607 and Onkey worked seamlessly. When I upgraded to Windows 10 Pro 1703 it worked OK for some time. For some strange reason it is still working but differently since the last 3-4 days.

    Symptoms are:

    - Although "Enable the boot menu" was selected (I love this option, saves me time and effort from booting into USB EFI environment) F11 notification was not coming on boot-up. De-selecting the option, rebooting and re-selecting has fixed this problem. I now have F11.

    - Same problem happened with the Add the item "Enter into AOMEI Onekey Recovery" to Windows Boot Manager option. Tried the same trick as above but it didn't help. Previously when I unchecked this option computer was booting straight into Windows but since this option is not working anymore I cannot disable the Enter into AOMEI Onekey Recovery menu and computer shows the Windows Boot Manager everytime before booting into Windows. This is not a serious problem but seeing the Windows recovery environment everytime you boot windows becomes annoying.

    If I disable the boot menu I loose F11 which is critical to access AOMEI Onekey PE because if Windows is corrupt there is no way to recover the system. I could use AOMEI backupper USB to boot into PE environment but it is not as user friendly and fast as Onekey and I'm not so sure if I can recover my system with Backupper with a Backup created with Onekey. The reson is I tried to explore by Onekey backups with Backupper USB today and it showed AMSystem backups but could not open or explore them.

    -I do not get any amwrtdrv.sys errors as mentioned in the first post. Software works fine on my Lenovo Yoga 720 computer.

    Hope this information comes useful. May I ask where I can download the new test version or when can I download it as final?

    Many thanks.

  • @alien2000a You need to assign a drive letter to the AOMEI Recovery Partition so that AOMEI Backupper can access the backup image created by AOMEI OneKey(click Restore and choose the .adi file manually).

    You could contact [email protected] to get the test version(this version is not for the driver issue, please say it clearly in your email).

  • Dear admn,

    Thank you for the information. I have contacted support and received the test version. But the problem still remains. :(

  • Hi alien2000a, do you mean you can't uncheck the "Enter into AOMEI Onekey Recovery" option or when you uncheck the option, computer still shows the Windows Boot Manager before booting into Windows?

  • edited July 2017

    Yes dear admin. Unfortunately that is still the case. I uninstalled version 1.6. The installer asked me whether I'd like to delete the boot environment. I chose not to delete it. Then installed the test version 1.6.1 When I try to change the setting it won't even allow me to check the box and gives me this error. 

    I checked the bios and Secure boot option is disabled.image

  • @alien2000a Can you upload the log files?

  • edited July 2017

    Sure. Here they are. OKlog is from C drive root and log is from Program Files/OneKey folder.


    Also i'd like to pass on some information which may help troubleshoot the problem. For some strange reason i suspect that Windows is protecting partitions and is not allowing Onekey to write to that partition. I realised that when I tried to backup from Windows version using the Aomeitech Partition, backup to Aomeitech partition option was not working. I deleted the backup partition, re-created it when installed the 1.6.1 test version. Then the program was able to backup.

    One other hint was the program occasionally gives a "reboot failed" error when backing up from Windows environment. I have to manually reboot and go into Aomei recovery environment and again software fails to backup.

    Only if I boot into Aomei Recovery environment from F11 menu and take a backup everything works perfectly. (Apart from the screen resolution on 4K screen on my Lenovo Yoga 720. Screens look so small that you'd need a microscope to be able to read. Although 4K screens are not that common now they will be in the future so we could appreciate if these screens and messages could be optimized for 4K resolution on PE environment.

    Please let me know if I can provide any more help or do any test you'd like me to do at this end.

  • Our technicians will analyse the problem, thank you for the information.

  • I think I may be having a simular problem. I hope somebody can help me here because I have come to depend on this utility.

    My OS is Windows 10 on a Lenovo Laptop. I was using an earlier version of Onekey maybe 1.2 or before that and it ran perfectly. I realized that I had not updated in a while so I installed version 1.6. 

    I tried to do a backup and it said it would have to do a reboot to adjust the partition size. It looked like all was going well then I noticed it errored when creating the boot. It made my laptop unbootable and I had to recover using an external image file. 

    Something in this software is just not working. 

    Would it be possible to download a previous version of the software that used to work just fine on my Laptop?


  • @wayne92 Please contact [email protected] to get an earlier version.

Sign In or Register to comment.