The White Whale: I give up on Aomeitech Backupper

I wasted an entire day yesterday trying to upgrade my hard drive from an 500gb SSD to a 1TB SSD.  So I give up on this @#$@#$@ software.  I finally got the system working today by using linux and plain ole dd.  Before that I tried--really, really tried--hard to make this software work.

I'll detail what I did and why I tried it in case some other person can learn from this experience.  But the bottom line is (for at least version 2.1.0 purchased  about a 13 months ago) don't buy this software if you're trying to clone your system drive.  It isn't worth it.  It isn't reliable.

Okay here's my story:

I originally purchased AOMEI Backupper to switch a mail server data drive to a larger drive.  Here it worked just fine, and I was pleased with it.  But yesterday, I decided I needed to update my workstation hard drive.

I've updated hard drives before.  My usual approach is to boot up a Linux Live CD (I generally use Ubuntu),  hook up a dual bay USB drive, and just dd from one to another.  It works well.  But this time, I considered that it was a 500GB drive, that my USB docking bay is version 2.0 (48 MB/s one way, about 24 MB/s read->write) or about 6 hours to clone.  But I considered that my workstation has two SATA docking bays built into the case--and THAT should give me about 480 MB/s one way... about 30 minutes to clone.  Cool.  I put in my Linux Live USB thumb drive, booted it up and tried a dd.  Crap!   The motherboard was incompatible--after fiddling with it a bit, I managed to boot into text mode but a dd had a miseable throughput of 1.1 MB/s.  Searching for drivers in the hope that I'll hit on something that works did not appeal to me.  At that rate it would take about 4 days to clone the hard drive.  That was a non-starter.

Ah.  Then I remembered I had AOMEI Backupper.  Hey that ought to work!

And imagine how happy I was when it was indicated that it can actually clone the System hard drive while you're using it(!)

So I installed AOMEI and bada-bing.  It cloned the hard drive in 30 minutes.  I thought I had a winner.

Then I tried to boot the clone drive.  It didn't boot--complaining that a hardware change probably nixed the disk and that I should try to use my original installtion disk.   So I tried the Win 7 "Repair disk" utility as recommended, and afterward the system would boot to the "Starting Windows" then blue screen of death.

Maybe sector-by-sector?  Same thing.

Maybe "clone System"?  Same thing.

Maybe the problem was the source drive was live?   So I made an AOMEI usb boot disk, pulled the drive, put it in the SATA bays, booted AOMEI and cloned.   Same thing--clone won't boot.

(note: I checked obvious things like making sure that both drives were set for GPT, that the patitions looked identical in layout, etc.)

By then, more than 10 hours of fiddling have gone by.  But I'm gonna kill this white whale.

I installed Windows 7 from scratch.  Then tried to use System clone to clone just the system drive.  Same thing, drive wouldn't boot. 

I fiddled with it some more trying various types of cloning (clone drive, clone partition, clone system) all to no avail.

I need my computer on Monday.  So I gave up.  This morning, since I had opened the case anyway, I booted Linux live on my laptop, hooked up my dual bay USB drive, and DD'd the drive.  A rough calculation: 6 hours to dupe it.  So I wnet to Church... ate lunch, when I got home it was all done.

Booted up with no problems at all..

Verdict:  AOMEI sucks.  Don't buy it.  Linux is free.

Some caveats:

(1)  If it worked as intended, I think AOMEI would have been my go-to software.

(2)  I AM using a 13 month old license.  I could have bought an upgrade, but looking at the release notes, nothing seemed to indicate addressing this problem... and I wouldn't buy an upgrade if there were no guarantee it would work.


  • A further update:

    It turns out that I was incorrect.  The license I bought had perpetual updates, so upgrading to AOMEI Backupper Professional 3.2 did not cost me anything.  So I downloaded the newest version and replaced the one I had.

    In the interest of thoroughness, I tried to dupe the 1TB disk that I am now using onto a 1.5 TB hard drive that I had lying around.   I swapped the hard drive in (I hadn't buttoned up the computer yet, so this was a breeze), and tried to boot.

    Still the same problem.  So maybe AOMEI doesn't like Windows...

    So this afternoon, I decided to use AOMEI backupper to dupe my wife's Macbook 128GB SSD to the 500 GB SSD I pulled out of my computer yesterday. 

    To my surprise it didn't boot either!

    WTF?   Maybe I forgot to click sector-by-sector.  So I tried it again making sure I checked the sector-by-sector option.  And I noticed something strange.

    Even though I most definitely asked for a sector-by-sector clone, the messages in the progress dialog says things like "Copying volume 0" and "Copying volume 1"... in a sector-by-sector clone, there shouldn't be the concept of volumes, right?  It's supposed to be a sector-by-sector clone.

    The resulting dupe *did* boot, but the Bootcamp partition is not recognized at startup, so Windows won't boot.  OSX, Windows, and Linux can see the duped partition as an NTFS drive--so retrieving data (if that were my intent) would've worked. 

    So maybe that's the problem.  AOMEI Backupper can't really duplicate a hard drive sector-by-sector?  And it mucks with the Windows partitions regardless of the sector-by-sector option?

    At any rate, I used good ole Linux dd, and the system is up and running.

    This recapitulates my verdict: don't waste your money or time with AOMEI Backupper--unless all you want to do is back up data (not system) drives.

  • Sorry for all of that. We are also sorry for that our software cannot support LINUX system and MAC OS. We will improve our product in the future.

  • edited January 2017

    I've cloned over 25 systems in different scenarios. Most of them HDD to SSD. Size wise mostly 512GB to 256 or 512GB. (price matters). All sucessfull.
    I've had some issues with older drives which had bad sectors and while donsizing the clone, but over all everything worked. Everything got cloned properly, what had some issues was the boot loader which needed a fix sometimes. It was necessary to set the partition as active and repair the boot record.

    boot a CD/USB in recovery mode, execute diskpart in command line.
    Enter these commands:

        list disk
        select disk 0 (be carefull shich disk you select in case of multiple disks)
        list part
        select part 1

    exit diskpart and execute the following commands:

    BootRec /FixBoot
    BootRec /FixMbr
    BootRec /ScanOS
    BootRec /RebuildBcd

    These steps worked for me 99% of the time...
    The rest was just plain hardware failure of the source drive.

  • Normally, when there is a few bad sectors in the disk, you can do the disk clone sucessfully. The software just skips the bad sector and do not clone it.You said that you need to set the partition as active, maybe the software fails to set it as the active when you do the clone.But it is not about the bad sector. We will try to find the problem and solve it.

  • Nope, in the few cases where there were bad blocks, the backupper did not skip the bad places but reported an read error or just did not clone the drive at all. But as I said, its not a Backupper problem if the drive is failing.    

  • You are right, sometimes it is sucessful sometime it is not.

Sign In or Register to comment.