Home AOMEI Products Support

SMTP Email Notification not working in AB 3.5 Pro

After upgrading to AB 3.5 Pro  I noticed the SMTP Email notification stopped working on a task I have been running for a year. I created a new task requesting the email notification. I verified and enabled the SMTP info on the Menu/Settings/Notification area and successfully sent a test email message. When the scheduled backup run there was no email notification sent. The log file indicates everything ran to completion.

I never had a problem with AB 3.2.



  • You are not alone with this issue. On all my servers/computers the test mail ist sent properly but the job notification isnt. To get temporarily around, use AOMEI's server. That oneis working. (dont ask me why). I had this notification issue since upgrade to the 3.2 version. I am on the email with Megan, but till now without success.

    I've got a tip to delete the C:\ProgramData\AomeiBR\MailConfig.xml and configure the notification server again, but it did not help.

    There is also an upgrade bug, where the notification configuration is not preserved after upgrade and the GMail server option is set as default. So allways check the configuration after upgrade.

    I have the 3.5 Technician Plus license

  • The AB upgrade to 3.5 also reconfigured the notivication configuration for GMail and destroyed my original settings. Is AB 3.2 still available for download?

  • Sorry Selfman. @charlie, what is the SMTP you use in 3.5 version gmial? Hope you can send us the screenshot of the email notification setting to us. And also you can get the 3.2 version from this link:   http://www.backup-utility.com/changelog.html 

  • Time Warner (Roadrunner) is my ISP provider. I use their email servers (SMPT) for email notifications. Worked great under AB 3.2 but not in AB 3.5. Test notification works but no notification sent upon completion of scheduled backup.

    Also, the link you provided for downloading AB 3.2 is invalid - error code 404 - Page not found.

  • @admin I already set up an account for your developers and sent it to Megan.

    @Charlie - Here you go http://www.aomeisoftware.com/download/adb/3.2/ABPro.exe

  • Thanks selfman,  @Charlie, did you download the 3.2 version?

  • Yes, I downloaded 3.2 and reinstalled. Now my notifications are working and my machine goes into sleep mode after running the scheduled backup. I will wait for 3.5 to be fixed before reinstalling 3.5.

  • edited August 2016

    Sorry for that the 3.5 version has this small problem. When it runs the backup, the computer cannot goes into the sleep mode.We will solve it ASAP.

  • I'm glad that I read this because I just enabled the email option and the test email was successful. I'd be chasing my tail tomorrow if I didn't receive an email at the end of the nightly job.

  • edited August 2016

    So in my case, the SMTP email using my smtp server is working. However, I indicated to use HTML email and while I do receive the email and it sort of has HTML code, it's not formated correctly and is plain text with some malformed breaks.  Below is what I received each night now. I've edited computer name.  But it's not in html format. The image is from Outlook 2016, which is set to default to html email.(I don't know why the uploaded image is of such poor wuality because the original is perfectly clear).image

    Hello, <br/><br/>Report of the backup/sync isas follows:<br/>                  ComputerName:HOSTNAME<br/>                               PlanName:System Backup After Win10<br/>                      Task Type:IncrementalBackup<br/>                        DestinationPath:I:\AOMEI Backupper\System Backup After Win10\System Backup After Win10\<br/>                           ExecutionResult:Success<br/>                   StartingTime:Tue Aug 09 03:00:20 2016<br/>                              FinishTime:Tue Aug 09 03:27:50 2016<br/>                        Description:Theoperation has been completed successfully.<br/><br/>If you have anyquestion, you can copy the above information and contact us by: [email protected]<br/><br/>Thankyou,<br/>Best Regards,<br/>AOMEI Tech<br/>http://www.backup-utility.com<br/>

  • There are two format you can choose to set it. Run AOMEI Backupper---menu---setting---email notification---notification setting---send email with txt. Hope it is useful for you.

  • Yes, I understand about the two options. I was pointing out that 1) the smtp email is working for me and 2) the htmp option isn't working.

  • edited August 2016

    The HTML mail didnt work before. it does not have the approprate encoding and thus not working. I sugget you stick wit the TXT version and modify the C:\Program Files\AOMEI Backupper\lang\en.txt or C:\Program Files (x86)\AOMEI Backupper\lang\en.txt according your needs. Like I did.

    You can try my en.txt file though its build on the tecnician plus edition and I am not sure if they are identical. (allways backup first)


    I did a lot of cleaning. (still might have missed some spelling and formatting errors)

    You can load both files in to WinMerge and compare the differences.

  • I upgraded some systems to 4.02 and guys, I am not happy with the result. The custom SMTP mailserver is still NOT WORKING. The AOMEI server option is. So it begs the question - are you colecting and analyzing the log files or WTH is going on???

  • Yes, we do some improve with the SMTP. Please try to send us the screenshot of the SMTP setting and LOG folder to us again. We will analyze it again. Sorry for the inconvenience.

  • @Thiersee "Only the coding is not." What can we do for you? Sorry we do not get you very clearly,please give us more details of this problem.

  • Thanks, we got it. We will try to solve it ASAP.

  • It looks like two separate issues being discussed in this thread.  My issue is with the original one as described by Charlie (first post) and brought up again by Selfman.  We have the Technician Plus license and I have a number of computers set up with Backupper 3.2 which can send email messages when their backups are completed.  This is done using our Internet provider's mail server (custom SMTP).  I upgraded one computer last summer to version 3.5 and this reporting stopped.  I could send the test mail but the automatic reporting on the nightly backup no longer worked.  I saw the original message so assumed you were working on it and did not bother to upgrade the rest of the computers as the backups were working.

    I've now upgraded the computer running 3.5 to the current version 4.0.2 and the email notifications are still not working using custom SMTP.  For all versions the basic settings are Port 587, Encryption is either "Plain text" or "TLS", and the email form is TXT.  In the "Send email notification to me" area all three options are enabled (checked).  The "Send for test" does work.  In the Schedule Settings area it is set for "Incremental Backup" and "Don't install the service..." so I can use the Windows Task Scheduler to run the backups even if the computer is not logged it (it usually is left logged in).

    So for some reason your Notifications using custom SMTP broke in version 3.5 and is still broken in 4.0.2.  I haven't tried any of the other servers but believe the Custom SMTP should work.  It is an inconvenience at the moment but this is something you should fix as I'm not the only one that experiences this problem.

    One other note - I've tried another ISP email server (similar settings) and the problem persists so it is not just my ISP's email server.

  • I forgot to mention that Backupper is installed on Windows 7 64 bit computers with all updates.  Backups go to an external NAS.  Also there are two log files - ABCore#.txt and Backupper#.txt.  The first line in both files say "AOMEI Backupper 3.5.0 log is as follows:" even though the program reports being version 4.0.2 (in About).  I could not see any lines referring to email notifications.

  • Another update.  I just checked the SPAM folder at our ISP and found the previous day's notification from the computer with Version 4.0.2 (after I changed Encryption from TLS to Plain text).  This leads me to suspect a problem with your TLS setting as it does work in my Microsoft Outlook.  I believe the reason it was in the SPAM folder was that the From was from myself (my SMTP authentication address) and the Subject field was blank.

    The emails from Version 3.2 shows the From field as "AOMEI Notification" and the Subject field is "AOMEI BACKUPPER notification ComputerName(Success)1/05/17 11:30:04 PM" which I prefer and find easy to check.  So somehow the Subject field in your message is getting corrupted and not interpreted properly by the mail server.  I seem to remember that I had to modify the en.txt file in Version 3.2 to have the email display properly (text mode).  Hopefully these are some clues as to the email notification issues.

  • edited January 2017

    When the mail gets in to the spam folder, it already passed the SMTP communication. Thats just a content filtering issue on your mailserver. My problem is that it simply isnt delivered at all BUT the test message is. I did several test and I can repeat it over and over.
    Admin: I've already sent you (AOMEI) a test account information on the server I am using. You can test it directly on your systems.

    The question is: IF a test mail is successfull, WHY is a normal report not sent?

    There is only one mail related entry within the log file:
    [0       ]SendMailByConfig(pMail) return code: 0x00000000, helper.cpp(1250).

  • I have not tested a different SMTP server and gues what, this time the mail was sent!
    I still cant get my head around the fact, that the test message is successfull but the report is not. WHERE is the difference here when sending the mail.

  • @lcooper sorry for the inconvenience. Please resend the screenshot of the SMTP setting to us. And also hope you can send us the log folder to us again. We will reanalyse it. For now, please use the AOMEI SERVER. Sorry.

  • Oh I wrote "I have not" but wanted to write "I have now" (sorry for the confusion...

  • Here's something interesting from my log file in ABCore6.txt:

    AOMEI Backupper 3.5.0 log is as follows:

    ====================== System Information ======================
    Module Path: C:\Program Files (x86)\AOMEI Backupper\ABCore.exe
    Product Name: Windows 7 Professional (6.1.7601.2)
    Service Package: Service Pack 1
    OS Version: 6.1
    Total Memory: 8151 MB
    Available Memory: 5562 MB
    System Root: C:\Windows
    Processor Architecture: AMD64
    Processor Number: 4
    Current Time: 2017-1-11 5:0:2

    (more stuff)...

    Dump Slice:
    ID ParentID SequenceID Offset Sector  Start Sector  Slice Size  Unallocated
    -- -------- ---------- -------------  ------------  ----------  -----------

    AsyncDeque.h(206): OpenThreadToken failed, errcode: 1008
    AsyncDeque.h(54): OpenThreadToken failed, errcode: 1008
    [1008    ]BrVol.cpp(682): Total Sectors:341458352
    [122     ]EnumRemoteFolder.cpp(494): 0 = InitNetWorkPath(\\\ABkups, aomei ...)
    [0       ]i<m_vtrInfoList.size() return code: 0x00491002, ImageReader.cpp(73).
    [0       ]uLen != 0 return code: 0x00000000, DsImgTask.cpp(524).
    [0       ]DsImgTask.cpp(327): Not find hardware info.
    [0       ]m_vHardwareInfo.size()!=0 return code: 0x0222100C, DsImgTask.cpp(546).
    [0       ]m_pTaskRecords->IsPolicy(iIndex) return code: 0x00000000, UiTaskMgr.cpp(2055).
    [0       ]UiTaskMgr.cpp(763): PolicyManager error.
    [87      ]pNode!=NULL return code: 0x00000000, UiRecord.cpp(7066).
    [87      ]pNode!=NULL return code: 0x00000000, UiRecord.cpp(7066).
    [87      ]pNode!=NULL return code: 0x00000000, UiRecord.cpp(7066).
    [1200    ]dwErrCode==NO_ERROR return code: 0x00000000, helper.cpp(227).
    [1200    ]helper.cpp(236): dwErrCode: 1200
    [0       ]SmtpSendEmail.cpp(363): CheckResponse 250 failed.
    [0       ]SmtpSendEmail.cpp(364): recv: 451 See http://pobox.com/~djb/docs/smtplf.html.

    [0       ]SmtpSendEmail.cpp(284): SendData Failed.
    [0       ]SendMailByConfig(pMail) return code: 0x00000000, helper.cpp(1250).
    [2250    ]m_hMonitor!=INVALID_HANDLE_VALUE return code: 0x00000000, BackupLogic.cpp(878).
    [2       ]GetFileAttributesA(szDir)!=INVALID_FILE_ATTRIBUTES return code: 0x00000000, helper.cpp(659).
    [2       ]ReadFromeSchedFile(szwParam, 1024*sizeof(WCHAR)) return code: 0x00000000, helper.cpp(699).

    Note the bold items.  Even though I've upgraded to 4.0.2 the log still says 3.5.0.  But the key item is "see http://pobox.com/~djb/docs/smtplf.html".  This site describes the error as due to a LineFeed (LF) without a preceeding Carriage Return (CR).  It seems to affect "qmail" systems which I'm pretty sure our ISP is using.  The site goes into detail about the error.  As Backupper is set for a text message I'm guessing this is the problem.  Hope it helps.

  • edited January 2017


    I've made a test, where I changed the line from the test message:

    11076=Welcome to use AOMEI Backupper Email Notification. Thank you.

    11076=Welcome to use AOMEI Backupper Email Notification.\nThank you.


    then I've changed it to:

    11076=Welcome to use AOMEI Backupper Email Notification.\r\nThank you.


    Sorry for all the CAPS but I am so excited that this annoying 1 year long bug had such a simple solution.
    FYI I did replace all the \n occurences with the propper \r\n

  • Thanks for all your guys. Love you. We will send this feedback to our technicians, they will try to test it and find more information.

  • edited January 2017

    Here is my english language file which I have tidied a bit up.


    The HTML mail still contains the html tags as its not a problem of the translation file, rather of the handling code. (its still a plaintext mail.)


    MIME-Version: 1.0
    Content-type: text/plain; charset="US-ASCII"
    Content-Transfer-Encoding: 7bit

    Welcome to use AOMEI Backupper Email Notification.
    <br/>Thank you.

    in a standard HTML mail you get:

    Content-Type: text/html; charset = "UTF-8"
    Content-Transfer-Encoding: 8bit

  • edited January 2017

    I've analyzed both emails and the only difference between them is that the "HTML" mail has a <br/> tag instead of a \r\n (new line)

  • @lcooper and @SelfMan   Thanks for all your guys. The solution is useful for most of the users, we will solve it in the next new version. Love you.

Sign In or Register to comment.