Home AOMEI Products Support

AOMEI PE Boots, then BSOD's



  • edited September 2015

    I have installed ‘AOMEI PE Builder’ v1.5 at my desktop with Asus ASUS P8H77-V motherboard and with Win7 Pro x64. Installing was easy and making a (non-customized) bootable USB too. But booting goes wrong after “loading files” when Windows is starting. It’s very disappointing that with v1.5 still there is that BS with “STOP:c0000145 {Application Error]” as reported in this topic already 5 month ago.

  • VERY disappointing... and what I needed to see to know to not bother spending money here. Too bad... the products themselves seem pretty decent.

  • I actually went back to compare the last "working" WIM image that I built with PEBuilder 1.4 to the latest non-working WIM image I just built with PEBuilder 1.5...

    I have to say - I just don't understand what the point of releasing 1.5 was. The hotfix compatability problem I reported here that causes the BSOD doesn't appear to be an issue that is specific to hardware. In other words, it seems as though the problem should happen to ANY and EVERY person with a fully patched Win7 x64 system. Does this mean that AOEMI didn't do ANY QA testing on PEBuilder 1.5 at all? Or does it mean that they are inexplicably testing their new software releases only on OLD versions of Windows?

    Beyond that - it ALSO looks like PEB 1.5 includes OLDER versions of BOTH backupper and partition assistant than the versions that came bundled in PEB 1.4??? Whaaaaaat?

    I think I'm ready to give up on a PE environment based approach alltogether, and instead try working in a Win10 Windows 2 Go environment... it's a portable but FULL running version of Windows (not a PE), so any tools any of us might have wanted to add to the PE image but couldn't get to work because of missing system dependencies won't have that problem under Win2Go.

    But seeing almost half a year go by without a SINGLE comment from AOMEI about this show-stopping bug that I troubleshot for them has convinced me this is not a company to spend money with. Maybe Macrium...

  • edited September 2015

    To be fair, since the PE created on currently patched (post 2014-12) WinOS fails to boot, it hadn't occurred to me that if the newer versions of Backupper and PA are installed before creating the PE, then those updated versions get copied into the PE.

    So that's good... and makes whatever (older) versions that come pre-bundled with PEBuilder a little irrelevant. So my bad there...

    Trailing off, I tried to do a bit of public service to see if I could narrow down exactly which fix (or fixes) specifically seem to break PEBuilder. Unfortunately, by the time I tried uninstalling the 20th or so fix from my list of ~30 something hotfixes, it resulted in a really unstable system and I still hadn't gotten a working PE out of it. This means I uninstalled ONE fix at a time, and created brand new PE USB keys in between each uninstallation of a hotfix. That was almost 20 boot images and took quite some time. Only to fail due to instability...

    I was able to find a VERY old ghost image that I restored to the laptop after that, from 2013-12. I kept it offline to leave it at that old patch level and reinstalled all the current AOMEI stuff and once again was able to generate a properly working PE image.

    So for anyone who has the option of rolling back to an older desktop image (pre 2014-12 would be a good bet), at least you still have that as a possibility in order to create a working PE image.

    Good luck all! I'll go ahead and write up a small tutorial on how you can edit the PE image AFTER the fact so that you can update it with new tools without breaking it once you've got it working.

  • With GImageX is this possible?

    Mount image with GImageX and drag the program's installation folder to the folder mounted on GImageX will work?

  • Steje,

    Thanks for all your efforts and posting the information, very helpful, I to am a tech by profession and appreciate the time/effort it takes.

    I have Win7 Pro 64 bit and encountered the same errors, I guess I'm glad everyone else is to or it would be much harder to resolve.  As a work around I plan to try removing the patches you listed and create the PEboot disc, if successful I'm going to create a system restore point before reinstalling the patches.  Although restore points have a limited life, you can regulate the process by monitoring your disc space assignment against the number of restore points held before being overwritten then monitor them and before the one without the patches is overwritten, restore it, create another restore point then restore back to current state, not pretty but would save time if it works.  That way you could always update your PE Environment using AOMEI PE builder fairly easily.

    I'll let you know how it goes......  Thanks again for your effort

  • As a followup for everyone else interested, during the process of isolating the hot fixes listed in this thread, I found I did not have the following hot fixes on my machine but still get the BSOD booting to the PE Disc so these hot fixes are definitely not the issue:





  • Another followup for anyone else following this thread.  I started uninstalling the remaining listed updates, found the following and uninstalled them:













    rebooted and created a PE Boot Disc which failed with the same error so we can rule out the above updates as being the cause.

    The remaining updates had files present on my system (Hard Disk Database) found the .cab etc. files but they were not present in the uninstall section






    This would indicate that a subsequent update replaced them and left these files as roll back support so I need to track down the subsequent update and uninstall it.  This will take some time so I'll post an update when I have one.  If in deed it is one of the listed updates in this thread that is causing the issue then we have it narrowed down to the five above in one form or another.

  • Well done and good luck Mrwizard, it's what I had tried to do but gave up on after uninstalling many of those same patches put my system into an unstable state...

    FWIW: rolling back to an 'old' OS patch level just to make a new PEBuilder image often is just impractical in my opinion, but really only needs to be done at all in order to capture the latest versions of the actual AOMEI tools in the image (depending on the differences between major versions, just dropping newer versions of backupper or partassist binaries into the image in the manner I'm about to describe will result in program errors)...

    If you're like me, and desire to use the WinPE environment provided by AOMEI PEBuilder to run 'other' tools than just the AOMEI Backupper and Partition Assistant tools (like how they themselves provide additional File, Network and System tools), then once you've created a 'working' WinPE, you can update files inside the resulting image using the following process:

    First, a few bits of information required to make sense of this guide:

    1. Generating a working WinPE first is necessary... which based on the info in this thread is not possible at the Microsoft patch levels current at the time of the release of PEBiulder 1.5. I leave it to future updates to this thread from ppl like Mrwizard to be more prescriptive than the list of patches and 2014/12 time frame I provided earlier in this thread. You will hopefully end up being able to get away with uninstalling a small subset of patches in order to create a working PE - OR - AOMEI will step up and fix their tool someday.

    2. The steps require the installation of the Windows AIK/ADK appropriate for your platform - EVEN IF you are otherwise already able to create a PE from your system withOUT having to install it... it's needed here to provide the imagex tool needed to properly update the WinPE (boot.wim) file. DISCLAIMER: the steps might be slightly or even massively different with different versions of the AIK/ADK. My steps are based on doing everything from a 64-bit Windows 7 installation with the 3.0 WAIK (WinPE 3.0) package linked to from the AOMEI website, and using it to create a USB Boot Device.

    3.  I manage all of this through what I believe to be the worlds BEST File Manager for WIndows - Directory Opus by GPSoftware. Apologies if I miss a manual step as doing it through Opus makes it all super easy... and I'm happy to share my context menu and toolbar customizations to manage this with any other would-be Opus users.

    4. Some basics, though I expect anyone interested in following these steps to be familiar with basic and mudane things like editing paths to wherever you like to stage things that might be different than my examples:

    a. On my Win7x64 system, the 3.0 WAIK installs the required tools to the C:\Program Files\Windows AIK\Tools\amd64 folder. Specifically, imagex.exe.

    b. Once you've created a working WinPE, you'll want to copy the WinPE image file from the USB device (for example: U:\sources\boot.wim) to someplace on your hard drive. In my example it is in D:\wimages. I'd also recommend keeping a copy someplace safe that you don't ever modify, since recreating a new one with PEBuilder is such a pain in the ass

    c. The imagex tool needs to mount the boot.wim file to an empty folder on your hard drive. In my example, I'm using D:\wimages\mount.

    d: Updating the boot.wim image involves 'mounting' the image to a folder like mentioned above, copying your updated files into the mount folder, then 'unmounting' the image with the /commit option of the imagex tool. This 'commit' saves the changes you made to the mount folder back to the boot.wim file.

    Assuming you work out how my examples relate to however you'll setup your working scenario, here are the procedures you need to know:

    1. Example command to MOUNT the boot.wim file:

        imagex.exe /mountrw "D:\wimages\boot.wim" 1 "D:\wimages\mount" /LOGFILE "D:\wimages\mount.log"

    2. Example command to UNMOUNT the boot.wim, saving any changes you made by copying/deleting/moving files in the "D:\wimages\mount" folder:

        imagex.exe /unmount /commit "D:\wimages\mount" /LOGFILE "D:\wimages\unmount.log"

    3. Example command to UNMOUNT the boot.wim but DISCARD any changes you made, in case you did something by mistake that you can't easily reverse:

        imagex.exe /unmount "D:\wimages\mount" /LOGFILE "D:\wimages\unmount.log"

    4. Example command to EXPORT the boot.wim to a new file name... don't know that this is strictly necessary, but doing the export does some kind of optimization of the packing of the WIM file that simply committing changes to it doesn't perform. It may shrink the file down a few to several dozen MB's depending on your changes.

        imagex.exe /export "D:\wimages\boot.wim" 1 "D:\wimages\boot_new.wim"

    There are other commands to do other things as well, like display info about the WIM file, mount it in Read-only mode, etc... check out the options by running imagex.exe /?

    As mentioned, the process may be a bit different when run under Windows 8 or 10 with the appropriate ADK versions. The tool and it's options might be different, and this isn't the only way. For instance, vagn_32 asked about GImageX - which is a GUI wrapper written to give you an easy graphical way of interacting with the WIM files.

    Enjoy... and good luck!

  • Thanks Steje,

    Good Info, I'm sure many will benefit.  As it turns out, I used a 3rd party uninstaller to unintsall the kb updates listed above which, apparently, must not have done the job well enough so I repeated the uninstall process on all listed KB's using the windows uninstaller command line utility

    wusa /uninstall /kb:??????

    This did the trick and I was able to create a working boot image, it also changed the list of KB offenders to the following possible KB's:












    So, I ran the command line uninstaller against all previously listed KB's and any not listed above were identified as not being installed on my machine, which was at a point where I could not create a good boot image, after uninstalling the above listed KB's I successfully created a boot image that worked perfectly.

    I plan to re-install each listed KB above one at a time until I get into failure mode again, perhaps we can narrow it down to one which would be sweet.  I'll post the results when finished

  • I tryed also but receive a BSOD c0000145 error.

  • Of course you did... it's broken until AOMEI fixes it ;-).

  • Hi guys,

    Sincerely apologize for the problems has caused you. We didn't address this issue because we are short of hands previously. Sorry for that.

    Currently we are starting to resovle this problem. After fixing it, we would appreciate very much if you guys can help to test it.

    Sorry again for the late and the inconvenience has caused you. 

  • I have been particularly critical of you guys for this topic... so I will say this:

    Even though I'm not a paying customer, I'm sure you have other paying customers that would like to be able to properly use this tool - even though the tool itself is free. But as a public forum, what happens here is visible to both paying and evaluating users, so it is really dissappointing that nobody from your company even bothered to make a public post to acknowledge that you've even read the thread - especially after myself and others spent time and effort to try and help narrow down the cause of the problem.

    All we had was a claim from another (presumably paying customer) that he had sent you a support email that you responded to - and that it would be fixed soon. That was over 5 months ago... long after which - you even released a new version of the tool, with no fix for the problem. So you basically released an update that nobody can use. If you're short of staff - I suggest it's probably not a good use of limited resources to release things that just simply won't work (at least for up to date Win7 x64 users).

    From a company who offers free tools in the hope people will like them enough to spend money with you - I'd have expected at least a forum post from someone at AOMEI between then and now, simply to acknowledge that you were aware of what we had reported and that you'd look into it when you could. And that just for your own best self interests, never mind as a simple courtesy to potential customers who had tried to help you discover the cause of the problem. It's a shame that you have been so short of staff that nobody could take just a few minutes to respond long before now... because it has definitely cost you customers that might otherwise have spent money with you. Even more of a shame that it costs you users that are willing to not just complain at you - but to actually spend their own time trying to help you make things better.

    Best of luck.

  • Well said.

  • 3 more months passed - no new version, still the same old problem. Just installed the 1.5 on current W7 x64, built a PE, booted from ISO into virtual machine => BSOD! Then googled this thread...

    Please, AOMEI, do something or make a note for the downloaders - you are WASTING OUR TIME! That's the worst about it :-((

  • @johnbot. How about the linux version of the bootCD? Or a WinPE made on an other machine.

  • edited February 2016

    When you created the bootable media on a real W7 x64 computer, and then booted on a (untold by firmware and by bit depth and by vm brand architecture) virtual machine, it is no surprise. BiOS/EFI architecture and 32/64bit makes a difference. Please tell your parameters.

    I know that the Backupper bootable media is a bit more portable across architectures than the PEBuilder bootable media.

    To compare what I did, and maybe helps you out: I created several Windows 8 US-en virtual machines, installed latest Backupper and latest Partition Assistant, and then let PEBuilder1.5 do it. The successful virtual machine was either EFI 64bit, or BIOS 32bit, and Windows was the corresponding 64bit or 32bit version, and the bootable media booted only on the own VM and on other EFI 64 bit, or BIOS 32bit machines that had the same architecture. They can not be crossed at will. My real hardware was more tolerant than the VMs were.

    +To add more: I created a PEBuilder1.5 bootable media on 32bit EFI and it boots neither on its own, neither on any other VM, however it booted on a real 64bit EFI. In the end I kept the 64bit EFI and the 32bit MBR media that were created on corresponding VM.

  • Same problems BSOD c0000145 after boot from image.

  • edited April 2016

    this might be the answer.. especially the Pending INstall package section.. i've used DISM GUI to test it.. results soon


  • edited April 2016

    in Windows PE there should not be pending installs! (this relates to #50)

    @nagual it is known that PE Builder does not boot on a foreign system (different bit level, different firmware BIOS/UEFI). UEFI 32bit does not boot, this is also known. Please give the parameters. In addition the Backupper PE is more robust, and worth a try, but architecture (where created) has to be the one of the target computer.

    @Jonbot you created on Win7 x64, but then tried on a VM with unknown bit level, and firmwares BIOS/UEFI are unknown. In addition the Backupper PE is more robust, and worth a try, but architecture (where created) has to be the one of the target computer.

    There are certainly reasons to complain, but without specifics the reasons cannot be assigned. - Microsoft Windows PE is not "create anywhere, run anywhere". The bit depth has to match. In addition, by errors, it does not always boot by firmware architecture (theoretically, WinPE of the selected bit level includes both BIOS and UEFI). And PE Builder includes the Explorer GUI, which is copied from the current system, this is a nontrivial, not official addition to Windows PE. Rarely seen and understandably, deplorably not robust. Official GUI would be cmd.exe.

  • sorry to say but my test didn't revleal any successfull results.

  • Has there been anything further on this?  If not, what would help is for the web page that promotes the PE Builder to explain clearly when this will work and when it will not work.  x64 vs x32? Version of Windows?  Vista, 7, 8,10??  If made on one platform, which others will it work for?  What will or won't work to create USB flash drive? Does it work only on the computer it was made on?  (But not always??)  Otherwise, people get mad wasting their time downloading and trying to install and use, when what they thought should work was already destined to fail.

    At one point you were working on a Win 7 only version.  Did that fail in the end, or is there a version that works on Win 7 x64?

    Also, did I misread that the latest version is supposed to build the PE with Backupper and Partition Assistant as part of it--and it does not matter whether you have these installed already on the computer?



  • Thanks, I will try it and let you know.  A little confusing--both files you say will produce a PE Builder on Win7.  However, the one that says it is specifically for Win7 is a much bigger file.  So perhaps that is because this one already INCLUDES Backupper and Partition Assistant, even if these are not already installed on the computer?

    I will try to make an ISO for USB stick.


  • edited July 2016

    PE Builder works up to Windows 8 in all languages, presumably. On Windows 8.1 it is supposed to work on an US-english system only. PE Builder draws Explorer from the running system. I for myself, when trying, created it on a Windows 8 en-US for this reason, and did it for 32bit and 64bit separately. The problem behind PE Builder is this: extracting explorer from the running system is a non-trivial tricky task, you might google for instructions if you want to know in depth.

    To answer the other question: PE Builder includes an outdated version of Backupper and Partition Assistant. It will however take the current versions if and after you install them yourself.

    bottom line: I consider the bootable media from Backupper far more stable. It does not have Explorer, but it does have Windows command shell.

    And consider, any bootable media must be created separately for 32bit and 64bit, because underlying Microsoft Windows PE is separate by architecture. One must create the bootable media on the corresponding Windows to be on the safe side. There is Microsoft documentation about this, current rules are: any xx.bit created Windows PE will boot UEFI and MBR computers of the same xx-bit architecture. In addition any 32bit Windows PE will boot on 64bit MBR computers, but not 64bit UEFI computers. It is also not safe to assume that a bootable media generated on Windows 7 does work on Windows 8 in all situations, however Windows 8 8.1 10 are the same.

    Bootable media, as discussed here, draw the keyboard layout from the generating Windows.

  • SIW2, Is that all ok now?Can you create it with PE builder?

  • Sorry for being so slow to be able to test my installation.  @Peter13feb, thanks for your comments.  AOMEI should have some of this on the promo & download page for PE Builder--so people will know what they are getting into (an incomplete and not yet fully functional program in every situation.)

    I am not sure if what I downloaded is the July 9 version--I went to find what SIW2 mentioned on July 8.  Was there on update the next day? 

    First, there is a big improvement, because this time the package at least installed, without BSOD.  The first time I made a CD of this (Win7 version), I did it on a computer without Backupper nor Partition Assistant installed, to see if the package came with these, but I found NO BU or PA when I started the CD.  So, if these were there even as earlier versions, as you say, I did not see them.  I then installed current versions of BU and PA in Win7, and re-made the CD.  Now I did find these programs when I started the CD.  However, only Backupper was found on the Program Menu; whereas I thought Partition Assistant was not there, but then I realized there was an icon on the Taskbar for PA.  BUT STILL--not the other way around.  These should both be on the Program Menu and probably the Taskbar too.  Nice having the other small programs, but would be nice if you included short Help files how to use them, and what they are even for.

    Biggest problem I found with this version:  When I did the first install, I saw no network was available.  Looks like I could work only on this computer, but it would be nice to be able to use the network, save backups to a network folder, etc.  Since it's a laptop, I usually use wireless, so the 2nd time I installed, I tried adding the WiFi driver file folder for the wireless.  I then also tried to add the driver for the ethernet (though I would think you might make ethernet work with generic drivers--but I did not test for ethernet the first install.)  The 2nd install let me add the wireless driver, but when I asked to install a 2nd driver, for my ethernet, it failed and jumped ahead.  Once starting the CD, I could not get either wireless or ethernet to work.  WinPE could not see my ethernet as a valid device.  It saw the wireless, sort of, but did not see it as workable.  When I was able to find the device in the little added networking program, I saw a message, "This is not a WiFi Device, or WiFi functionality is disabled for this device."  In Windows, I found the adapter showed as a device, but it said it "could not start because another instance of the device is running."  I could not disable the device and restart it--WinPE wants to restart the computer, which of course will not load the change.

    So, I will have to work on this to see if I can get the ethernet or wireless to work--but I don't know how since the latest driver did not work for wireless.  Is there a new version I should download, posted after the one stated by SIW2 on July 8, 2016?



  • @Peter13feb, thanks for the note about not being able to boot 32 bitWinPE on 64bit UEFI computer.  I don't have experience with UEFI.  However, other than that, would it matter at all to boot either 32 or 64bit version from a WinPE disk to use Partition Assistant or even Backupper, no matter the Windows version of the target computer?  Don't the partitioning and backup operations proceed outside of whether the content of the disk is a 32 or 64bit system?  Except for the one thing--I can see that if I made a backup with a 32bit WinPE disk, and saved it, that I might not be able to use and restore that backup from inside my 64bit Windows system--I'm not sure if this backup file would be readable on the 64bit system?



Sign In or Register to comment.