OneKey Recovery (fails on Windows 10 x64 Pro English, Fresh Install)


i wanted to install the OKR 1.2 on 4 Thinkpad T420 Notebooks with a intel 160GB SSD.

The machine has Windows 10 x64 v1511 Pro installed, english language.

I installed Office 2016 and OKR 1.2

I started the software, selecet the recovery partition on drive C: (120GB free).

OKR 1.2 start´s working and reboot the machine, started to create the partition and backup.

But it says : Failed ...

I tried this 3 times, one was working with a backup.

But most of the times, there was no partition created.

I found some log files on C:\SomeFolderName\....log

Within in these logs i could read some information about WIN PE 8.1 Version and 32 Bit OS ...

Is there a working build for Windows 10 x64 Pro v1511 ...

Maybe some has more information for usage with Windows 10 x64 v1511.



  • Sorry for that. You said that it failed. What the error message you get?

    Waiting for your reply.

  • Hi,

    this is the message after rebooting the T420 ..

    Adjusting partition layout to save backup image

    Creating recovery environment...

    Backing up Failed

    I can press finish.

    Next i could press "OneKey System Backup", select Backup .. to recovery ...

    and i see the new partition layout.

    500MB | 136GB NTFS (C:\) | *: 11.55GB

    Start Backup button is greyed out.

    I can only exit the WinPE Environment, reboot and nex i see a blue windows.

    Chose an OS (WIndows 10 or Enter into AMOMEI OKR ..)

    Where can i send the oklog files ?

  • Why do the log files show

    OneKey Recovery 1.0 log is as follows ...

    Produkt Name: Win PE 8 (6.2.9200.2) ...

    Seems that OKR is not v1.2

  • Please check if the recovery partition is created. You said the button is grey out. Would you give us the screeshot?

  • image

    The recovery has been created, but can´t be used for a backup ...

  • You have two problem, right? We are wondering that you run the ONEKEY in two computer.

  • edited January 2016

    I tried OneKey Recovery 1.2 on a virtual test system (VMware), BIOS and MBR styles, Win10-1511. The disk was virtual 40GB, which contains the system partition (500MB), and C: (about 40GB).

    1) OKR System Backup fails, and leaves empty space about 7GB, and C: is 33GB.

    2) OKR System Backup fails, and disk is not changed.

    3) I make room using AOMEI PA, creating empty space of 12GB, C: is 28GB.

    AND I copy C: into those 12GB using AOMEI PA, labelled Copy of C .

    Copying was to provision the virtual disk, at least partially, in case provisioning matters.

    The partition of 12 GB is then deleted, creating empty space of 12GB.

    4) OKR System Backup succeeds, creates recovery partition of about 8GB into the 12GB space, leaves empty space 4GB.

    5) OKR System Recovery, using key A, boots, proposes recovery and succeeds successfully. There is just one issue: no Reboot button after successful recovery. The recovered virtual computer boots well.

    6) the C: partition was destroyed, to simulate an issue. There is now unallocated space (28GB).

    7) Windows complains on boot, understandably.

    8) OKR System Recovery, using key A, did not boot, Windows obtains control and complains.

    9) OKR System Recovery, using F11, did boot and start OKR recovery, proposes recovery, but fails to recover.

    10) a empty NTFS-formatted primary partition (28GB) was created where C: has been.

    11) OKR System Recovery, using key A does not start.

    12) OKR System Recovery, using F11 does start, does not automatically propose recovery. I click on the System Recovery button, OKR complains that the system partition does no longer match, proposes to create new partition, and creates new system partition and C: into the empty formatted partition. C: shows now label Copy of C: . I close the window and this causes reboot.

    13) Windows boots, however it flashes a few times, obviously reparing its system environment. There is now system partition (500MB, old), system partition (500MB, in use), Copy of C: (27.5GB), Recovery partition (8GB), unallocated space (4GB).

    Any conclusions are yours.

    My positive only conclusions are:

    Technologies are in place: to back up C: using VSS, to restore C:, to switch to PE in the partition assistant,. to boot into PE which is contained in the AOMEI recovery partition (here 8GB). Not in place is adjusting contents of system partition (500MB).

    OKR never crashed. OKR always succeded or failed within reasonable time and with a corresponding message.

    PS some Windows terminology is as following and is criss-crossed.

    "system", "system partition" is the partition that is booted by BIOS and contains Windows boot loader. (we would call it boot)

    "boot" is the OS partition C:. which is booted from "system" by Windows boot loader. (we would call it system, but it is the opposite).

  • edited January 2016

    jürgen, regarding your issue from #0 #2 #5, the space created by OKR, 11.5GB, is too small.

    The lightblue screen #2 with choices Windows 10 and AOMEI OKR environment is right. This step is correct for doing recovery (but not for creation of Recovery partition).

  • Thanks Peter,

    the space in #5 was created by OKR.

    I could use a normal Windows Backup, Acronis Backup, Clonezilla, hdclone, linux dd..

    But I was looking for a easy Software to use.

    Lenovo as an OEM seem's to use OKR and they have a working solution..

    Techsupport has the log files and maybe there 's a update we can use in the future.

  • edited January 2016

    #0 #2 #5 yes I knew OKR did 11.5GB at #0 and failed for this reason at #0 #2 #5. OKR made mine 7GB when 8+GB was better (I gave it 12GB ) I suggest try making the space larger manually and proceed, to see it further. That test thinkpad is broken anyway. You could also try your Gen1 VM with firmware=BIOS. I will try a VMware firmware=UEFI later today.

    Actually on my system 8.21GB was allocated as AOMEI Recovery Partition and 5.43GB was used, 2.79 was free.

  • edited January 2016

    I did a few experiences

    14) OKR creates empty space 8.09GB and fails to create partition. Sometimes empty space needs to be increased, that is C: decreased by 500MB. Sometimes simply reboot and run OKR again.

    14A) The recovery partition of 8.54 GB has contents of 5.43 GB only. It would make sense to preflight contents, to calculate its size more smaller. Preflight would make the creation a bit slower, but it would make sense.

    15) I enter recovery and it works well.

    16) I delete partition C: and enter recovery, it fails. See picture for the situation of deleted partition C:.

    17) I decide to create a partition where C: has been and enter recovery. It complains that the partition is not the original one, and recovers both system and C: into the partition space - it does not use existing system partition space for system. And, the volume label is now Copy of C instead of C. And there is old system partition and current system partition.

    18) Because the AOMEI recovery partition is created as logical partition, I try to convert it to primary. Primary makes more sense, and primary could be set Active. However now the computer sticks at the F11 message on boot, no matter I press F11 or not. Obviously F11 is handled in the MBR and in addition does not go by the partition table, but by direct sector address to the AOMEI recovery partition.

    I then repair the MBR, using either bootsect /nt60 c:, or AOMEI Partition Assistant and it boots into Windows10.

    19) I decide to set the primary partition active, and to my positive surprise it easily boots into OneKey Recovery.

    20) When I do recovery, it creates the MBR with the F11 phrase again, and it does no longer boot, I repair MBR see point 18 for all this.

    21) In the end I delete all partitions for a proper factory reset, except AOMEI Recovery partition, make the AOMEI Recovery partition active, boot and recover again, to system and Copy of C. I repair MBR again, because of the F11 issue.

    22) Now booting always proposes Windows 10 and AOMEI Onekey recovery with timeout xx seconds. After xx seconds it boots into Windows 10. This behaviour is in BCD.

    I change this behaviour in the advanced system settings of Windows10, and it boots directly into Windows 10.

    There is a lot impressively well done and would be useful, but it does not always work. There are difficulties, that require manual repair, and that repair can be done.

    It is very interesting to analyze, and learn a lot about bcd and boot, and can be overcome. For example, it should recover even when C: has a new volume id or is missing, and should not depend such heavily on the system partition. That's what factory reset would work. Ideally factory reset can be called from the BIOS settings, or from an emergency CD.


  • Hi,

    i had a request today to prepare a new Thinkpad T420 with Windows 10 for Demonstration purpose.

    So i had a clean Install of Windows 10 v1511 to the harddisk.

    The disk is a Intel 160GB SSD, the partion used the hole disk.

    Before installing OKR i receized C:\ down to 85GB.

    The unallocated space was exact 64GB (65535MB).


    Then i installed AOMEI ..

    There was no reboot required now, and the software created a own partition for recovery and took a online backup while Windows 10 was running.

    No reboot at all, and no backup within the AOMEI PE systems.

    Now this look fine for me.

    Peter has tested a lot of option (several failures and restores), thanks Peter.

    I wasn´t able to extend the AOMEI Partition to take all of unallocated space...

    Next i did a restore of Windows 10 under normal conditions (had some Apps installed)

    I started the recovery within Windows 10, AOMEI did a reboot to WINPE ... starting a restore and after some minutes the Thinkpad is back ...

    This looks fine.

  • edited January 2016

    thanks for the report, and you can't extend because the AOMEI recovery partition is a logical partition inside the extended partition. It depends on which Partition Manager you use, some would silently increase the extended partition and allow to extend the logical partition. There is no reason to increase the OKR partition after it is created. See below.

    Please be cautious, if you move the AOMEI recovery partition high, then F11 may not work any more.

    On your thinkpad I would reserve not 64GB, but about 12GB, just enough to make it not fail (or let OKR reserve space, fail, and then decrease C: by 0.5GB manually, which increases the unallocated space by 0.5GB).

    And as

    14B), the OKR partition should be created as high as possibly, given after it is calculated properly. Maybe it calculates better when we make the page file large....

  • edited January 2016

    17A) my C: had a volume name of CAM, and my system was called SYSTEM, with drive letter S. After OneKey recovery in the specified way not into the original partitions, my C: got a volume label Copy of C, and system got a volume label Copy of S!

Sign In or Register to comment.